Needing Help with Ardu

We have a small group of us here at the shop who are all drone guys. Must of us are fairly versed on Betaflight and DJI, but could use some help with Ardu. Anyone in the Sherman or Dallas TX areas willing to help our group out? If so feel free to give us a call at 903-819-1452 or email at:

Chris. What type of help do you need?

Hi Dave,

Thank you for saying hi. Sorry been a while on my reply but the Corona thing has us pretty busy planning.

My/our (small drone group at office) is we are all new to the Pixhawk/APM technology. We have backgrounds in both DJI and racing drones/Betaflight.

I have 3 Pixhawk related drones:

  1. Daya 550 Pixhawk

  2. Tarot 680 Pixhawk

  3. Tarot 680 APM

Have bought everything used and in the process of sorting everything out. Have managed to load latest rev off of Mission Planner (MP) and have managed to get all of the motors to spin up while in MP with USB cable on the bench. Drones 1 and 2 are bound to a Taranis Plus XD9.

Problem 1 – Daya 550 everything up to and including arming is working. When I went to test flight it tipped over (not a flip) but a gradual tipping as throttle is added.

Problem 2 - Tarot 680 Pixhawk, I am getting a: FS_TH_Value error and unit will not arm under the control of the Taranis Plus XD9 controller.

Thank you in advance,


For #1 did you do a motor test? Did you make sure they rotate the proper way and in the proper order?

For Prob #2 You need to make sure the FS_TH_value # is less than your lowest throttle value. Did you perform a radio calibration?

Hi Dave,

Re problem number two listed below. Yes I did perform a radio calibration but did it again to make sure based on your question.

I still get the Check FS_THR_Value error.

I went to, Config, then to Full parameter list and the following was found:

Value Units Options Desc

976 PWM 925 1100 The PWM level in microseconds on Ch3 below which throttle failsafe triggers.

Tried changing this number but apparently did not take it? Do I make a change in this list, if so how to save?

Is this the number presented after calibration, there Ch3 is saying 982 2006? Where do I find Ch3 PWN microsecond stat?

Thanks… Chris

Hi Dave,

Re number 1 below:

Yes did a motor test but did again to make sure. All motors spinning and in correct direction. If I do a test motor in sequence, while checking a motor diagram they run 1, 4, 2, 3. Starting at motor 1 and go counter clockwise (motors on drone not prop rotation).

I retraced all wires from Pixhawk to ESC’s to verify, motor 1 plugged into Main Out 1 on Pixhawk, 2 plugged into 2 etc. All are correct.

I can give you a call this afternoon if you’d like to walk through these things that you’re finding

Well thank you for that offer, let me check with the work situation and then suggest a day and time.

Thank you.

Would tomorrow morning work, maybe around 10am CT?

Cool I will give you a call tomorrow

Hi, I’m kind of new to Ardupilot and I have a fairly big quadcopter with a PixHawk flight controller. I downloaded the firmware from Ardupilot and once I was all done I checked the motors and they spooled up so I turned the drone off and took it outside. After I turned on and armed the drone I started giving it power slowly but every time I get to around 75% throttle the light on the PixHawk flashes red and yellow the. The light turns off and the power cuts. I don’t know if it’s the PixHawk or Ardupilot but if anyone has any solutions it would be greatly appreciated

Thanks in advance


There is not much we can tell you unless you provide a .bin file from the Pixhawk.
Have you followed the setup procedure in the documentation?
Have you calibrated everything?
Have you read through the Tuning Wiki?

Did you calibrate the ESC’s?

The more information you give us the more we can help.
From what you have said so far I can only assume you have not done one or all of the above.

I did all of that except for the tuning I went into the Params and checked some of the stuff and thankuu you for the reply

Dave. Just started to go through tuning process and of f to a great start. Could not enter Mot Bat Volt Max into cell and hit something and now both Bate Max and Min lines are missing. Know how to get them back? Thanks Chris.

You should be able to refresh the parameters. Or disconnect from the flight controller and then reconnect

AHRS I am assuming is gps related as I am indoors and not seeing sats.

Well still missing two lines but think I am making progress. Disconnecting FC and refresh did not work.

A couple audible issues fixed, one left to go: 3D Excell Calibration needed.

On Flight Data screen: Bad AHRS

While it did not yet arm the old problems appear to fixed… LOL

I would bet that will go away once compass is calibrated, accelerometers calibrated and you have a good gps 3D lock

Also no RC Receiver, it has a receiver and is reacting to transmitter?