Servers by jDrones

My 1st Rover Project

arducopter

(David Boulanger) #63

Give me an hour or so. Maybe less


(Mus) #64

No problem, thank you


(David Boulanger) #65

I looked at the logs. Very different than what you see with the more advanced controllers. I’ll do my best. Can you describe what it is doing wrong, somewhat good, and good?


(Mus) #66

in manual mode everything is perfect. once I switch to auto its a constant backward and forward motion in a small space. the speed seems maxed out when going forward and reverse. sometimes it drives straight, wheels constantly locked pointing right and goes around like a circle. the rover seems confused and angry to say the least. in the steering mode it was also a nice drive, seemed a bit sluggish at times but overall acceptable performance.
main issue here is auto.


(Peter Hall) #67

its just doing the same waypoint over and over again

23.669s - init home
141.148s - Executing command ID #16
163.411s - Executing command ID #16
163.412s - Resetting prev_WP
241.984s - Reached Waypoint #1 dist 0m
241.985s - Executing command ID #16
279.53s - Executing command ID #16
279.531s - Resetting prev_WP

Not sure what would cause this, maybe a better test of the autonomous capability would be to try a RTL. Arm it and drive it somewhere in manual then switch to RTL mode it should return to where you first armed it. Its sort of like a single way point auto mission but should show if the navigation controller is working properly


(Kenny Trussell) #68

If it drives properly in Steering mode, then I think your throttle and steering channels and RC channels must be set correctly (as far as reverse or normal). If you have the rover far from WP#1, and switch to Auto, does it drive reasonably straight to waypoint 1 before then going crazy trying to keep going back to WP#1?


(David Boulanger) #69

I see a possibility of a lot of tuning issues. Cruise speed and throttle. No FF on the STEER2SRV parameter. The sluggish steering in Steering may be the fact there is no FF in the steering. Cruise speed may be faster than it can go. I saw the forward and reverse stuff going on and I wonder if the GPS is not accurate enough to give proper readings. You may want to try the stable release of 2.50 at some point. The people helping you here have a wealth of knowledge and the problems will solved.


(Mus) #70

thank you @iampete & @ktrussell

regarding the RTL mode I will also give that a try and report back with the log data for you to check out. also Kenny the rover typically just goes back and forth 95% of the time regardless of how close or far the rover is from waypoint 1.
maybe the tuning of this thing is completely off.

@David_Boulanger thanks David for your report. as you mention the FF is not available in tuning tab and is blanked out so I cant set it. Ultimately I think this is a tuning issue. The GPS is a standard one that’s from amazon so im guessing the GPS isn’t great either.

How can I try the 2.50 stable release? Im thankful for all your help and Im sure I will have this sorted in the end. Ive spent my entire day off on this, my wife isn’t happy with me! but im determined nonetheless!


(David Boulanger) #71

Go to the full parameter list tab on mission planner for the FF. You can find, not sure this is aproblem, AR2.50 on mission planner in the previous releases. Try RTL. I didn’t think of that one.


(Mus) #72

ive typed FF but nothings coming up, is FF short for something else? Is it STEER2SRV_FF? and if so what should I change it to?


(David Boulanger) #73

Yes. It is STEER2SRV_FF. Currently it is at 0. Try 1 and see if the steering is better. I’m sorry I was not clear on that


(Mus) #74

managed to get that changed. another thing ive noticed, when I put the switch down into automode on the flight modes its set as auto, but at the top it says current mode: hold.
modes

ive now spent the best part of 12 hours trying to sort this out and I still haven’t progressed any further. feeling a bit defeatist over here lol


(Mus) #75

@David_Boulanger @dkemxr @ktrussell @iampete guys I’m gonna make it worth your while and offer £50 to the man who can get this sorted for me. You guys have all put in the time but whoever can crack this for me I will send £50 via PayPal or direct to your bank account, whichever you prefer. The log files I’ve sent are all in this thread. Anything else you may need just let me know👍🏼

I’ve also decided to buy the Pixhawk as I’m thinking this might solve my current issues & maybe make life easier for the rest of you in checking out data logs etc. Please let me know which ones on amazon are any good, is this one ok or would you say it’s a fake?

Là Vestmon flight controller Pixhawk Multi-axis Fixed-wing Drone Flight Controller PX4 2.4.8 New Generation 32-bit Flight Controller https://www.amazon.co.uk/dp/B07H5QNF94/ref=cm_sw_r_cp_api_i_OsrrCb6SQFCRJ

I’d like to purchase from a reliable source.


(David Boulanger) #76

I think it may say hold because you have no waypoints downloaded into it or do not have a sufficient amount of satellites for a GPS aided flight mode.


(Kenny Trussell) #77

I agree with David because after a successful mission, it goes into hold. So, your rover thinks it is finished!

Don’t get discouraged. I had a lot of trouble at first with tuning. You have to get the low level loops, throttle and steering, tuned first. Then, you still have the NAV loop to tune. I don’t know anything about the older flight controllers and old firmware versions, but the pixhawk you are about to purchase should work way, way better, I think. You will be able to follow the tutorials by @rmackay9, using graphs of set point and actual, for instance.

I’m using a similar Pixhawk.

A couple of very important tips that I learned the hard way:

  1. It is important to have a working compass. Compass offsets and interference are real problems. If the MagX, MagY or MagZ values go up much when your motors run for example, you have a problem. Calibrating the compass is important.

  2. The GPS must be stable before you can begin operating in auto. I have found that I need to let my GPS run out in the open for 5 or 10 minutes before attempting an auto mission. Mine is an RTK system which takes longer to fully lock in.

Hang in there. My rover weighs several hundred pounds. I’ve torn down a wooden fence, torn up my actuators… I know where you are coming from. :slight_smile:


(Drew Sandlin) #78

I’ll echo what @ktrussell said, compass interference can be a real problem. The only good solution I’ve found is to physically separate the compass from the motors and any sources of changing magnetic fields.


(Kenny Trussell) #79

Here is an example of interference on my Youtube channel: https://www.youtube.com/watch?v=gBn3Eygo88o


(Dave) #80

Some of those default values are not the same as what I see as defaults on my bench setup which has the same FC as yours. I suspect because the “reset to default” function isn’t clearing them all. If you want to really set them to default load Arducopter or Arduplane then load Rover. You will have to configure everything again and re-do all calibrations. It would seem that you do need to reverse chan 1 as previously discussed so do that 1st.

And as some of us have suggested mounting the GPS/compass module on a stand for some isolation can help. Even a little bit (~50mm) can help.

Or if you have already bought the Pixhawk abandon the APM effort and wait. I’ll be getting a new Rover on the road this week with a PixRacer. Well, on the floor in the house anyway as it’s -21C and snow covered here right now.


(Mus) #81

@David_Boulanger @ktrussell @MisterMower @dkemxr thank you for all your advice. I will take everything into account & start from scratch with your knowledge to check along the way.
I’m questions wether upgrading my gear to the Pixhawk 2.1 with The Cube & Here+ V2 will solve my issues I’ve been facing, or just stick with the APM & try to get it working. Makes me question is it the hardware that’s letting me down or my complete lack of understanding.
Basically will acquiring the new hardware make my life easier & finally get this rover to follow some waypoints in auto mode?
If it makes my life easier I will have to put together the money which is around £350 & just buy it. If you guys have any solid sources from where to buy “I know there’s many fakes on the web” then your help in purchasing from a reliable source would be appreciated


(Kenny Trussell) #82

I have changed a few things related to the GPS RTK communication and am way overdue updating my videos but all the items I bought when I got started with my mower are listed in my comments on the 1st part of an overview video I recorded months ago. I was a total newbie, but I got lucky and all the parts worked as prescribed. I am not saying these are the best parts. It’s just what I used. I also didn’t have any motor controllers to buy for my project so I can’t advise there. Click “show more” to see the list below this video: https://www.youtube.com/watch?v=kyI7HjmpcVM

Looking forward to hearing more about your project.

And I don’t think you need an expensive GPS to solve your problems. You can worry about GPS accuracy after you conquer your control issues.