Servers by jDrones

My 1st Rover Project

arducopter

(Mus) #1

Hi Everyone. I’ve decided to build a APM Rover from scratch and so far so good. I have purchased a rover & have successfully added the APM 2.8. I have wired the components as follows:

image

Because the transmitter is only a 2 channel I have now ordered the Flysky FS i6 for more channels to also provide the option to switch to auto mode once I setup a flight plan on Mission Planner.

What I’ve noticed is that it says on many tutorials that you can’t power servo’s and ESC’s through the APM but oddly enough I’m able to do this. Is this normal?

When I use power from the lipo battery directly into the ESC which then powers the APM it doesn’t function as well as when I power everything via the APM “which like I said you shouldn’t do”
I’m wondering why this is happening?

Any advice would be appreciated. Thanks in advance


(David Boulanger) #2

I seem to remember , its been a long time, that with a APM 2.5 I removed the JP1 jumper. Used a power module to power the APM, telemetry.GPS, etc. And a BEC plugged into the servo rail for the servos. This prevents brownouts from possibly occurring. Best I can remember from 4 or 5 years ago.


(Dave) #3

David is right. The JP1 jumper routes power to the servo rail. Removing it isolates it allowing another source to power the outputs. Either power the rail from a BEC as he suggests or power the servo directly. Everything you need to know about powering that old APM is here. Note the 1st illustration.
http://ardupilot.org/copter/docs/common-powering-the-apm2.html_emphasized text_


(Mus) #4

Hi Dave. Thanks for the info. Could you please send me the link again as it’s not working on my end. Thanks


(Mus) #5

Also wanted to hear everyone’s opinion on the following;

I’ve seen theee stepwdown converters and was thinking of buying this one:

Basically my thought was to have 1 Lipo to power everything rather than havin 2-3 lipos.
In the manual it says the following specs for the ESC:

The step down module has an output of 20 amps but they recommend going up to 15 amp Max. Not sure if going through the module would be enough to supply a
consistent amount of power to the ESC & Servo?

So I was thinking of buying one of these:

Then having a parallel output from the lipo for 2 devices. 2 step down modules setup before each device. Would this be a realistic option to increase drivetime & keep the lipo battery’s to a minimum and just use 1?


(Dave) #6

Odd. Try this link. If it doesn’t work simply Google “powering APM” and the archive should be 1st on the list.
http://ardupilot.org/copter/docs/common-powering-the-apm2.html


(David Boulanger) #7

Why not just get a Castle Creations programmable BEC? they come in 10 and 20 amp


(Mus) #8

At last I’ve managed to get everything working. I’ve also worked out the wiring for the Flysky FSi6 which I received today and have it wired into the apm.
Also I’ve added the switch to change to auto once I have created an auto mission and saved it to the apm.
I will configure the transmitter on my pc this evening and try the rover again once I’ve done that.

One thing that just isn’t working is the telemetry. It’s this one:
powerday®3DR Radio Wireless Telemetry Kit 433Mhz Module for APM2.6 APM2.7 Pixhawk PX4 https://www.amazon.co.uk/dp/B00Q7US5NG/ref=cm_sw_r_cp_api_i_mAopCbWDQDJSY

There’s always a blinking green light on both sides. I have tried installing the latest driver and also previous versions. Also tried windows driver reassignment which someone said might work and still there’s no communication between them. Not sure what I’m doing wrong or maybe they’re just so cheap and don’t work properly? Any advice is appreciated


(David Boulanger) #9

Green blinking light means they are not connecting to each other. Do you have a FTDI cable?


(Mus) #10

I’ve seen these. I haven’t got one. It’s where you plug it in via a usb and recode the data to match. I might need to buy one of these to make this work.

The telemetry for now isn’t a major issue I can buy one of those FTDI cables soon.

What I’m having trouble with is making a switch on my transmitter show that it’s active in the mission planner radio calibration.
All other things like pitch & throttle are visible when I move them but when I flick any of the switches on the Flysky FS-i6 there’s no movement in mission planner. I have made channel 5 on the transmitter for the switch that I want to use to toggle between manual and auto & plugged the wire from the receiver channel 5 into the APM input number 5.


(Dave) #11

Did you set the MODE_CHAN parameter to 5 if that’s where you are connecting flight mode? Default is 8 as I recall.

You should really get a new up to date Flight Controller. Many people that could help you have retired these APM’s years ago. Compared to what you are prepared to pay for this Rover it’s an insignificant expense.


(Mus) #12

Yes I have connected it in 8 which is default like you said. Also went into MODE_CH in the Parameter list and the value is also set to 8.
I have now managed to make the switch toggle between manual and auto in the Flight Modes Tab on Mission Planner but when I click Save Modes it says “Error Setting Parameter”

Not sure if it’s saved it or not


(Dave) #14

Well, there are Flight Mode parameters that will tell you what’s configured.


(Mus) #15

Managed to get the flight modes saved. Then I went into flight plan and planned something very basic that has 6 waypoints in a square around my garden.
When I turned it on I could use it in manual mode.
Then I flipped the switch into auto, and all hell broke loose! The rover went berserk and was moving very sporadically all over the place.
I have set the waypoint altitudes to 0 as it’s on the ground. What could be the issue here? Thank you


(Dave) #16

It could be several things.Compass or GPS problem will do that. Did you run all the calibrations particularly Radio Calibration? Get the telemetry working so you can connect to Mission Planner and see if there are any error messages displayed. Or put it on a block with a long USB cable.Or review the log and see if there are any messages there. You can post a link to the log and someone interested in reviewing an old APM log may be able to help. Posting the parameter file might help also but the log is more useful. How to manage logs:
http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html


(Kenny Trussell) #17

All these things Dave mentioned are certainly #1 priorities, but then you have to tune speed and throttle, steering, and navigation. Use this series of tutorials (NEXT at bottom will take you through each part): http://ardupilot.org/rover/docs/rover-tuning-throttle-and-speed.html

Big dose of patience required!

I’m enjoying your progress!


(David Boulanger) #18

What version of the Rover code are you trying to us with the APM? There is usually a progression of tuning that must be done before performing auto missions. A flash log would help a lot also.


(Mus) #19

@dkemxr @ktrussell @David_Boulanger many thanks to you all for your advice. I will check these once I’m away from work & will do my best to tune the rover which will hopefully resolve the issues I faced yesterday evening when my rover literally turned into a lunatic.

I’m not sure what Rover code I’m using as I’m not at my pc right now. How do I obtain this info once I get the chance to check it out?

I will be happy to provide log files which you can analyse to see if there’s any problems or setup/tuning options I may have overlooked. I’m sure there will be things that aren’t set correctly.

Ultimately if I do purchase the following Pixhawk 2.1 with The Cube & Here V2 would it be a smoother process than dealing with the APM 2.8? And if so why?

Thanks


(David Boulanger) #20

I think Rover 2.5 is the last code to run properly on the old APM boards. The Pixhawk boards run like 4 times faster, have more memory and interfaces on them. A pixhawk one would be a huge improvement even and allow you to run the latest Firmware and take advantage of all the features available. You most likely can use your existing Telemetry and GPS module.

You can use mission planner to tell what code you are using. But the fact that you are not sure indicates to me, just my opinion, that you may have just clicked on the latest stable or RC maybe.


(Mus) #21

@dkemxr @ktrussell @David_Boulanger Hey Guys. I have managed to find the time to try the way-point missions again in the garden. This time the rover didn’t go crazy like before but once put into auto just drives in a straight line. the speed is fine but im not sure why its not following the auto mission i have set. I have provided some log files and would really appreciate you guys having a look when possible. Thanks in advance and I look forward to hearing from you.

2019-01-20 10-23-45.bin (65.5 KB)

2019-01-20 10-14-23.tlog (419.0 KB)