Servers by jDrones

My 1st Rover Project

arducopter

(Mus) #243

Failsafe Trigger 0x1 just popped up


(Dave) #244

No worries man we are going to get that Rover going. I’m not at my bench right now though so can’t walk you thru it. There is a failsafe screen in MP. Disable everything (Throttle, low battery, etc). Geofence is probably disabled already But you need to check.


(Mus) #245

Thank you so much. I have found fence:


(Dave) #246

Good, no fence enabled. The other related parameters don’t matter.


(Mus) #247

And failsafe:


(Dave) #248

OK, disabled there also. Have to investigate the 0x1 failsafe. I notice from your HUD that its not level. Why is that? Did you do an accelerometer calibration?


(Mus) #249

yes I did the calibration for the accelerometer. when I calibrated the pix and compass I had them both side by side on a box to calibrate them accurately. now I have the compass at the front of the rover and the pix at the back. could that be the issue for not calibrating them in the same position that they will be used?


(Dave) #250

Yes, could be.It needs to be calibrated on the vehicle. Re-do this. I would perform the 6 axis cal which can be a bit challenging with a rover but do-able. At a minimum do the single axis “level” calibration. You are using telemetry for connection now right?


(Mus) #251

I can do the wizard again and recalibrate the axis for pix and compass. that might be the cause of the error. I will do that now via telemetry but ive usually done it via usb but the wire is too short to perform a calibration whilst holding the rover. lets hope it can be done via telemetry


(David Boulanger) #252

You can click on the red EKF if it happens again and get a good idea real quick what the problem is.


(Mus) #253

When I tap EKF:

velocity_horiz Off
pos_horiz_abs Off


(David Boulanger) #254

Are you in a good environment for testing with a good GPS location estimation. I get this error sometimes when I first boot up but then it clears.


(Mus) #255

hey David. seems to have solved over time. I actually rebooted the pix and began again from scratch, for the 100th time :wink: everything is back to normal except for the arming via the transmitter. I did it fast before but now I cant seem to get it working. My switch on my receiver is on CH5, on MP there isn’t an option for RC5_OPTION but only RC7_OPTION is coming up. how did I manage it the last time im not sure

@dkemxr


(Dave) #256

What? What do you mean “from scratch”? You were almost there. Don’t bother with the Wizard, all you needed to do was a accelerometer calibration. I don’t know what condition you are in now.


(Mus) #257

only problem now is the arming switch via transmitter. the pix is fine I even took it out for a spin, all is working as when I switch on ive bypassed the arming requirement so its instantly armed for now, but would be nice to have the arm/disarm feature again. the switch I used before was on CH5 but I don’t know how I managed it, I looked over your instructions again but couldn’t figure it out this time.

also managed to tune the rover when in auto mode to move at a slower speed. I used a single waypoint but the rover cant seem to keep the a straight line and ventures off to the left usually and sometimes to the right. sometimes it seems like it might complete the waypoint but but always ends up steering off course


(Mus) #258

all sorted now. all that’s left is to get this rover to do an accurate flight path. could you send me a screenshot of your tuning tab please? the one in config tuning > basic tuning. seeing as we have similar style rovers maybe I can input what you have and it might work


(Dave) #259

From what you have reported its not “all sorted”. You need to solve one issue at a time before moving on to the next. Performing an Auto mission should not even be on the radar.

Other than turn radius my parameters are at default. Wandering a bit to a waypoint is typical pre-tune, what you are reporting is “not working”.


(Mus) #260

At this point what would you advise I do next?
What checks or mods should I make to eventually get me to the point of an auto mission? I’m off to bed but anything else I need to do please let me know and I will continue tomorrow when I get the chance. Have a goodnight & speak soon👍🏼


(Mus) #261

I think I’ve figured out a big problem why the rover isn’t following the waypoint.
When I turn into steering mode the steering is off & the wheels lock to the left. This is why it’s not going straight I think. From what I’ve understood the steering mode is a good representation of auto mode.
I need to tune this in steering, on the transmitter the trim is dead on but on the pixhawk it’s off.
Any tips on what to fiddle with would help allot. Thanks in advance

@iampete @David_Boulanger @ktrussell @dkemxr


(Peter Hall) #262

sounds like you need to reverse your steering servo and your RC steering input