Servers by jDrones

My 1st Rover Project


(Dave) #223

Yes, similar chassis. What it is hitting? This was also a problem with the Redcat Crawler I have with the Tie bar contacting the Differential case. Redcat came out with a revised bar and knuckles (which came with the truck) to correct this and add more steering angle. Now it’s limited by the tires contacting the shock springs which required some steering limit in Ardurover. It has a turning radius (TURNING_RADIUS parameter) of 1.2m which isn’t great but for a crawler I suppose it’s typical. Lockers have a lot of tire scrub while turning which doesn’t help. My other truck turned very tight but it was a 4WD Basher and not the greatest vehicle for a Rover.

So you would have to find something similar either from the manufacturer or aftermarket. I’m not familiar with that truck but some of these are built by the same manufacturer and re-branded so maybe it’s possible. I found that to be true with my previous Rover which was a HobbyKing truck.

(Mus) #224

Regarding arming via the transmitter which option do I select for the channel to be able to do this? I’m flight mode where there’s a scroll down tab beside each channel which one is that? Thanks

(Dave) #225

Not there. 1st make sure ARMING_REQUIRE is set to 1 (enable) and ARMING_RUDDER is set to 0 (disable) then set an RC channel option based on which switch channel you have setup on your radio to activate it. Any unused channel can be used; in the attached example I am using chan 7. So select a swicth on your Transmitter to use for arming (not the mode switch) and configure this in the radio, then make the parameter changes.

BTW-Rudder arming doesn’t make a lot of sense for a Rover anyway as it can run the steering servo to the full stop and holds it there until it arms. Not good for the servo particularly if it’s not arming and it’s held there. So Tx switch is a better option.

(Mus) #226

Ok, please check the following & I will program it like this if you think it’s suitable:

Arming_check set to 0
Arming_require set to 1
Arming_rudder set to 0
RC7_option set to 41

(Peter Hall) #227

probably a good idea to have at-least some arming checks, if your in doors you can just untick the GPS one

(Mus) #228

I’ve ticked all except GPS & Hardware Safety Switch. Is that ok?

(Peter Hall) #229

yeah, so long as all is not also ticked :wink:

(Mus) #230

With your help I’ve set up the arm/disarm from my transmitter. Thank you for making it simple for me it works perfectly. So now that’s done may I remove the switch from the pixhawk? The little button you press that arms or disarms?

(Peter Hall) #231

(Dave) #232

Yes, not needed. Personally I think they only belong on Planes. On some multirotors I have seen people reach thru the props to press the button (bad strategy) and on a Rover there isn’t much danger in any case. After you get everything sorted you can put it back if you like.

(Mus) #233

Ok so I have disabled the BRD_SAFETYENABLE now and removed the switch. The BRD_SAFETYOPTION is set to 7 as default. Should I untick the following or keep them ticked?

(Dave) #234

That doesn’t matter if its disabled.

(Mus) #235

Have you done an ESC calibration for your rover and is this an essential process to perform?

(Mus) #236

I’m so close now, everything is working with arming, disarming, everything’s working like throttle, steering etc. I’ve even got the telemetry working😁 But right now the pix has a solid red light on it which doesn’t go away after rebooting. Any ideas?

Solid red after looking it up means Error😩

(Dave) #237

Right. What is Mission Planner reporting? Either in the HUD or messages.

I wouldn’t worry about ESC calibration right now. Some of these ESC’s don’t enter calibration mode upon power up with max throttle. I don’t think mine does.

(Mus) #238

Where do I look for what Mission planner is reporting regarding errors? The solid red light is obviously not good but I don’t know where to look on MP

(Dave) #239

Either right in the HUD (upper left window from main screen) or on the messages tab selected below the HUD. Watch the messages screen, arm it and see what it says.

(Mus) #240

(Dave) #241

You are getting close. Turn off all failsafes and make sure fence is disabled. All this stuff can be re-enabled after you are successfully driving.

The worst that can happen with a Rover isn’t very bad! It takes off and you run it down or it hits something.

(Mus) #242

Sorry but how do I turn off all failsafes & what is fence? Sorry to ask so many times