Servers by jDrones

My 1st Rover Project


(Mus) #263

its like it only wants to go left or right not straight.
after reversing its going straight but wheels are moving left and right fast to keep it in line, actually looks hilarious

(Mus) #264

ive reversed them and tried different orders for reverse but the wheels are still shimmying left and right but the good thing its going straight.

steering control rate in PID was too high. ive lowered it and much more stable now

(Mus) #265

as you all can see the headings are spread out quite a bit.
the only heading that seems to be pointing in the right direction is the orange “Direct to current WP”
The Green “Target Heading” is well off. rover wants to drift to the left constantly. GPS satellite count is at 15

@iampete @David_Boulanger @dkemxr

(Peter Hall) #266

Now its going straight you can follow Randys tuning video, then you can try Auto.

(Mus) #267

I tried that before but when I select PID Desired and PID Achieved I get no movement when I move the steering or throttle

(Peter Hall) #268

you have to set the GCS_PID_MASK to send back the thing your interested in tuning

(Mus) #269

GCS_PID_MASK is currently 0, so I change these and then begin tuning?

(Peter Hall) #270

yeah, 1 is to tune steering and 2 would be to tune throttle

(Mus) #271

I forced external compass enable which helped in making the rover more accurate with heading to the waypoints. I finally completed a successful auto mission in my garden😁 the accuracy of the rover isn’t amazing but it done the job and steering and throttle are working very well now.

If I upgraded the pixhawk to 2.1 with the cube & here gps how accurate is it able to be? I want it as accurate as possible, like cm

(Peter Hall) #272

you’ll have to use RTK gps to get centimetre accuracy, cube wont make any difference, you will probably see a small improvement with the here GPS.

First think to do is to make sure its getting to where it should with the steering closely matching the desired rates. And looking at the L1 controller. Then you will get the best possible accuracy out of your current setup.

(Mus) #273

So I could bypass the cube and a new pix and get the RTK system & it will work?

What is the L1 controller?

Once I’ve done a decent run I will upload a log file for analysis. I’m sure you & the rest of the fellas will find something to grill me about lol
Right now I’m just over the moon that it’s functioning in a normal manner even tho it’s not so accurate, todays a good day🙏🏼

(Peter Hall) #274


(Mus) #275

Thank you for the info, will look into purchasing the RTK in the future; Will read through this and tune the L1 controllers to hopefully give more accurate waypoints whilst in auto.

(Mus) #276

So this would do the trick:

(Peter Hall) #277

probably, i’m not very familiar with RTk GPS. As ever the wiki has lots of info

In particular it says this:

The base station needs a certain amount of time to meet the accuracy requirements of your input. Testing shows that, in an open area without shelter, to achieve the absolute accuracy of 2m takes a few minutes; to reach the absolute accuracy of less than 30cm takes around an hour; to reach the accuracy of 10cm takes a few hours.

Personally RTK is not the first thing i would do, if you want to do surveys on uneven ground its not like you would get the rover to drive that accurately anyway. It really depends on you use case. For example you may not care that much that the rover is exactly on the waypoint but more that the sensor data your collecting has a accurate location stamp.

I would do some surveys your current setup first.

(Dave) #278

Add a small delay at each waypoint if you want it to actually attempt to reach the center of the Waypoint coordinate before it heads to the next one. Otherwise as soon at it’s within the Wapoint radius it will turn to the next one. You can reduce the Waypoint radius also but you will reach the practical limit of the GPS accuracy at some point and a smaller one won’t really help.

(Mus) #279

Is it me or is this thing temperamental?
Now when I turn on the power and the ESC and Pix start up there’s a solid red light.
When it’s done via the usb to the pc it works fine.
Seems it doesn’t like being powered up now without being plugged into the usb/pc…ffs😩

(Kenny Trussell) #280

Dave, I never thought about adding a delay at a waypoint. My big mower is actually doing well as far as reaching the waypoints before turning, but I still can see this being very useful at times. Thanks!

(Peter Hall) #281

Now this is the sort of thing a Cube would help with :wink:

(Kenny Trussell) #282

I see the wink, but, really, is the Cube a lot more reliable? I have been using a Radiolink Pixhawk similar to what @ArduNoob is using and I have not had any problems, but for future reference, is the Cube worth the extra money?