Servers by jDrones

My 1st Rover Project

arducopter

(Dave) #183

Change the connector or buy an adapter. I would solder on a new connector, adapters are another point of failure.


(Mus) #184

Good news all is I’ve managed to hook up the pixhawk & have everything working in manual mode. The switch from manual to auto is being detected by mission planner “flight modes tab” and changes when switched. Only thing is when I’m using the rover in manual mode and then hit the switch nothing happens & even with the switch in auto or hold or rtl I can still use it as if I’m still in manual mode.


(Sebastian Schürmann) #185

It is only a guess, but did you set the servo out functions to “RCINx” or “Passthrough”? This would explain why nothing happens when you change flightmodes. You should set servo out to “Throttle” and “Groundsteering”. But at least you know everything is working together.


(David Boulanger) #186

A flash log or even just a parameter list probably would reveal the problem.


(Mus) #187

I’ve now got it on RCIN7, it was on pass through before, but still when I flip the switch it doesn’t go into RTL mode and still allows me to control the rover after the switch has been flipped into a different flight mode


(Sebastian Schürmann) #188

You should read through the basic rover setup in the ardupilot wiki again.
The servo out parameters are numbered corresponding to the main servo outputs on the pixhawk. So you need to set the output where your ESC is connected to, to “Throttle” and the output where the steering servo is connected to, to “Groundsteering”. Any output set to
“Passtrough” or “RCIN” ignores anything coming from the autopilot and just reacts to user input via RC.


(David Boulanger) #189

Is Mission Planner indicating what mode you are in? For a simple rover with ground steering I think the default settings are pretty much spot on.


(Mus) #190

When it’s in pass through it all works.
When I select them for specific things they don’t work. For example when I choose ground steering that one works and shows movement.
When I select the one for throttle there’s no movement. And the switch is set to RCIN7 but this doesn’t switch the rover into that mode when I’m driving it so it needs to be set to something else.

Throttle shows movement when in RCIN3 but when I change it to throttle nothing happens on mission planner


(Mus) #191

Would anybody here be able to do a Skype call with me & take me through step by step from scratch? I will be happy to send some money for the help. I think this would be the easiest & quickest way to solve this


(David Boulanger) #192

When it is in passthrough the pixhawk isn’t doing anything essentially. Honestly I don’t think the system is armed. Post a parameter file if you will.


(Mus) #193

I’ve set the armed options to disabled so it’s always armed. I will post up my parameter file👍🏼


(David Boulanger) #194

so after the tweeting bird sounds it gives you a long buzz to tell you its armed?


(Mus) #195

Just got it moving, gonna try and get it configured now, I will update you soon


(Mus) #196

Just need to know what to set the switch to, currently on RCIN7


(Peter Hall) #197

this is the outputs, so your outputting steering on channel one and throttle on channel 4, and passing rc input 7 out on channel 7.

What switch is it your trying to set up?


(David Boulanger) #198

Ya. this is the first thing I saw. throttle on 4 with a really low PWM. Usually its set up on 3,


(Mus) #199

It’s the switch on my transmitter which makes it go from manual to a mode that I choose like RTL or Auto etc,

Throttle and steering are working, which one do I choose for the switch for auto mode etc


(Sebastian Schürmann) #200

You do not need to assign the flightmode channel on the servo out page.
And it does not really matter where you connect the servo/ESC to, since it is freely configurable now. The mentioning of servo 1 and 3 is just a historical reference to earlier Ardurover versions.


(Mus) #201

And your right on the Radio in it shows Radio 2 for throttle and on Servo/Motor out it’s on Radio 4


(Sebastian Schürmann) #202

There is a MODE_CH parameter in the full parameter list where you can change the flightmode channel.