Multi-point with RFD900 & TXMOD on TX16S

We are trying to setup a multipoint configuration with RFD900 radio modules. We wish to use a TX16S controller with a TXMOD module plugged in the back to control the UAV. We have found that the TXMOD wifi connection is very slow, so we wanted to add an additional RFD900 to connect to the rover via a USB cable.

The issues we are running into are:

  1. Although the radio modules are connected (flashing LEDs), the TX16S shows no connection.
  2. In the multipoint firmware guide, it’s noted that GPIO passthrough is not available, so we cannot send RC channels over PPM.

We have successfully connected two PCs to the rover at once, but we have not gotten the TXMOD working. Is this even possible currently? Is there a way on the TX16S to send RC via Mavlink without the use of the PPM port?

In this post (below) check the pieces about baud rate. There’s a setting related to WiFi baud rate.

Is just the slow baud rate the only thing holding you back from using the ordinary firmware with RC-passthrough? If so follow the guide to fix everything AND change over to using SBUS instead of PPM.

1 Like

AFAIK there is no support for that in EdgeTX.

Given how past attempts at integrating Mavlink into EdgeTX went your best bet would be to ask RFDesign to add PPM to RC override messages conversion to TXMod.

Do you mean no support for TXMOD in EdgeTX??
I’m using EdgeTX on a TX16S with TXMODs and yaapu telemetry script. SBUS too by the way, you want to avoid PPM if at all possible.

It’s the RFD multipoint firmware that doesnt support RC (PPM or SBUS) because there’s potentially no way of knowing which radio should be the source or destination or ignoring the RC. RFD could potentially put in an option for all that, but I cant imagine there is much demand.

Perhaps changing the baud rate will help. It takes about 5 minutes when downloading via wifi as opposed to the few seconds it takes using the RFD900X with a USB cable.

I thought using the multipoint software would be good because we can implement “swarm mode” later.