mRo x2.1 rev2 Radio issues

After update with the ChibiOS firmware 3.6-rc1 my Radio will not connect to MP. I decided to look into this a little more and noticed as long as the USB was connected the Sik radio connects the led flash red to green as normal. However it the FC is powered up via battery the mRo SiK Air Telemetry Radio V2 leds are solid red and will not connect. I did try setting BRD_SER1_RTSCTS to 0 but no change.

Note: when having issues a few days ago I did not notice the correlation between USB and Radio and visa versa…

so if the usb is connected and i select the Radio com port it works via the radio . remove the usb and power up via battery the radio fails. all works normal with Nutt.Chi-noraido-mOr.param (14.0 KB)

This sounds like the radio issue talked about a while back where some version of the radio will not work if they are powered on and communications starts right away. The radios when first powered on are in boot mode and so if they receive communications right away they stay in boot mode or something.


1 Like

Hi Mike, I will do more testing with a older raido see if I get the same connections issues.

Mike I think your right… if I plug in the battery I get solid red led on the radio no connection. if i plug in the USB without the battery I get green flashing and can connect. if I plug in the usb and then the battery at the same time then remove the USB I can connect with the radio to MP with the green leds.

Here is what I am seeing.

Now with the usb connected first and then the battery:

Definitely odd issue.

Remove the CTS/RTS wires from the connection.
Flow control handled via the Mavlink_radio packets, so no need for hw flow control. (also switch it off in the parameters)

1 Like

I will try that thank you.

" Solved" thank you Eosbandi removing the CTS/RTS wires allowed connection.

Then why does this module come with a six wires connector instead of 4? And why did you have to remove the wires when you could just switch it off in the parameters? I might be missing something here, but this doesn’t make any sense.

Changing the parameters did not work.

Maybe it’s the mRo radio itself that is getting confused about whether CTR/RTS should be used. There is a setting in the radio itself which allows this to be turned on/off. It’s shown in the first screen shot of the mission planner on this slightly old wiki page. I don’t know why there would be a difference but…