Motors arm but won't spin

I’m really stumped here. If anyone can help me here before I go completely crazy I would very much appreciate it.

All I did was change over the esc’s and that’s when the problem occurred.

This worked fine.

  • Pixhawk 2.4.8
  • Sunnysky x2212-13 kv 980 motors
  • Frsky X8R receiver
  • Hobbywing Platimum Pro 30a opto ( even removed the red wire on the servo lead )

I decided to replace the Hobbywing esc’s with EMAX BLHeli 30a

I calibrated each esc individually and all esc’s functioned fine through a receiver only

I then replaced each Hobbywing esc with the EMAX BLHeli esc’s. Red wire removed from all servo leads.

On start up Pixhawk booted fine. Pixhawk armed fine with solid green light on the Pixhawk. Upon throttle up motors did not spin.

On second try I reconnected the red wire on one servo lead to the receiver. Pixhawk armed but still motors did not spin.

I have also re bound the receiver several times and loaded different versions of firmware through Mission Planner including the latest version.

Please help if you can, going nuts here.

Thanks for your time and consideration.

Can you please run a motor test through MP and see if the motors spin when individually triggered.

Something is wrong. Even More problems. Through MP, I chose Setup > Advanced > Terminal.

Then I chose Pix4/Pixhawk > Connect

This is the error message I got

“Rebooting COM6 at 115200
Cant open serial port”

I’ve tried other COMs but to no avail.
Thank you for taking the time to help.

Are you connecting via direct cable connection to the Pixhawk or via Radio telemetry. If its the latter, I would try connecting via direct cable for troubleshooting. Also, what happens when you try to connect via the “Connect” button at the top right of MP?

Also, I would try a baud rate of 57600 and see if that fixes anything.

Hello … I am connected via direct cable. I’ve tried baud rate 57600 to no avail. I’ve also tried all the other baud rates. Thanks for the suggeation.

Would it be possible to re-load the firmware to the board?

That error in terminal means nothing. Even if you pick the same port as seen by Device Manager that error will occur. What are you trying to do with Terminal?

What happened with Motor Test? That is self arming no need to do it manually.

Have already done that and to no avail.

Sorry … I was thinking of testing the motors manually. Did take your advice and chose “Motor Test” from the MP menu. Would not work … error message that came up was “Command was denied by auto pilot” . That must mean something but not exactly sure what.

The safety switch needs to be pressed down for motor testing. If it says denied again, quickly switch back to the flight HUD and see what error it is saying.

Did that, thanks. Tested the motors and was able to get a tone sound. It seemed that the tones came only from one motor. Will Isolate the other 3 when testing for one.

The tone comes from the Pixhawk not the motors and the motors do not spin

Each motor should spin individually as you trigger them in the motor testing screen. The letters are as follows:

Motor A: Front Left
Motor B: Back Left
Motor C: Back Right
Motor D: Front Right

You might have to increase the throttle % input to around 10-20% to see any motor movement. If the motors still do not spin at 20% or more then there the Autopilot is not connected to the motors. Can you send a close-up picture of your autopilot hardware?

Here is the photo of the pixhawk I’m using. It is set up on a testing board and not a frame.

Do the ESCs/motors make any sort of sound when you unplug and plug the wire into the main out ports of the Pixhawk? Also, does the aircraft have a battery installed?

If there are no sounds when unplugging and plugging the wires back into the main out port then the ESCs are not getting power or you have plugged in the ESC cables upside down into the Pixhawk.

Here is a thought. Either I am missing something very obvious or … as a noob I bought this from Banggood at a good price. As time has gone on I’ve picked up it may not be “original” Pixhawk goods but rather clone. Maybe I should have gone with a product from Holybro etc and from a reputable dealer like GETFPV? I think I’ve got junk equipment here. Like they say , “If you pay peanuts, you’ll get monkeys”

ESC are plugged into the pixhawk correctly … ground wire (brown or black) at the top.

Ok, do the ESCs/Motors make any sound when you disconnect and reconnect them from the Pixhawk main out?

No noise at all. All red wires have been removed from the servo connection. ESC to Pixhawk

Interesting. That either means the ESCs are not powered or that they are not receiving any signal from the Pixhawk. Just want to double check that you have the battery currently plugged in and powering all the ESCs?

Next step might be taking out a multi-meter and measuring the voltage of the signal rail on the Pixhawk. This will let us know if those ports are still operational.