Motors arm but won't spin

upload a photo of the ESC, battery and motor wiring that you have in place for this test

1 Like

Sorry I couldn’t answer yesterday. New to this forum so there was a cap on the number of posts I was allowed to do in my first 24 hrs.

ESC seem to be fine … shows 4.97 volts. Signal rail show about 2 volts ± 0.1 volts. Not exactly sure what that means.

Have also checked out each ESC and gives a voltage of about 5 V. Have also run each ESC through the #3 output on the receiver only (not the Pixhawk) and each ESC and each motor functions well. Thought I’d isolate from the Pixhawk to see if the individual components were at fault. Also replaced the cable from the receiver SBUS to the Pixhawk.

I’m running out of things to check.

These are 2 photos of my test board. I have remove 3 of the ESCs so it doesn’t look too much like a rat’s nest. The second photo shows connection from receiver to Pixhawk. If I missed something please let me know. Cheers

1 Like

Brian, if you are still getting those denied by messages so for the time being, disabled all arming checks.
Move to the motor test page, press the safety switch, and raise % to 15. Than press on motor A and tell us results of that.

Hey @brian_b! No worries on the delay.

If I remember correctly, the signal rail should be outputting somewhere around 3V to 3.3V in order for the ESCs to “activate”. Can you measure the signal pin rail on the receiver and tell me what voltage that is outputting? Since that setup is working, I am going to assume you should see somewhere around 3.3V on the receiver’s signal rail.

Also, you say the ESC is showing 5V - what are you referring to on the ESC that has this voltage? It seems like you have a 3S battery - so I would assume its being powered at around 12-ish volts?

You are not going to see 3.3V on a voltmeter even if the PWM signal was at 100% (~2000µs).

Hey manavgandhi17, Thanks for you comments. The signal rail on the Pixhawk is showing about 2.5V which is definitely less than 3.0 / 3.5 as you suggest it should be. The signal rail on the receiver is consistently showing about 4.85 volts which seems to be fine spinning motors attached to that rail. When I said the ESCs are showing 5V, that is the reading from the servo lead on the ESC. I checked each ESC thinking there may be something wrong with one of the ESCs. But they seem to be fine.

Hi Gal … I’ve done what you suggested but unfortunately it did bring any favourable changes. Thanks for your suggestion.

I’m beginning to form a conclusion here and its not placing much faith in the so called “Pixhawk”. Perhaps another manufacturer may be the solution. I think the “Pixhawk” itself has gone faulty.

Have you got
Post you parameter file, you can export you params from MissionPlanner to a .param file.

1 Like

Hey Brian,

One last thing before we end up determining this is a bad Pixhawk. Can you post the parameters file?

Also, make sure you have selected the correct frame type in MP.

pixhawk June 6 2020.param (17.8 KB)

Here is the parameter file uploaded. I’ve tried Shawn’s suggestion but it didn’t change anything. Thanks.

You have MOT_PWM_TYPE = 4, which means you are using the DShot150 protocal. I assume you want normal PWM - so change that value to 0. Also, your servo outputs are not defined to be connected to specific motors. They should be as follows:


Also set the AUX Servo ports back to no value:


Yeah most of the parameters in this file are set for DShot Protocal with motors plugged into the AUX port - where you flying with DShot ESCs before?

If the changes above don’t fix your problem - I would highly suggest re-setting all parameters to default and upgrading the firmware to the most recent version. I suspect that there might be other parameters that were changed that might be the root cause of this problem. Might take a little bit of time to set everything back up - but it is always well worth the effort once its up and flying.

You are the MAN !!! Problem solved !! Thanks for being so tenacious and not giving up !!! Thank You, Thank You, Thank You. I can now live in peace thanks to you!

Sounds good, hopefully you can have this bird up and flying soon!

Also, I just noticed you are using BLHeli ESCs - so plugging the motor plugs into the AUX 1-4 ports (without changing any parameters) also would’ve worked too (I think). So, if you want to change all the parameters back to what they were and plug the ESCs into AUX 1-4 (instead of MAIN 1-4) that should work too.

You would need to change the parameters back to what they were before - as follows:


This isn’t required. It is up to you if you want to use PWM or DShot150. DShot seems to be more “robust” than PWM and others have recommended DShot over PWM in the past.

Does this mean that only SERVO9-12 are DShots? SERVO1-4 are PWM. Or this is dependet on the flight controller. I have the Kakute H7 V2 with the Tekko32 50A 4IN1 ESC which a DShot ESC. And the ESC and FC is prewired from factory to SERVO1-4. So I’ve done my parameter settings shown below.
But after reading this thread, I am wondering if my setup is running on PWM or DShot? Please comment on my setup.

Here’s the recommended wiring of the motors to the FC. I used in in a QUAD so I only need 4 motors. I used the other 4 outputs to drive WS2812 LED’s. I assume the eight motor outputs of the Kakute H7 FC are all DShots.

Drone can be armed and flying. It jsut take too much time to arm which is a pain in hte butt. I don’t know if that’s normal. By the way, this is my first built so I don’t have a fair idea on what is normal or abnormal.

Here’s my first drone. Body and GPS mast were 3D printed.

On a Pixhawk, it’s really not the place for your question with the FC you have.

What does the Banner Message say is configured on the Messages screen in Mission Planner after connection? Example here:


You usually want to use Dshot600 not 150.

Thanks for your generosity answering my question. I will change my DShot settings to 600. And yes the message screen shows its alredy on DShot 150. I didn’t know that this is where you verify the motor settings. All good now.