Motor losing power


I am a noob and I have just put together a quadcopter using Navio2 . When I armed the copter, initially all the motors were running but the copter wasnt flying! now I notice that one of the motors have lost power. But when I check individually the motors are working. Here’s the link to the logs. Can someone help me out please? Many thanks

There isn’t much to see in that log. Describe the components on your craft.

hi @Hesh_Dan
i was faced this problem when i was trying to lift a heavy copter with weak motors

how much is copter weight ?
witch motors and propellers used ?
battery cell count ?

Hi Hosein,

The total weight is 1077 gms and the approx TWR is 2.3. I’m using the following
Motor: Emax MT2213-935KV 2212 CW CCW Brushless Motor For DJI F450 X525 Quadcopter Multirotor
Props: 1045 10x4.5 Propellers
Battery: GOLDBAT 3S 11.1V 3000mAh 30C Lipo Battery

this config is ok for 1077g weight
do you checked motor directions and esc connections to the flight control

I calibrated the esc on all motors and also ensured that they are spinning in the right direction. I took a slow mo video and noticed that two of the four motors are kicking in slow .Attached is the link to the video

did you calibrated ESCs like this ?

Yes i did. I did run the motor tests on the mission planner and it works fine. Every time I arm the copter and give a little throttle it flips backwards. I double checked on the propeller…the motor spin direction but with no luck :frowning:

As a double check are you sure they are in the right order from Mission Planner motor test? The order is often not understood even if there is a description right on the screen.
A-Front Right-CCW
B-Rear Right-CW
C-Rear Left-CCW
D-Front Left-CW

If this is correct are the trims on your transmitter centered and were they when you performed the radio calibration? BTW-These should always be centered and never used for any purpose on a multirotor.

Hi Dave,

I ran the checks again and the order is correct . But when I ran the motor test, I notice that motor A ( Right front ) and motor D (Front left ) spins right away the moment I hit the test motor button whereas the motors B and C …twitches a bit before it starts spinning wheel…also they seem to be running little slower.Attached is the video that shows the motor test.

Video of motor test for motor B and C

OK, we can rule out motor order and prop direction as the problem as you stated earlier. What ESC’s are you using and did you run the transmitter based calibration in the link Hosein posted?

I have ESC-30A brush less speed controller. DC 5.5V -12V BEC 5V/2A and yes I did calibrate the motors as per the instructions on the link

Are they BLHeli firmware ESC’s by chance? Running out of ideas but if they are you can check the PWM range set by Transmitter Calibration with BLHeli Suite.

I don’t know .sorry am a novice…how do I check that ? Thanks so much for your help

an idea
try to substitute motors with together it will help to find motors are damaged or not
my mean is replace 2 front motor (motor number 3 and 1) with 2 behind motors (motor number 2 and 4)
after replacing if 2 front motors spinning slower i think they are damaged or 2 behind motors spinning slower it means that there is a problem with ESCs

read label on your ESCs

I downloaded BLHeli suite but I realized that I cannot connect since the FC pass through doesnt seem to available . I’m using Navio2 ( FLight Controller) and Mission Planner ( GCS) …have connected through UDP . Looks like it could be an issue with ESC. Will try to rotating the motor

It would have been in the description when you bought them. It’s either Simon-k or BLHeli.

unfortunately it doesnt say whether its simon-k and BLHeli