Motor A doesn't spin up as fast during arm, but spins at the right speed during motor test?

Hey All,

I’ve never experienced this before. We took a new build out for it’s maiden flight. I armed in alt-hold mode, throttled up, and motor A didn’t seem to spin up above 15% or so, while the rest of the 3 motors (it’s a quad) spun up appropriately. I tried arming in stab mode as well and it displayed the same behavior. I decided to check in motor test. and motor A spins the same speed as B,C,D, at any throttle percentage. Any ideas on things to check? The motor orientation is correct, the props are on the right way.

It’s a cube on 3.7 (latest master) running Dshot.

Here’s a video of the behavior

Here’s the log from a test arm

You actually have 2 motors spinning slower than the other 2, just 1 is not as dramatic. Try recalibrating accelerometer.

1 Like

I recalibrated the accelerometer which seemed to help with the motors spinning up. That said it won’t take off at full throttle. It’s like the throttle is being limited? It behaves the same in stab, althold, and poshold modes. This tune worked great on a nearly identical build. The only difference is this build has 400kv motors, where the previous build had 600kv motors. 600kv seemed like a bit much, so we went down to 400kv. I thought the tune might be a bit looser on the 400kv motors, but this is extreme, and doesn’t seem like it’s the motors fault.

That’s a big change from 600 to 400 if props and batteries are the same. Need a log however to help.

Here’s a log doing the described behavior. The props and batteries are the same as the 600kv build. 13x4.5 APC MR Props and 10500mah 6s Li-Ion batteries. Thanks for the help!

Is your current sensor calibrated? It’s showing you’re only drawing 15A at full throttle. So either a wiring problem or your ESCs aren’t calibrated.

You also have excessive vibrations.

1 Like

The current sensor is calibrated. I’m running Dshot which doesn’t need ESC calibration from my understanding? I’ll try switching it to PWM instead of Dshot and calibrate.

On the 600kv build that flies great, it draws about 15A in a hover, and about 25A at full throttle. AUW is around 2600g

Good to know on the vibrations. I wonder if that is partially due to never making it off the ground? The 600kv build had very minimal vibrations.

Well then that’s your problem. The 600kv was working because it provided just enough rpms, but it also wasn’t correct. 6s 600kv 13" should be minimum 75A full throttle, if not over 100. Switching to 400kv revealed the problem. I’m curious what made you think 600kv was overpowered considering you were far underpowered. Ironically, when it’s all working correctly, 400kv is a good change for your setup IMO. I’d bet it’s definitely a problem in ESC signalling.

PS. I’m unfamiliar with DShot, but I’m pretty sure you still have to tell Ardupilot the PWM range of DShot. Can’t leave the RC3 pwm boundaries at default, i think. Someone else can give more accurate information. I think DShot is covered well in the wiki.

1 Like

I should specify that was full throttle in poshold mode, so not true full throttle. During motor compass calibration I saw around 70amps at 80% throttle, so that sounds about right.

According to a few motor thrust charts from KDE and Tmotor for comparable motors, the 400kv 2812 should still have enough thrust to get the bird in the air.

as i said already, your component choice is good… you need to fix why the motors are only drawing 15A at 1950 PWM (full throttle in your setup)

1 Like

Yea that definitely seems to be the issue. During a motor compass calibration it still only hit 15A at max throttle as you noted earlier. Any other ideas as to why it wouldn’t be able to draw more amps at a higher throttle? I tried switching to PWM and calibrated the ESC, but it gave the same result. The ESC and wiring are identical to the 600kv rig that flies great.

Is there a parameter for max throttle other than the one found on the ESC setup page?


RC3_MAX (pwm)

MOT_SPIN_MAX (% of pwm)

Thanks! I checked those parameters and they are what they should be at. We put a set of 600kv motors on and it flew as it should. The 400kv we had custom wound might be under 400kv as motors tend to not be their excat stated KV. Thanks again for help!

ok so you must have wound 275kv or less, because around that KV is the point your copter won’t even hover… you can test that theory by running 2 of your 6s in series, it should fly perfect

1 Like

IMNSHO, running 13" props on 6s is totally useless. BTDT with a Tarot 680 Pro Hex. Stayed with 740Kv on 4S.

I have a Tarot 650 Sport that is stretched to 662mm. I’m running 16" props, 350Kv motors on 6S.

HINT: LOW Kv Motors LOVE big props…

My question is what is the size of this frame?

Which ESC’s are you using? If they are BLHeli do you have Low RPM Power Protect turned off?

It’s a Aikon AK32. That’s a good point. I’ll try that and make sure RPM low power protect is turned off.

Yea we’ve been going to experiment with 4s in the near future as I hear you actually get an efficiency gain due to switching losses on the ESC at higher voltage. It’s a 700mm frame.