Mission planning questions

All I have ever done is LOS flying. I am starting to play with the mission planning in MP. I have done them with DJI stuff in the past.

Couple of questions that I have:

Where is the control for the mission coming from? Is the mission uploaded to the FC? Or is the ground station running the show?

If I am in the middle of a mission and the ground station locks up, runs out of battery etc?

If I were to use a companion computer, could I upload the mission there so I don’t need a ground station?


The mission is uploaded to the Flight Controller and is completely autonomous. There are a couple of Failsafe actions you can set for Continue with Mission. Loss of RC and loss of ground station. I always have these set with that option as the telemetry I use is not long range and even with the Frsky R9 radios I can loose RC on a longer Mission with obstacles.

Thanks @dkemxr

So once I plan my mission I click the write button, then once I am ready I can arm the copter, raise the throttle a little and then flip the auto switch right?


Yep. Either with Takeoff as the 1st command (arm, switch to Auto, raise throttle) or get it flying and Stable and then hit Auto. Whichever you are more comfortable with. You can end it with an RTL or a Land command at a waypoint. Autonomous flight is what got me into Ardupilot.

Perfect, thanks for the quick answers @dkemxr

What are the failsafes that you are referring to? Is it something other than “loss of rc” failsafe?

One pointer-Put WP Speed on a Chan 6 Tune option with a speed range you might want to adjust with a pot. It can come in handy sometimes.

That’s a Good Idea, thanks

There is a bitmask for the options.

For setting WP speed on channel 6, Are you doing it here:



I don’t see a way to set min and max , so I assume it’s done in the extended config screen?

It’s coincidental you ask that because there is/was a bug in MP that would not set the range properly on the Extended Tuning page. Just 3hrs ago Mr. Oborne posted that its fixed in the next Beta. Otherwise in the Full Parameter List you can use TUNE to set the option and TUNE_MIN/MAX for the range in cm/s

Oh I saw that thread, and I ran into that same exact bug when playing with the ATC_INPUT_TC setting

Crap, I totally forgot all about TUNE_MIN/MAX


I am on the latest beta as of tonight, and I think it is still broken

I set 200 and 600 through extended config:

And this is what gets written to TUNE_MAX/MIN


However… enter the number in tenths

And it writes it correctly


Seems like it’s a decimal place error

So as in your other thread, I think it’s best to just use the full parameters

It’s fixed, just tried the latest Beta.

BTW-The WP speed option will override whatever you have set for WPNAV_SPEED. So if your range pot is cranked to the max when you takeoff she will jet out at the max speed set. I always check that pot before arming!

.750 is 750 cm/sec and 1.5 is 1500 cm/s for example.

but… the numbers listed in TUNE_MIN/MAX are the actual numbers that match WPNAV_SPEED

I guess it’s confusing, as the numbers in the Extended tuning screen are at a different scale (Meters/Sec) while TUNE_MIN/MAX are in CM/S

Here is my MP build


Yes, same Beta I have. I think it has always been this way for WP Speed. dekameters/s on the Extended Tuning page and cm/s on the Full Parameter list. I guess I have just adjusted. I did make a note of it on the Mission Planner thread where Mr. Oborne told me to report stuff like this :grinning:

1 Like

I ran into this same scaling problem when I was trying to set up ATC_INPUT_TC on channel 6. Seems like it is a global scaling issue

Yea, I’m betting he will come back with a logical explanation as to why.

1 Like

best Training video out there

Me doing waypoints on hexa quad. Auto take off and Landing…

Jump to 16:01 time.

1 Like