Mission Planner On Android freezing

Hello All
My setup is a RaspberryPi/Navio2 drone (with Ardupilot software) on the bench without propellors. The companion Raspberry Pi is setup as an AP (Access Point) with private network
I can successfully connect my Windows 10 PC running Mission Planner using WiFi (192,168.100.11) and it works continuosly without any freezing.
I installed Mission Planner from Google Play on my mobile phone (Android). I put my phone into the 192.168.100/0/24 network and I could successfully connect to the RaspberryPi/Navio2 drone but the telemetry data freezes after a few seconds. The connection icon in Mission Planner says it is still connected. I disconnect and reconnect using the connect button in Mission Planner and it starts working again but it freezes after a few seconds.
I installed Qgroundstation on the same mobile (Android Phone) and tried it out for comparison with Mission Planner. Qgroundstation connects to drone and telemetry data is diplayed just like in Mission Planer but using Qgroundstation it does not freeze and works perfectly.
I prefer Mission Planner so could some one have any possible solutions to why Mission Planner freezing when using Android
Any help greatly received
Regards Frank

is there any chance you could give me some kind of log?

Hello Michael
You have written a great Ground station software. I really like Mission Planner.
That’s why I am keen to get it working on my Android mobile.
Thank you for your quick reply. Sure, just tell me which file do you want?
Reards Frank

Please let me know which log (file) you want.

Regards Frank

2021-07-28 16-57-02.tlog (136.8 KB)
Is this the file you want?

Here is the file converted to text
2021-07-28 16-57-02.txt (612.5 KB)

Sounds similar to this issue:

Yes I’ve exactly the same issue. I’ve also tested with QGC but I’m not so familiar, nevertheless telemetry was running on QGC.

@fmentiplay Frank, you can try to DL WP, and your telemetry value will update once showing that the Data are there, looks like only the GUI is not updating.
@Michael_Oborne what do you think? same question as Frank, what kind of file could help you?

Best regards,

idealy i need maybe the tlog and the mission planner log.

this would will need to pull off the sdcard under


Hello Cedg
Thanks for your help
Please excuse my ignorance.but what is DL WP?
Regards Frank

Hi Frank,

I mean just read a mission.


2021-07-30 10-16-29.tlog (94.2 KB)

Hi Michael,

Please find the TLog. Originally I had no SDcard installed. I’ve uninstalled MP, inserted SD card, installed MP. But the Tlog is still recorded on the internal memory of the tablet.

Best regards,

Hello cedg
I took your advice and when the GUI stopped working I went into the plan section and hit the Read button then the GUI came alive again. So it looks like Mission Planner is not freezing but going to sleep.
I am thinking, has the developer (Michael) added a inactivity timeout on the Android version of Mission Planner to save power on the mobile phone? So when there is no input from the user the GUI goes to sleep?
Regards Frank

Hello Michael
Here are the files you required.
Please have a look at them and see if you can spot the problem with the freezing issue.
It seems that the connection is still up but the GUI seems to go to sleep. If I go to Plan tab in Mission Planner and select read the GUI comes back to life. Have you set some sort of inactivity timer in “Mission Planner for Android” that the GUI stops after a certain time of user non input to save phone battery power? Any thoughts from you would be greatly appreciated.
Regards Frank

[2021-07-28 16-57-02.tlog|att2021-07-28 16-57-02.txt (612.5 KB) achment](upload://5SIvjigBtFGtPvz21UqTJIM3KLq.tlog) (136.8 KB)

Hello Cedric
Michael seems to have disappeared. Did you solve the issue? Do you think it is a timeout issue?
Regards Frank

im around, but am over a lot of topics. also raw tlogs and bin logs are much better than the txt logs

Hello Michael
Please find attached the raw file from my android Mission Planner when it was freezing. Hopefully you can give me some insight to what might be the problem. Thanks in advance.2021-07-28 16-57-02.tlog (136.8 KB)
Can I ask a simply question. Have you added a timeout on the Android version of Mission Planner to stop telemetry output from the drone being displayed in Mission Planner if there is no input from the end user to save mobile/tablet power?
Regards Frank

Hi Frank, sorry I come back from vacation.
FYI my colleague tried with old Samsung tablet and with is Galaxy S9 and it’s not working.


Hello @Michael_Oborne @fmentiplay,

I’ve updated my MP to the last version available but still the same issue.

Best regards,

Just chiming in that I am having the same issue