Mission Planner Android

pushing out the internal version that resolves the text overlap. will be out in about 24 hours

Thank you very much dear Michael,
I hope that this version of MP x android has a more and more development seeing the many users of MP on Android devices.
Thanks again.

I like to open this topic for both @Alex and @Michael. We have now telemetry data over fport protocol (Thanks to Alex) and Michael just released MP for Android.

Would it be possible to connect MP to Taranis using either Wifi or Bluetooth link? See the concept diagram below.

From a user point of view, there are some advantages:

  1. Lighter UAS (No need for extra telemetry device on the UAS)
  2. Don’t have to carry laptop to the flying site.
  3. Access to telemetry log data on the phone or tablet.

If this topic does not belong here, please suggest another location.


I just installed this on a Samsung Tab A (2016) running Android 8.1.0. I am using 915mHz Sik radios.

This is a bench test rig is using a Pixhawk 2.4.6 (fmuv2) running AC 4.0.5, X8R receiver, QX7 RC transmitter, external M8N GPS/Cpmpass, Sik radio, Craft&Theory telemetry, generic battery monitor, 4S 4000mAh LiPo. There are NO ESCs or motors.

The main issue I am having is that when I arm the “motors”, MP drops the Sik radio connection. The same thing happens when I am connected via direct USB.

I can understand why the USB connection would be dropped, but dropping the Sik defeats the purpose of having a GCS.

Apples and oranges. Taranis uses SPort and FPort, MP uses MavLink.

Besides that a Sik air radio doesn’t what all that much, and with a Y cable you can feed an OSD and then feed the combined video to a video transmitter for FPV.

@oldgazer1, it’s not entirely impossible (see the link below). It’s an opportunity to build modules like TBS CF or R9 modules that would interpret different protocols allowing MP to connect thru the RC radio.
I’ll be the first customer to buy such a module :wink:

Merry Christmas gentlemen, this works great with my Android 5 mobile phone. However I just have one suggestion to make connection via bluetooth. Currently it can not connect via BT… I use Skydroid ML12 with MP for Android, and I need USB cable to make the connection… It is super if the Blue tooth connection works…
Thank you michael…

1 Like

Happy new year to everyone!

I just downloaded the app. Great job!. We have now all functions of Windows MP on android. But it is really hard to use with touchscreen. I use it on my 10 inch Lenovo tablet with 1080p screen and even there I could not touch some buttons. Can you optimize for touchscreens?

Which is the equivalent version of windows MP? On start it shows version 1.0.0 but maybe there is an equivalent windows version.

The following things do not work yet correctly on my tablet:

  • I cannot close the app by pushing normal android “back button”
  • Connect/Disconnect only works once, then I have to restart the app to connect again
  • Cannot change size of windows with touchscreen
  • Sometimes crashes when I want to use mission building function.

Thank you

1 Like

Happy new year to everyone!
Tablet Galaxy Tab Active2
The following things do not correctly work on my tablet:

  • MP is not storing the planner- & connection (TCP) settings as on Windows so one has to input every time after a new startup
  • MP disconnects suddenly and has to be reconnect

Question: how can I move the log- folder to my external SD card?
Thank you for the great work

1 Like

Installed Mission Planner to Android.
Accepted all request.
Connected with USB OTG adapter to 900Mhz telemetry module.
When try to connect is asking: “Connect to USB Device? CP2101 USB to UART Bridge Controller” No/Yes. Select Yes, Is trying to connect, but fail. Tested on Samsung A20, Nexus 5 and Nexus 7, same fail to connect. Any suggestion?
When using Tower or DroidPlanner with same android and USB OTG all connection is OK.

answer no, then pick the port and baud rate from up the top.

Still not detecting, see below.
After installing MP to Android I did accept ALL.
When connecting with OTG USB I answer ‘No’ to bridge question as you suggest.
I am using APM and 400MHx telemetry.

On same device (Nexus5, Nexus7, Samsung A20), with Tower or Droid Planner detection is OK

115200 is the correct baud rate?

It worked! Thanks a LOT!

57600, as usual. :slight_smile:
But the drop down list was hidden.
After make it visible I did choose the good baud rate and happy

i have a beta version that supports bluetooth.

so testers please give it a try


Clicked on link to install beta update. Not see an update for MP. Started MP and is shows v1.0.0, Build
Go to Help and press ‘Check for BETA Update’. popup Check for Update then “Error Getting Parameter Information.”
Other issues:
-no voice although is activated on Config\Planner. Other text to speech apps works fine. Voice is important when fly with MP as GCS.
-cannot save as new file: Plan tab then Save File, or Full Parameter List , I cannot enter a filename to save
-simulation not work. is connecting to TCP, when I press “Mission start” after pre flight checkin, is saying “The Command fail to execute MISSION_START”
-more test coming

I have not Voice, although Speech is checked. Anything special to enable voice? Other text to speech app works fine

Thanks all, I just downloaded the app. This works great with my Android. Great job! :+1:

Downloaded the Beta App for my Heli (firmware 4.6.RC2) but the app does not show any bluetooth entry.
The lowest speed is 115200 and could not be changed to 57600.

The app itself works well, but only on the OTG port. The phone is an eight core MT6753 64bit system at os version 5.1 with 1.47gb free for the app.
(can be updated to 6.0 if needed)
Btw,…QGround works fllawlessly . ( but for any reason only with the 32 bit instead of the 64 bit app)

have you connected via bluetooth before to this device?
at the moment i leave all pairing to the user. Mission planner will display BT_* for the devices in the existing paired list
also double check you have the beta version 38199