minimOSD Bug or Feature?


I have recently added FPV & minimOSD to my octo. (Arducopter 3.5.4)

Everything works as a charm, except that the flight mode field does seem to a) show garbage and b) does not change even when flight modes do change. Basically it forever displays “M_O” (see pic) as flightmode while all the other fields update as I would expect during flight.

As I am new to minimOSD wanted to ask if others have the same problem and if there is a known solution ?

Regards & Thanks,


I think You should Update the charset…

I used the MinimOSD-Extra and got it going quite well - I saw a similar issue when I flashed the wrong version.

  • Download the and unzip, run in windows.
  • Use OSD_Config.exe to flash the character updater first, Character_Updater_FW.hex
  • Then flash the desired character set, I used MinimOSD_2.4.1.4-digital.mcm
  • Next, flash the desired firmware version number - usually the latest - BE SURE to choose the “mavlink” and not the PX4 version, MinimOsd_Extra_Uni.934DV-MAVLINK-release.hex
    • this is where I originally went wrong, incorrectly chose PX4 instead of mavlink

The PX4 version worked but the flight modes showed like yours (above), when I changed to Mavlink version everything worked as expected. And the spinning prop shows next to flight modes when armed!

1 Like

If the character set was corrupted the entire display would be garbage.

With that said, all of the “standard” minimOSD/MavLinkOSD fimwares are seriously outdated.

A much better option is MWOSD. MWOSD supports minim, micro minim, MavLink, and Aeromax OSDs as well as the OSDs embedded in the flight controllers popular with the FPV racing folks.
MWOSD supports Pixhawk (PX4), APM (MavLink), and FCs running CleanFlight, BetaFlight, and iNav.

Unlike older systems, MWOSD is completely GUI based so there is no need to use Arduino to compile and flash firmware.

One caveat: For FCs using AurduPilot firmware, MWOSD uses MavLink ID numbers. If you leave the aircraft MavLink ID (SYSID_THISMAV) at the default of 1, MWOSD will work just fine. However, if you setup a new OSD on an aircraft that has a MavLink id that is not 1, the OSD will not work. To fix this you need to either change the id of the aircraft to 1, or you can use the GUI to change the target id on the OSD.
I have three aircraft with OSDs running MWOSD with the Pixhawk(PX4) firmware. Two of those aircraft are quads and they have different MavLink IDs. The OSD on the #1 aircraft worked just fine. It took me a little while to figure out why the OSD on the #2 aircraft wouldn’t work…

I didn’t know about this piece of NG’s work. I have a couple of spare boards so I’m gonna give a shot.

Thanks for posting…

Thanks Shawn,

your advice worked magic.

I think I might have initially used the “PX4” Version accidentally also, same as you!

I reflashed following your advice using the latest “normal” MAVLINK" version and now things are as expected!

I actually ended up using the most recent charset ( and also the latest Firmware (9.43 at this time) and it works like a charm also with these newer versions. - the trick was NOT to use the PX4 Version.

Cheers and thanks,

You don’t need any arduino to flash minimOSD by NG.

GUI for MWOSD is piece of crap, it never worked for me (that’s why I’m using NG version)

EDIT: OK, new GUI is bit better but I still prefer NG version

For Night-ghost minimosd-extra, you MUST use the OSD_Config.exe that came in the zip too. If you already had one from another minimosd you shouldnt use it.

I use a generic 3.3v/5v FTDI to flash, switched to 5v.

Up Date…

I tried NG’s fork. It has some neat stuff, but it still uses blocky character sets just like the older versions. For the time being I’m staying with MWOSD.

i have the same issue about flight mode.and have try a lot of character set but all of them didn’t work until a change the charater set to MinimOSD_2.4.1.4-digital.mcm.The flight mode display right now,but this character seems not so clear evern i have set the brightness to hight. any one have the same problem?