minimOSD/w MWOSD: Displays over lay but NO DATA

Three separate minimOSDs/MWOSD firmware on three separate Pixhawks (1 2.4.6 and 2 2.4.8s) all bit the dust. I have flashed firmware, fonts, and tried every trick in the book. I can use the configurator to make changes to the over lay and those changes appear in the transmitted video, but I cannot get any data. I have switched from Telem1 to Telem2, and back again… I have tried with a telemetry radio in parallel and the radio works, but the OSD still does not get any data…

Any advice will be greatly appreciated.

Protocol set to Mavlink1 ? Baud 57 (57600) of course.
I also set TELEM_DELAY to 5 secs, gives everything time to settle, maybe 2 secs would be OK too.

DEV_OPTIONS = 2 for DevOptionVFR_HUDRelativeAlt once the OSD’s are working

I tried that. Still no data. I did forget to mention the OSD is displaying ArduCopter startup status messages, but still no dynamic data. This has got to be an ArduCopter thing…

This old discussion covers most things: