Servers by jDrones

Mini Talon QuadPlane Conversion


(ronsand) #241

Are your guys using the internal compass in the PH or are you disabling it, when using an external one?


(cala2) #242

I disabled the compas in pix 1


(Greg Covey) #243

I also disable the compass on the Pixhawk.


(ronsand) #244

Disable it is then :slight_smile: The MT is configured and ready for maiden. Just waiting for the weather to improve a bit.


(ronsand) #245

A few pictures of the MT awaiting the maiden flight :slight_smile:


(Greg Covey) #246

Very nice and neat! It looks ready to go and makes me long for warmer weather. Our first full day of Spring hit 35 degrees F, so it’s finally above freezing!


(ronsand) #247

Video from the maiden with my Mini Talon Quadplane. Let the tuning start :slight_smile:
The F80 1900kv motors have plenty of thrust on the 7x4 apc props and the craft was initially hovering at 25% stick in q_stabilize. Only yaw seems sluggish and it sort of overshoots the stick commands.

A few pictures


(ronsand) #248

A quick one. When having the accelerometer set for level flight (airplane mode), and the apx 5deg forward tilted motors, the craft creeps forward in all non GPS modes. Is there a way around this?


(Greg Covey) #249

Hi Ron,

Great test! It looks like it hovers nicely. You’ll want the forward creep for transitions and when yawing in hover. Remember that you’re not flying a copter but rather a quadplane. The normal operation is not hovering in place in no wind conditions but rather moving forward into the wind. Hover times on take-off and landing are relatively short. Autonomous modes will compensate so you need to adjust when flying manually. The first time you accidentally transition or hover with the wind at your back will be an eye opener. The quadplane setup becomes more natural after a while when flying manually. When flying autonomous, it does a better job than my manual flying.


(ronsand) #250

Thanks Greg. regarding the forward freep, I see your point and will just compensate manually with the sticks during hover testing. I will do a few more sessions to tune the quad part, before transitioning to forward flight.


(ronsand) #251

I am trying to get the craft to hover at 50% throttle stick in Q_stabilize (hovers at about 25% stick now) and I can not find the parameter “Q_thr_mid” in apm plane 3.5.4. Has this been changed to something else, and the Wiki not updated, or is there something that I am missing?


(Greg Covey) #252

Ron,

It learns itself pretty fast. Here are the settings.

Q_M_HOVER_LEARN,2 for Learn & Save
Q_M_THST_HOVER,0.2 to 0.8

I think the default is 0.35 for THST_HOVER. I have not needed to set them manually.

Make sure SERVO_AUTO_TRIM is enabled and you will be amazed at how fast the plane flies level without stick offsets.


(ronsand) #253

Thanks for answering. I have been looking at these parameters, but have not changed the q_m_thst_hover based on what I read here: https://github.com/ArduPilot/ardupilot/issues/6652 From this I get that it only works for altitude hold modes (q_hover?). Maybe this has changed over the last fw releases, and now also has effect in q_stabilize?
q_m_hover_learn is as default set to 2, but I also thought this was for the q_hover and q-loiter modes?

I have now set the servo_auto_trim to 1 and will try that out.


(ronsand) #254

I have done some tuning today and for sure the q_m_thst_hover does not tune the throttle posisjon in q_stabilize, only the more “automated” modes like q_hover and q_loiter. It is strange that the q_thr_mid is gone in the 3.8.4 fw (or is it only mine?), but stil in the wiki.

Edit. After reading a bit more I see that the thr_mid parameter disappeared with the 3.4 fw. I am still running 3.3 on our large SAR hexacopter, an was not aware of this change.

In any case from what I read, the q_m_hover_learn parameter set to 2 should have sorted out my “misaligned” stabilize throttle (hover at apx 1/4 stick) but it is not so far. Anything that I am missing out on?


(Greg Covey) #255

Ron,

I am not sure that I fully follow your issue. If your hover throttle in QStabilize mode is 25%, does this not match your Q_M_THST_HOVER setting? Perhaps your 25% is an estimate and you need to graph the ThrOut under QTUN.

Here is an example. On my mini Talon QP, the Q_M_THST_HOVER is 0.35 or 35%. This matches my actual throttle setting (ThrOut) in QStabilize mode. Try graphing your ThrOut and then retrieve your configuration from Mission Planner for comparison.


(ronsand) #256

Hello Greg and thanks for taking the time :slight_smile:

Se the attached screenshot. The trend is clear; the Qtun ThrOut does not follow the Q_M_THST_HOVER which is at default 0.35, it is more in the 20-25% range. It is a bit troublesome as it hovers mid stick in all but q_stabilize mode.


(Greg Covey) #257

It does look like the default value for Q_M_THST_HOVER is 0.35 so maybe I gave a bad example. Try changing your Q_M_THST_HOVER setting to 0.20 and see if your issue goes away.

I’m not thrilled with the noise spikes in your graph. What are you using for a Power Module?


(ronsand) #258

I have tried it at 0.20 but that made the q_hover and q_loiter, hover about 70% stick input and q_stabilze was still at about 25%.
Maybe I should try again and give it some time?

I use a much pm, but the flight was with quite a lot of stick input during testing. I will check the logs for fc voltage spikes anyway.


(Greg Covey) #259

I’m not sure anymore. Something isn’t right. Is the Mauch PM +5v isolated from the Pixhawk Main output 5v? If the receiver has no other servo connections then it can be powered from the Pixhawk RC In port otherwise disconnect the red center wire and power the receiver from an external UBEC.

The hover seems so over-powered that you may want to drop the prop size an inch. You may want to check the vibration levels too. Here are my vibration and ThrOut graphs from my latest FX-79 Buffalo QuadPlane for reference.


(ronsand) #260

Hello Greg. I really appreciate your input :slight_smile:

I really can’t se any real problems with vibrations and power to th PH / RX in the logs; the Mauch PM should be isolated from the PH 5V output and all servos are connected to the PH. There is a back up power supply connected to the aux output. In addition there is a diode and a small low esr capacitor on the aux output.

Even in the time frame represented in the screen shots, I was moving around a bit and not trying to hover stationary.

For sure I am quite over powered and dropping to a smaller prop may solve my problem with the q_stabilize mode. I feel it is a step backwards if they have removed the thr_mid parameter that would earlier have sorted this out straight away.

I had a flight today where I lowered the Q_M_THST_HOVER parameter to 0.20 but that did not solve the problem. I had to cut the testing a bit short due to snow and strong winds (the logs look like crap :wink: )

Edit. I found that the RC3_trim (throttle) was set to 982 (same as RC3_min). It might be supposed to be like that (as the throttle stick is supposed to be held low at the end of the end of rc calibration), but I will try with a value closer to 1500. In any case I will have to wait for tomorrow to test as it’s pitch black outside :slight_smile: