Mini Pix Problem

I have trouble putting together my drone.

The equipment I am using is:

  • 4 Readytosky Motors
  • 4 Simonk ESC
  • Mini Pix
  • 5200Ahm battery
  • Flysky i6
  • FS x6b Receiver

When assembling, it only emits sounds (high pitched), coming from the buzzer. I also try to configure the channels, but I have the same problem. Other times it emits a constant sound, but never the typical sound to arm.

I have changed parts, but I always have the same problem.

Can they be the ESC?

Sounds like my original setup I had on my Reptile 500…

I’m not trying to bad mouth some of these Chinese companies yet have had more issue with failures using the Simonk ESCs and found the MiniPix are a pain to get working correctly … I never could get log reading from the MiniPix… Anything to do with RadioLink equipment I have totally backed away from due to no support from their company or equipment reliability .

However, your main issue is the MiniPix … it is very finicky on setting up.
Not sure if you have tried to calibrate your ESCs using Mission Planner or not … Be sure to follow the instructions in Mission Planner on ESC calibration… You have to assure you unplug everything (USB and Battery) for a reboot in order for the calibration to get synced … …

I personally ended up dumping the MiniPix and switched over to Pixhawk … Found it was a lot more reliable and retrieved data a whole lot better… Yet some folks who have used the MiniPix have had some luck but its a challenge and not enough info out there for support.

ls it Radiolink mini Pix.?
Have you read this…

Hi Doug!

It has been difficult for me to solve these problems.
I tried to perform different tests. Work with Mission Planner to configure the entire system, up to ESC (Simonk 30a), but it always presents the same problem.

Now I can have problems with Simonk ESCs. Previously I worked with two APM 2.8, using the same ESC, and with both I had the same problem. I have no control over the turns and the movement to the left or to the right, also when starting, the drone goes to the side. I was very careful with the position of the APM, the position of the GPS, the position of the propellers and the movement of the motors.

I leave the link:

On the other hand with Mini Pix, I had worse result. This never started the engines.

I tried to contact RadioLink technical support, but all they did was send me the equipment manual. The same that comes in the box.

I leave the Mini Pix test link

I will try to perform new tests, if I do not return the product haha ​​(I bought in Amazon) and exchange it for a new ESC or OPTO so that it works again with APM.

Thank you!

Try this …
Not knowing if your Mode 1 or 2 either way
Take your **LEFT gimbal and pull down right corner and your RIGHT gimbal down to left corner at the same time and see if she will arms …
I found that was an issue when I was dealing with the MiniPix on arming my motors… It sounds like they want to arm or start but your sequence might be wrong …

Kind of hard to see what you have without being there to help you figure it out… But stay with me and I maybe able to help you out… But give it a try and let me know…

Also … forgot to mention … My drone did the same stunts as yours … I ended up going back and taking a piece of blue tape (any tape is fine) and putting on my motors … I went into Mission Planner to INITIAL SETUP then to MOTOR TEST … I tested each motor for proper rotation and found one of my motors was running the wrong direction … Switched the leads on the ESC for it to turn the opposite direction … Did another motor test to verify all the motors were starting their rotations in the proper direction … Then did a TEST ALL MOTORS to verify all motors work accordingly … Then did a SEQUENCE TEST as another double check my settings … Took the tape off the motors and added props did a test flight and off she went without a roll over …

RadioLink MiniPix … I still have a lot of questions even after reading the book … I am not a satisfied customer after purchasing a lot of RadioLink items… I have a failed MiniPix that I purchased new and RadioLink doesn’t want to back their products… I am planning on moving to another complete radio system… I find the company likes to “PUMP YOU UP” to purchase but “LETS YOU DOWN” on customer support and backing their products. There is a special MISSION PLANNER that you have to download from their site specifically for the MINIPIX …
Uhhhh? … Really and Why … and RL customer support only stated read the book … So I totally understand Francisco’s frustration.

1 Like


I was working on your comments, but I don’t think it worked.
I made a small (new) video explaining and showing what my condition is. Use your recommendation, but you can see a response from the drone.
If you have any comments, I am very attentive.

Are you trying to calibrate the ESC ?
Trying to Arm the quad ?.
I don’t know about the Mini Pix !, but…
Have you done an accelerometer calibration ?
(I don’t think so, without mounting the FC)
Have you done a radio calibration ?
For the normal procedure of ARMING, Throttle Down & Yaw Right. (Left stick-Down & Right[mode2]
ESC calibration,-Read documents.!

OK Francisco I believe I see the problem … First off the main give away is your MINIPIX light indication.

You need to do the following
The indication light on the MiniPix is flashing “fast” various colors … meaning there is an issue with the flight controller - Could be anything .

  1. Make sure you have downloaded from RadioLink the Mission Planner just for MiniPix… MissionPlanner For MINIPIX

  2. Connect using USB and BATTERY to the drone connected to your PC and go through the COMPLETE initial setup process. DO ALL CALIBRATIONS OVER AGAIN> make sure your connected to the drone by your USB - COM PORT ???

  3. When you get to the ESC section of the setup … (I leave the throttle setting in low or down position) It’s small print telling you to unplug USB and BATTERY after you click CALIBRATE.
    Then you re-connect your battery and will hear musical tones from all of the ESCs. Give it a second and don’t rush it - When you hear the tunes … plug back in your MiniPix by USB … you should leave the battery connected.

  4. Once all of your calibrations are done you should run INDIVIDUAL motor test to make sure the motors are turning in the correct rotation according your drone type - Quad…

  5. WHEN YOU ARM (pushing the arming button) - You should see the MiniPix indication light go GREEN to BLUE (flashing slow)

  6. On the Radio to arm = THROTTLE and ELEVATOR sticks goes BOTTOM - CENTER -
    !!!NOT FULL THROTTLE up or down!!! (I used that process back in the early 2000’s for aircraft due to the ESCs back then.)

WHEN ARMED - Your BLUE slow flashing light goes to SOLID BLUE with a long tone warning you for motor start .

Mission Planner will tell you (VOICE) your ARMED - Do “EACH” motor test for rotation … If one is running backwards then reverse leads on the ESC … I normally do the two outside leads.

Let me know if the above helped …

REVISION: I keep coming up with ideas to help you and keep revising this write-up for you


Why use the Radiolink firmware when Arducopter supports this FC? I don’t have one just asking the question.

1 Like

No problem Dave, Good Question …
When you read the documentation on the MiniPix at RadioLink website … it specifically addresses to use the MINIPIX Mission Planner … I do have QGroundControl on my pc … I did try it but didn’t work for me …
Why that FC is so different beats me ??? Not sure what it is about the on board electronics if the chips are different ??? Hope someone can chime in and give us some ideas or heads up on “The Whys” …

Hi Doug-Yes, I understand that was the case when that FC came out but since then the Dev’s have produced a standard Ardupilot firmware version for that FC that I believe will install from and then subsequently be supported by the standard Mission Planner. I’m not sure if MP will recognize the board automatically and select the proper firmware, maybe it will. But I would just download the .apj file from the link I posted and use the Load Custom Firmware option to install it.

AH! … I just recently updated my QC software … I have some MINIPIX myself and will test that out … I’m curious to see if there were any changes … YUP! Maybe there was a transition the DEVs were going through and I was caught in the mist of it all … Let me do some testing and see … That should be interesting…

What is your status? … Did you get your drone going yet? …

Hi Doug , i am new on this topic i have a minipix and try to conect ith to misionplanner from radiolink, but my pc say he don’t recognized the usb device i plug in so i dont find a com port on mp.
do you have a suggestion
Krg Rob


He was working on his comments, but the result was always the same. Motors do not arm or do not calibrate.
One thing that caught my attention was that the engines move very slightly (see minute: 1:59). This happened after loading a new .apj fimware, and a very characteristic music was added that it didn’t have before.

Why are you bothering with Compass/Motor calibration? That is of no value to you at this point and in most cases can be ignored. Also, there are several reasons why a Flight Controller won’t arm and lack of ESC calibration usually isn’t one of them.

You may need to check your Flight Controller back to the RX … You got movement on a motor via the esc but not a constant … Something seems off on your flight controller …

I have to agree with Dave … Why are you in Compass/Motor Calibration?.. There is no need using that at this time … You need to go to MOTOR TEST in the Mission Planner…It’s on the same line as Compass/Motor Calibration…


Did you go to RadioLink and down load their Mission Planner? It supposed to be geared for the MiniPix …

However Dave stated the latest Mission Planner was suppose to have update to carry the MiniPix…

I have tried it with both and only the one from RadioLink recognized the MiniPix … the regular or most popular Mission Planner did not. (I do not know why)

As far as the com port did you go to Device Manager (Wiindows) and see if it was even recognized? The other thing I ended up having to do was download a driver at:

This information is on their web site:

Let me know if that helps …