Servers by jDrones

MicroArduCopter, 3" props, Omnibus Nano, Success!


(Paul Atkin) #423

Yep, i see that - yours are returners. 1407 are tornadoes. Good to know.


(Paul Atkin) #424

hi, not sure if you saw it - @tridge made a logging support for the dataflash chip, but i for some reason cannot make it work on the nano v6. does it even have a blackbox chip? betaflight definition seems to have its pin assigned as PB12 for the dataflash, but i am no longer sure. i get bad logging error all the time after the compilation.

if you have any blank nano v6 board left - can you check if it even works under the betaflight to support a blackbox logging?


(S) #425

Hi,
I saw that chat yesterday and am super excited about it! I’m having a problem w/ my new copter (It’s not level after each reboot) and logging would really help me figure out what’s going on…

Both of my boards are in copters now… I could probably flash my older copter I’m not messing w/ right now back to betaflight to check… But, I’ve got a busy day w/ work today, so it will be a day or two before I have time…

You could try writing to airbots support and ask them… They’ve been very helpful w/ my questions in the past.
https://store.myairbot.com/contacts/
I think it has one, but I’m basing my info off a few random posts on RCGroups… I haven’t actually personally checked.


(Dave) #426

I have one one on the bench, I’ll give it try later. This is an great development!


(Paul Atkin) #427

so far i did not get it working, must be smissing something in there as we confirmed chip to be on the board, and config seems to be correct, but, something is not cooperating. @tridge says it works on the kakute f4 - but i do not have it so cannot test.
All works,. Param had to be set to 4.


(S) #428

Awesome!
Do you know if Tridge added the configuration to the nano hwdef?

If not, do you think you could copy/paste the lines into the default hwdef and PR it?

Now I’m going to have to read up on the logging options, because 16 megs probably won’t last long for the defaults…

The past year has been amazing for Arducopter :smiley: (I don’t mean the past month, 2019, but all the 2018 work, and then this… Really amazing…) It was impossible to build a small drone w/ these capabilities a year ago.


(Hugues) #429

I encounter a strange issue where motor spin direction always remain the same eventhough I change the motor direction on the ESC (via BlHeli suite). I use mission planner’s motor test screen to check the motor’s direction and it is always the same whatever the ESC “normal” or “reverse” parameter. I don’t understand how that is not working.
ANyone any clue ?


(S) #430

I’ve only swapped wires… Never tried the reverse motor function of the ESC. But, that functionality shouldn’t have anything to do w/ arducopter…
Are you sure the parameters are saving? The next time you open the blheli configurator, it’s still reversed?

For anyone using an omnibus nano, is it staying level for you? At least a couple of us are having the exact same issue w/ the IMU’s thinking the copter is progressively tilting more and more over a flight, when it’s not.


(Dave) #431

Sorry Wicked1 I haven’t been able to test mine further after setting the loop rate back to 400. Too cold to fly outside (darn Polar Vortex) and this 130 is a handful to fly in the limited space I have in the basement. A ~2 min flight seemed to work OK but that’s not very definitive for this issue.


(S) #432

No problem… Whenever you have time, let me know. I caved and ordered another ESC and FC… I still hope I don’t need to rebuild, but I have them if necessary. It’s nice to have spares on hand anyway.
Anyway, no rush… and if I get it solved before I hear from anyone else, I’ll definitely update the threads.


(Hugues) #433

Yes I’m sure and I see the modified parameters after a second connection. But no effect whatsoever.
I only get an effect after swapping wirres physically.
The BlHeli suite had always worked fine for me using Betaflight or Cleanflight. But this behaviour only happens with ChibiOS Ardupilot. So there might be a link somehow even though I don’t understand what.


(S) #434

@Paul_Atkin1 (or anyone)
What port in the arducopter config is ESC telemetry on? -For the omnibus nano.
In the config, the defaults are:
Serial 1 is telem. Serial 2 is nothing. Serial 3 is GPS. Serial 4 is GPS. (I only have 1 GPS, but this is what’s in the default config).

I’ve tried port 2 and 4, and don’t see any info… I just want to be sure I have the port correct, before I start looking for other issues.

thanks


(Paul Atkin) #435

esc telem will be on any port you configure with an option for it. :slight_smile:
SERIAL_PROTOCOL for that port needs to be set to 16, that is all.

on kakute f7 it is an UART7 which is usually fed ESC telem signal, it is mapped to SERIAL5, i think. you set it to that 16 protocol and speed of 115K.

to cehck if you get that ESC telem is not easy, simplest way is to alter the battery to option 9 - BATT_MONITOR 9 0:Disabled 3:Analog Voltage Only 4:Analog Voltage and Current 5:Solo 6:Bebop 7:SMBus-Maxell 8:UAVCAN-BatteryInfo 9:BLHeli ESC 10:SumOfFollowing Controls enabling monitoring of the battery’s voltage and current

this way when you connect lipo while your model is connected to MP it should start showing voltage and current from ESCs if telemetry works ok and flows in fine.


(Paul Atkin) #436

sorry i did not see. for nano v6 it is a serial 4.

SERIAL4_PROTOCOL 16 -1:None 1:MAVLink1 2:MAVLink2 3:Frsky D 4:Frsky SPort 5:GPS 7:Alexmos Gimbal Serial 8:SToRM32 Gimbal Serial 9:Rangefinder 10:FrSky SPort Passthrough (OpenTX) 11:Lidar360 13:Beacon 14:Volz servo out 15:SBus servo out 16:ESC Telemetry 17:Devo Telemetry 18:OpticalFlow 19:RobotisServo Control what protocol Serial4 port should be used for. Note that the Frsky options require external converter hardware. See the wiki for details.

set battery monitor to 9 as i stated above.


(S) #437

Thanks a lot!
I take it from your reply that the “status” readout in MP for ESC is still not functioning. So, maybe it was working :). I’ll try the battery monitor test in a little while.

This particular ESC has a current wire, so I’m hoping it actually measures the current internally, too, and sends it over ESC telemetry… (It has telemetry and current wires).
The omnibus nano doesn’t have a current pin, does it? I noticed the hwdef still says pc1 is the current sensor, but I think that’s left over from the bigger omnibus FC.


(Paul Atkin) #438

Nope, nano got pretty much nothing. :blush:


(Hugues) #439

I finally finished my first 3" build on a Kakute F7. In case you missed my build video, I repost here:

Next will be the endurance flight test.


(S) #440

Nice!
I’ve had two problems w/ those batteries…
The spiral nature of them makes them more inductive… It interferes w/ my magnetometer more than a flat battery, and I think they interfere w/ my gyros… I’ve been having problems w/ my copter going out of level under throttle… I can hold down on the bench, spin up the motors, and watch the HUD slowly tilt. When I turn the throttle off, it re-levels. That issue is much worse w/ 18650’s! (This is still just a guess. There are other differences like they’re heavier, so I am using more power when I use the 18650’s, and may be that is causing the increased tilt… It seems like more is going on though… Because a high speed run w/ traditional lipos doesn’t cause it to tilt as much as these 18650’s at hover)

And the other issue… I can’t find an ESC that works at less than 6v, and LiIon’s have to be discharged to a lower voltage to get the full capacity, and they sag more. My batteries are basically 1/2 full at the point I have to land.

-That’s a great build video! And I see your GPS is on a mast… I couldn’t tell on the image here on the forum… That’ll mitigate the magnetometer interference.

–If you do any sort of long range flights let me know how that telemetry modem performs.


(Hugues) #441

Interesting feedback about the 18650 impact on gyros. I’ll experiment that for sure.
It is true that 2S is a bit low in voltage and I’ll have to land at minimum 6.4V (3.2V per cell) with the specific ESC I have. Even if that is only 60% of the full charge, it is, for a 3500mah capacity still way more at equivalent weight than a LiPo battery could provide.
60% x 3500 mah @100grams = 2100 mah for 100 grams.

To compare a 2S LIpo at 2200 mah weighs 148 grams, 50% more than a Lithium Ion.

Furthermore, the long rectangular shape and size of a LiPo of that capacity makes it impossible to fit and balance nicely on the top plate.

A little anti EMI tape around the 2S pack might solve the issues you encountered. I bought such tape in a specialized shop in France who’s making EMI military grade insulations around cables and boxes. It adds a little weight for sure but not more than regular thick tape. It is made of a what looks like to be some kind of Aluminium looking foil material with on top of it a small metallic net.I’ll post a picture.


(cala2) #442

Perhaps this is usefull https://store.mrobotics.io/product-p/3m-emishield01-mr.htm