Servers by jDrones "link 1 down" w/ RasPi

Ok, that’s good. That means that mavlink-router is routing the telemetry from the serial port to over udp.

What commands? The apsync img file is preconfigured. No extra commands are required.

You don’t need to use the --baud option when using a udp source

Generally, you should only run as root when making system modifications that require it.

Looking at the, those instructions are quite old and probably don’t work anymore. They need updating (thanks for pointing that out!). Hopefully I’ll have some time over the Christmas break to update them.

Rpanion is a completely different software with a different img file to download and install. You can have Rpanion or Apsync running on your Pi, not both.

Oops, that was a typo. I meant the SERIAL1_PROTOCOL (set to 2)

APSync uses mavlink-router to distribute the telemetry, and is already set to auto-start in the imgfile. You don’t need to use MAVProxy for that.

OK, why is “Server connection interrupted” occurring (see image in prior response)? Everything is located within feet of one another.

What are the limitations of employing this configuration in flight, and what can be done to ensure signal connectivity?

Also, which of the “open hardware” does/will apsync work with ?

Also, you mentioned above

What are the different options? How does one choose between the two?

That would mean your Wifi connection is cutting out. I’m not sure why.

The Wifi range would be the limiting factor. From what I recall the Pi’s Wifi range isn’t brilliant. The exact range would depend on the Pi’s mounting in the vehicle and any potential interference from other devices. You’d need to measure it yourself for an accurate number.

All of it. Apsync will talk with any controller that runs Ardupilot.

I wrote Rpanion-server, so I’m probably a bit biased :slight_smile: Rpanion-server is designed to be easier to use and install, but it’s quite new software so there may still be a few bugs in it.

Thanks again for your guidance.

@stephendade can we use higher power WiFi through the USB ports?

Yes, that would work.

I have my RPI zero w connected to my pixhawk 4 mini telem port and get the same error as the original post.
I only connected the tx & rx of my pi. The pi it’s powered on USB. Is GND necessary for a stable connection?

yes it is…

Servers by jDrones