Servers by jDrones

MAVLink to HoTT telemetry converter for Graupner RC users


(zdv770) #1

New version of mavlink to hott telemetry converter is ready for beta-testing and usage.
It was attempt to take most from both MAVLink and HoTT.

It emulates all known sensor modules from Graupner:
Graupner #33611 General Air Module
Graupner #33620 Electric Air Module
Graupner #33601 Vario Module
Graupner #33600 GPS Module
Graupner Air ESC family

It takes from mavlink stream and shows

Temperature
Absolute air pressure
Altitude
Climbrates by 1s, 3s and 10s
Current
Voltage
Battery capacity used and remaining
Battery percent used
Ground speed
Electric time
Flight direction
GPS satellites number
GPS fix type
GPS coordinates
Yaw, Pitch and Roll in degrees
Home distance
Home direction
Armed / Disarmed status
Flight mode
Current WP number in AUTO mode
Heading and distance to current WP
MAVLink heatbeat status
Throttle


It allows flexible tuning of voice alarms.

It’s configurable directly from RC.


Can be loaded into any AtMega328p 5v 16MHz board.

I’ll appreciate any feedback.

More info here.
HEX file here.


(zdv770) #2

New version 1.4 added. This version was tested with MX-16, MX-20, MZ-24 (Thanks to Klaus) and MC-32 (Thanks to Deepflights).
Currently tested with copters only, but should support planes as well.
I’ll be glad if anyone will test it and give feedback.


(zdv770) #3

Newer version available.
New functions added.
More info and HEX files Here


(Sandre) #4

Hello,

I’m installing a pixhawk into a fixed wing aircraft, using a graupner radio.

First I had some issues with sumd compatibility between my GR16 and the pixhawk. It’s now solved with an hand mad patch, proposed here https://github.com/ArduPilot/PX4Firmware/pull/71 to ardupilot.

Now I’m trying to load the hex file into a spark fun arduino mini 5V 16 MHz board and I don’t get any result.

The arduino mini has been bought with bootloader inside. I installed avrdude on an ubunu 16 PC, I used a standard ftdi cable (usb <-> TTL , ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port)

with the command (and pressing simultaneously the reset button):
avrdude -c stk500 -p m328p -P /dev/ttyUSB0 -U flash:w:MAVLinl2HOTT-latest.hex

I get only “avrdude: stk500v2_ReceiveMessage(): timeout”

I’ve a doubt with the signal level of my ftdi cable, 3.3V or 5V, but is it critical ? After releasing reset button, the green led flashes two times, that’s all.

I tried with Xloader on a PC, without success.

Is it possible to have some details for arduino newbe ?

Regards,
Benoit


(Sandre) #5

The command to flash the Arduino is :slight_smile:

avrdude -c arduino -p m328p -P /dev/ttyUSB0 -b 57600 -U flash:w:MAVLink2HOTT-latest.hex

Not easy to guess, but after that it is plug & play with a GR24L and a pixhawk (with ArduPlane)
Benoit


(wk) #6

Hello everyone,

I’m trying to make work the version 1.4.3 of MAVLink2HoTT without success.

Here is my setup:
Pixhawk 1
Arducopter version: 3.4.4
Graupner MX-20 with firmware version: 1.207
Receiver: GR-16 with firmware version: V6a37
Mini Arduino Pro 5V 16MHz

Everything is wired worrectly to Telemetry 1 port and the settings of the port unchanged (Mavlink 1 protocol + 57600)

All settings in MAVLink2HoTT 1.4.3 are the default ones (all sensors emulated)

Problems are:
All values on the Graupner display are at zero, except the capacity of the battery (mAh)
When I change the flight-mode, the display (of this flight mode) takes around 3 to seconds to update, which seems to be quite long.
Beside that, nothing else changes.

I can walk though the settings of MAVLink2HoTT on the MX-20 and change them, but the telemetry data dont come.

I tested the same setup with another GR-16 receiver and also with another mini Arduino Pro, but the behavior remains the same.

Any idea about what could be the problem?

Thank you


(Mike Boland) #7

Can you post a log or parameter file?
I am running the same setup and it took a bit of tweaking with parameters to get it talking.

I am also setting the same on a PH2.1 and it is not wanting to play the game so far and giving me the same results as yourself.


(wk) #8

Hello Mike,

Please have the parameters file attached.

parameters.param (10.1 KB)

Thank you


(Mike Boland) #9

@vag_01 I had a look at your SR1 params and they are quite different.
It was this area I needed to fiddle with to get the connection working.

Here are mine, I am using serial 2 on a PH1 here and it works:

SR2_ADSB,0
SR2_EXTRA1,10
SR2_EXTRA2,10
SR2_EXTRA3,2
SR2_EXT_STAT,2
SR2_PARAMS,10
SR2_POSITION,3
SR2_RAW_CTRL,0
SR2_RAW_SENS,2
SR2_RC_CHAN,2


(wk) #10

Hello Mike,
I tested with your parameters and now it works perfectly :slight_smile:
Many thanks to you!
vag


(Emin Bu) #11

Hello all…
Pixhawk 2 firm.3.5 rc1…success with MX-20 with GR-24 with mboland parameters…all sensors visible!

BUT it does not work with GR-32(latest firm. 4.0.4.)and MX-20(firm.1.207)

Anyone knows what is the difference between two?
As far as i can see only diference;on MX-20 telemetry screen, in GR-24 i can change parameter TEL.RCV between rcv ch1 and rcv ch2…on GR-32 i can not only rcv ch1

Thank You…


(Kay Spranger) #12

Hi,

I am new to this community. My name is Kay and I come from Essen in Germany. I have recently started out flying drones with my Cheerson CX-20 (APM 2.52) and have since really caught the bug.

Since I already used my Graupner MX-20 for model ships, I also installed the Graupner RX into the Cheerson and have started building my own drone with a mini APM 3.1

Now since I have seen telemetry on a friends Taranis I wanted to include this in my Graupner which allows telemetry with ther HoTT technology and quickly found mavlink2hott.

So I bought an APM328P board, installed the firmware and wired it to the APM mini as follows

TX > RXO
+5V > VIN
GND > GND

Then I wired D3 > T on my Graupner GR-12 RX and set the function to “Sensor” in the telemetry menu.

However, I cannot seem to get any telemetry data from the APM.

There is not even a sensor emulation screen. When in the telemetry menu, I cannot select/deselect any sensors.

One thing I am thinking about right as I am writing this is, that I have only connected the telemetry pin to the RX for testing so far. There is no other connection to the APM as of right now. May that be the problem or did I do anything wrong?

Help would be greatly appreciated!

best regards,
Kay


(Mike Boland) #13

Have you set the Telemetry port parameters correctly in the APM?

Not only the baud rate and protocol (MavLink) but also the SR1 parameters.

Are you testing with battery or connected via USB?


(Kay Spranger) #14

Hi Mike,

thank you for your reply.

As of now I seem to be able to communicate with mavlink2hott through my MX-20.

I do not receive any data, however.

What seems to have been the problem with the communication in general was that I had not connected the RX to the GND of the APM mini. After powering it through the APM, I could see the mavlink2hott menues.

However, as I wrote, I do not seem to receive data.

The baud rate seems to be set correctly to 57600.
I do not find SERIAL1_PROTOCOL to set a telemetry protocol. Possibly in miniAPM 3.1 there is no such option?

Here are my parameters:

parameter1.param (5.8 KB)

I think I generally used the ones that you had posted earlier.

Any idea?

best regards
Kay


(Markus Müller) #15

It works for me MX-20 v1.207, GR-16 v6a37, MavLink2Hott firmware v1.4.3.
Downloaded Xloader from here.
Added new line for Mini in ‘devices.txt’ :
Mini(ATmega328);m328p;stk500;57600;
devices.txt (253 Bytes)

Edit:
With the original schematic (Power from Pixhawk to ‘Vcc’ I get fluctuating Rx voltage display.
I get much better results by powering the Arduino from the Rx (Rx on 2s). Red wire goes to ‘RAW’ and NOT to ‘Vcc’ !!! Signal (white / orange) goes to ‘3’ and black/brown to ‘GND’.
Two wires (‘RXI’ and ‘GND’) to Pixhawk.

Thank You


(Mike Boland) #16

You did not say if you are testing with USB connected as power or battery.

In the APM (FW3.2.1) there does not seem to be a protocol selection for serial.
But it is MavLink.


(Kay Spranger) #17

Hi Mike,

no just battery connected. I use FW 3.2.1

Unfortunately still no data.

I have no idea, what else to try.

  • Kay

(Kay Spranger) #18

Just an addition …

The red LED on the arduino is blinking about twice per second. The RX LED is blinking rapidly. The TX LED doesn’t blink at all.

However there must be some data connection, because when I remove the telemetry cable, the set 3000mAh value disappears. It reappears when I plug it back in.

I am going to bed for now :frowning:

  • Kay

(Kay Spranger) #19

Hey Markus,

which FC are you using? APM oder Pixhawk or other?

If APM, could you share your parameters?

Thanks,

  • Kay

(Markus Müller) #20

Pixhawk 1, just used Mike Boland parameters from post #9. Didn’t bother to try any of the other (quite different) parameter sets that are around because those worked.
Maybe you could try some other Mavlink stuff on this port like radio modem telemetry to check if this works.