Manage waypoints only with the radio


which configuration does require in Mission Planner to navigate between the saved way point numbers using by switches/sticks on the radio? I would like to use only the radio to manage way points. For example If I save 10 way points how can I select only the 8th ones or only 4th ones (from home point go only to 8th or 4th)?
I have Frsky Taranis x9 lite, with opentx 2.3.15 and yaapu script on the radio. The communication is through Fport between Mateksys H743 wlite flight controller and R8 Pro receiver, ardurover 4.2.3 running on it.
Anyone able to provide a little guidance?
Thanks in advance.

There is no functionality to do that.
You could use a Lua script to load various Missions stored on the Sd card from a switch. There is an example of that in the Github Lua scripting examples.

I can confirm the switch mission lua works to switch between preloaded missions it was only created very recently, before that there was nothing at all.
You can save a waypoint location with a transmitter switch function, but there isn’t any existing way to create/modify anything to do with missions from the transmitter, that’s what mission planner is for

Dave and Scott,

thank you very much for your reply, understood. However I tried this bait boat which has flight controller (I linked the video below however in Hungarian language), with Flysky Fsi6 transmitter with I6b receiver. For the three position switch programmed Manual mode on the top, “waite” mode in the middle and Auto mode in the down position.
In the “waite” mode using the right stick you can save way points (moove to the right), and navigete between to the each way points from 0-9 (moove up and down), 0 is the home position and 9 pieces more points for the other wherever you want on the lake.
For example when you saved four points you can identify which one you want to go, in Auto mode used the right stick up and down to chose points and move to the left to send to specified point.
On the screen you can check all the informations:

Thank you for taking time.

With standard Ardurover functionality you can save waypoints with a Tx switch but you can’t then navigate to them with a switch. It won’t do what you have described without either added hardware (companion computer) and/or perhaps custom scripting.
It looks like they have their own Autopilot and custom firmware running on the Transmitter too.

thank you again for your reply, it is clear. So I will use mission planner on tablet or on Iphone (if possible) to do that. Which type of telemetry do you recommend me between the gcs and flight controller which has stable connection in 300m (rarely 500m) range? I have not experiance at all.
Thanks in advance

Standard SiK telemetry radios (915 or 433MHz depending on your region) should do it. HolyBro and Mro both make quality units.

1 Like

Hi Dave,

I have bought Holybro V3 433Mhz radio. I followed all the steps in documentation to set up it. I used 4 pins from the radio (5V, Gnd, RX to TX7 and TX to RX7) to connect to Mateksys H743 wlite Telem1 port, but when I connect to Mission Planner it doesnt work. What did I do wrong? I also upload firmware local for both radios. The green lights solid on radios so it should work.

Thanks again for taking time.

Try setting the Serial Port Protocol to MAVlink1 and restart.

I have just tried mavlink 1 and mavlink 2 too still no connection. The green leds are solid both however every 1sec the small reds are blinking wich is next to the green led.

Have you got any idea? Thanks a lot!

You connected to serial 7 right? So change that uart.

no, I connected to serial1 which is UART7 (TX7 and RX7). But now i changed it to the Serial4 (TX3 and RX3), it is not working too. I have also tried “swap” serial options as in this discuss SIK Radio not connecting after changing to Matek H743
He has the same issue but for me still not working…

Right. Try 57600 baud for serial 1.

1 Like

now it works with this 57600 baud. Massive thank you again! :slight_smile:

Cool! Go back to MAVlink2 Protocol and check it.

It is running on Mavlink2 perfectly! Thanks!

Hi Dave, could you please send me that Github link? I could not find it at all unfortunatelly… Thanks a lot in advance

“ There is no functionality to do that.
You could use a Lua script to load various Missions stored on the Sd card from a switch. There is an example of that in the Github Lua scripting examples. “