SIK Radio not connecting after changing to Matek H743

Hello all,

I’m upgrading a copter from RadioLink MiniPix to Matek H743.

The SIk radio was working fine but once installed in the new flight board it doesn’t connect. Put again on the old hardware it is ok.

I have looked at the related params in old and new configuration and they are the same. In the copter it is connected RX -> TX and viceversa on SERIAL1 (RX7-TX7) at 57. baud,

Both radios have green pilot on but red pilot only lights on the GC side. Is this a indication from the FC not sending packets?

Any help much appreciated

Following the SiK radio configuration procedure in Mission Planner, firmware is upgraded and configuration reset to defaults on both ground and remote radios connecting without trouble.

Changed the serial port from SERIAL1 to SERIAL2, as the signal voltage is 3.3V in the first one.

Reading Mavlink documentation seems clear the protocol is not hardware dependant, working on any serial connection. So, why the Matek H743 is not sending signal throught it?

Are SiK radios limited to some hardware as Pixhawk and APM?

Which Matek H743 do you have, there are 3 versions? Not that oit should make any difference but your mention of 3.3V on the port raised the question.

That is the SLIM version

The signal voltage is not 3.3V on Serial 1 it’s just 3.3V tolerant. But anyway you are now connected to Telemetry 2 on Tx1/Rx1 +5 and Gnd and configured on Serial2? Both radios have the same firmware version? 2.0 presumably if you updated them.

That is correct. My knowledge in radio systems and electronics is very limited.

I’m trying some changes in SERIAL2_OPTIONS, with no effect. Ardupilot Firmware is 4.0.5

You shouldn’t need any Options set unless Tx/Rx are reversed. The you can switch them in firmware.

I don’t have one of those boards but I know someone that has the Wing version. I’ll ask if he has telemetry radios.

Thanks a lot Dave.

I don’t know if that radios work usually with this kind of boards

It should work Jorge. I can’t think of reason why it wouldn’t. I’ll be using the Mini version of that board on a new build but I’ll just have a WiFi radio.

I confirmed that there is no general problem with a Sik radio working with these boards as expected. This was how it was connected.
I have connected the Tele-Radio to UART7 Tx7,Rx7,5V,G ArduPilot Telem1

I was struggling to connect telemetry to Matek H743 Slim for couple of hours. And I have simple Rx TX connection without hardware control pins, which worked fine with Pix4. I managed to make it work by enabling “Swap” in Serial1 options (you have to reboot after that). And my wiring is correct Tx to Rx and Rx to Tx. It looks like either the programming or board silkscreen on PCB are incorrect.

1 Like

Grateful friend! These workers seem to have quietly fixed Serial1 , but Serial2 is still the same software error …
I fought for almost 2 days … and if I hadn’t found accidentally your advice and the magical “Swap”, I probably would have thrown this trash in bin… it’s extremely sad

1 Like