Lowrance NMEA 0183 to Cube Orange

I am trying to connect a Lowrance Elite TI2 to my boat project to gather bathometric information. I currently just log all the sonar data to a SD card and then use ReefMaster to create maps. I wanted to be able to get real time depth using NMEA 0183. I have the Lowrance NMEA 0183 connector and can get data on my computer through HyperTerminal (using a serial connector Rx and Gnd going to the Tx and Gnd on the Lowrance cable). With the boat sitting in a filled water trough, the data looks like: $SDDBT,1.5,f,0.4,M,0.2,F*04

The 1.5 is the depth of the water…not sure what the other numbers are. The Lowrance says that the Protocol is RS 422 (no option to change). The Lowrance allows me to change the string – but only to add or subtract information being sent.

I am connecting through Telem2 using the Pin 3 (Rx) and Pin 6 (Gnd) because this worked on the computer. I have also made all the changes to the parameters as described in previous posts:

[SERIAL2_PROTOCOL] = 9 (Rangefinder)

[SERIAL2_BAUD] = 9 (9600 baud)

[RNGFND1_TYPE] = 17 (NMEA)

[RNGFND1_MIN_CM] = 13

[RNGFND1_MAX_CM] = 30000 (i.e. 300m).

[RNGFND1_ORIENT] = 25 (i.e. down) if mounted on a boat

But I continue to get nothing on sonarrange in Status in Mission Planner. Does anyone have any ideas ? Do I need something between the Lowrance output and the Cube Orange? I see that this was tried before by others – but I am not sure of the success they had. I am currently running ArduRover V4.2.0. and Cube Orange. Any help is appreciated.

@RDodds,

I think that RS422 cannot be directly connected to an autopilot’s TTL/Serial port but instead some kind of converter is required. I’ve had a quick google for it but it keeps pulling me towards RS485<->Serial converters … maybe these will work because RS422 and RS485 are quite similar… but I’m not sure.

something like this might work

2 Likes

Thanks for the information. I have ordered a RS422 to TTL interface and will get back with results.

This is what I have found so far about the Cube Orange Serial Ports:
The Telem2 port on the Cube Orange is a “UART (serial port) with HW flow control” UARTs transmit one bit at a time at a specified data rate (i.e. 9600bps, 115200bps, etc.). This method of serial communication is sometimes referred to as TTL serial (transistor-transistor logic).

When the interface comes in I will let you know how it is working. Here is the Test Tank - the boat is anchored to the log to keep it from drifting.
Test Tank

1 Like

Need a bigger log. :).

Great stuff.

I’ll add this to the wiki when/if you get it working 'cuz the Lowrance is a popular brand. Just tell me the model etc and if possible the details on how the pins are connected (or you can do it yourself but it’s tricky the first time you do it so I’m happy to handle it).

hello RDodds, did you happen to get any results? I’m also using a lowrance sonar and would like to see the depth readings in missionplanner.
at the same time i’m trying to feed the ardupilot gps data as a NMEA stream into the lowrance.
at the moment i think i’m stuck at the bit with the rs422/rs232 convertion.

i found out though, that this convertion shouldn’t be too big of a problem. simply because of these two pictures i found.
Lowrance-Elite-5

here you can see that the lowrance sonars seem to accept rs-232 by simply connecting differently.

and here is shown how that works.
Screenshot 2022-07-25 023052

i would love to hear wether you made any progress.

1 Like

Just to tie topics together we’ve got another discussion going on here re how to connect an AP autopilot with a Lowrance sonar. Bathymatric mapping --urgent help--

1 Like

Just to tie topics together we’ve got another discussion going on here re how to connect an AP autopilot with a Lowrance sonar. Bathymatric mapping --urgent help--

Thanks - It looks looks like this problem may be solved. If it is, I will put a link to the complete answer - or post it here to so the thread can be completed.

1 Like

Sorry for the long delay - I had to send the unit back because it stopped showing depth. Turns out it had a software error. Works great now.

So here is the answer!


Use the settings discussed here earlier this year:
[SERIAL2_PROTOCOL] = 9 (Rangefinder)

[SERIAL2_BAUD] = 38 (38400 baud) (or whatever you set the Serial Output on the Elite to)

[RNGFND1_TYPE] = 17 (NMEA)

[RNGFND1_MIN_CM] = 13

[RNGFND1_MAX_CM] = 30000 (i.e. 300m).

[RNGFND1_ORIENT] = 25 (i.e. down) if mounted on a boat

You will have to set up the Serial Output on the Elite to set the serial sentence to just output Depth and make sure the baud rate is the same as your Mission Planner

2 Likes