Large drone for agricultural processing, pid and all

I tried to adjust it in Autotune but it didn’t work.
the drone bowed as expected and then a message appeared about the need to configure it manually. I tried it several times in both althold and stabilized mode
By the way, I don’t understand why it gives me an error on the compass when I took off there was no error, I see it only in the logs

Take a look at my post on how to methodically tune any multicopter. Looks like you skipped the magfit step.

Is it really because of this that it won’t start because the data is being configured? I used to set it up at all about the compass, I didn’t think about the auto-tuning, it went great, it seems like I haven’t flown for a long time and there have been big changes

You need to do some manual tuning before Auto Tune will complete. Try these:
ATC_RAT_PIT_D,0.01 (same for Roll)
ATC_RAT_PIT_I,0.20 (same for Roll)
ATC_RAT_PIT_P,0.20 (same for Roll)

And read this and follow the guidelines Setting Motor Ranges (surely I have directed you to this before)

Then perform 3 flights none of which will be Auto Tune:
Hover flight in AltHold for a minute or so.
Flight to collect data for Magfit. Perform a few figure 8’s with some throttle changes
A flight in whatever mode you want with some significant pitch roll and Yaw movements.

Clearly identify these logs and post a link to them.

Thank you very much, kind person, for these comments, for these comments and for helping me do my work, it’s very difficult for me to read anything now, we have the conditions of the Polar Night and we all walk around like sleepy flies. Yes, I completely forgot about this parameter, I installed it, there were two values 0.17 and 0.2. By the way, I noticed that some parameters were not set immediately. Perhaps this was an error in the flight controller. I had to reboot it, and only the second and third time they began to be installed. Before that, there was a failure error. Perhaps this was due to the fact that I was using USB power and not the main one

The way to never ever forget about something is to follow a checklist with standard procedures:

Do that and you will be fine!

Guys, I was wondering. How can you make sure that the percentage of battery charge in the ardupilot is calculated by voltage, and not by its consumption?

You can’t. Pack voltage is not a good indicator of charge used/left.

I connected the laboratory power supply to my drone and changed the voltage. To my surprise, Mission Planner and qground Control did not issue any warning; the color of the indicator changed in Mission Planner; and nothing happened at all in qrone Control. Why can’t you set it separately for voltage and separately for flow?The main problem is that after rebooting the flight controller, if you need to make several flights, the battery will again show 100%

Have you set these correctly?


EDIT: yes, I looked at your log, it seems fine.
BUT you dont have these set - they are extremely important!


People that believe they can monitor battery voltage or flight time better than the flight controller, and choose when to take appropriate action, are just wrong. We’ve seen it in logs many many times.

I suspect you wont see any change in a ground station unless you try to arm or are already armed - but please set those two actions and retest, let us know if that makes a difference.

If you are sure the current sensor is reasonably accurate then you can also set these:


but for them to be effective you always need to start with a fully charged pack, and dont reboot the flight controller in between flights.
The correct voltage settings are still required when using the mah/capacity levels in case a battery has a bad day or capacity is not as you expect.

Change this too please:

Thank you very much :grin: :grin: :grin:, I’ll watch it tonight


I tried to set up the temperature calibration, but it seems to me that I did something wrong. And by the way, before running this script, I had to tinker for a couple of hours on the Internet in order to find how to fix all the errors and they consisted of the lack of all sorts of different modules and also in the command line the line does not contain large capital letters. They are not copied because of this there was also an error

That temperature compensation did not work. The black temperature curve is not logarithmic

If you continue to struggle with the script for Offline Calibration forget about it and run it live. It’s not complicated and the docs are in the same link. Also, if you didn’t do so already you should review that parameter file you loaded from the tune guide and make sure the parameters are set for your Flight Controller. As with all those parameter files in the guide, and as it’s stated, “edit it with a text editor to meet your needs”.

1 Like

In general, what happened I took off in althold mode, it started to rock, I switched to the stabilized mode and landed, I thought it was the temperature compensation settings, I took a magazine, found it at a construction site that had changed, returned them to their original state and took off again, but in the stabilized mode I tried to turn them on althold mode, but the Drone also swayed after switching to the stabilized control mode, but the Drone also continued to sway. I landed it as soon as I managed to land it, but I didn’t have time to do so, and after swinging, it fell heavily, as a result, the chassis and battery mount were damaged. I hope the glue will help. I’m very upset, it’s not so easy to leave. in order to make a flight I have to travel tens of kilometers and carry it all manually on myself, it’s just a shame that it fell. To be honest, I thought that everything would be fine because after I turned on the auto-tuning last time, it flew very stably, but it was felt that there was a certain adjustment over a wide range I have equipment with a spring-loaded left throttle stick, so when I release the gas it’s very inconvenient, the quadcopter immediately flies up, I’ll glue it for now.

Spring-centered throttle should be good, it is safest for a normal copter.
The copter needs to learn hover thrust in AltHold or Loiter, and you should have this set:
PILOT_THR_BHV,1 (I use 7)

@dkemxr the off line script is better and safer than the on line code in the FW because it allows you the see the quality of the compensation and more importantly it allows you to see if the computer moved during the calibration process and the compensation is hence invalid

Yea, I suppose it is. I have always used the live method to good effect but it makes sense to check the process with the script.

I’m afraid to adjust the pid manually, the drone is very large. During today’s takeoff, before the fall, the drone swayed just before landing, these vibrations were increasing with a frequency of about a couple of hertz.

can my board be calibrated at the factory? is there any point in doing this?