Large drone for agricultural processing, pid and all

Thanks to Shawn the calcs on his spreadsheet are contained in the Initial Tune Parameters screen in MP.

I don’t think it’s a good idea to use some generic ESC for a craft like this. Who makes them?

1 Like

Eagle power , and motors

I also want to ask a question about the PID regulator. It is known that the adjustment of the regulator is done for a specific weight. But it is known that the weight of the drone will change by as much as 10 kg. So maybe set it to 5 kg then it will be closer to both empty and loaded

Adjust the PIDs with the minimal expected take off weight.
Then limit the accelaration parameters when the weight increases. This is explained in the documentation.

please give me the link, I can’t find it

It’s on the Input Shaping Parameters page:
Input Shaping

1 Like

ahhh, thanks! I just didn’t understand the meaning of the message

Hello, I have a question about preventing a lack of battery power when flying on a mission, i.e. we create a mission and the autopilot warns with a message that the mission cannot be completed due to battery consumption?

No, there is no off-line mission time validation. You as a pilot are responsible for doing that manually.

1 Like

Hi all! I finally collected my pepelats)
And tried to fly
first time tried in loiter second alithold and stab
In loiter and alithold there was an overshoot like , a quick swing in different directions with a crash and a flip. deep snow saved me from injury)))
when I turned on stab, it seemed to take off steadily, but it was carried away so quickly that I didn’t even notice how it landed, I was afraid that it would fly into a tree.
I am attaching a video of the start in loiter.
перед настройкой пид все остальное есть.param (16.6 KB)

The first flight must be done in stabalize (almost full manual) mode, and you are responsible for positioning the copter and manually compensate against the wind.

Then use the results of that flight to configure the notch filter.

The second flight can be done in althold.

Only after autotune you can use loiter.

I think you should reset all to default parameters and start over. You have parameters set that don’t make sense. After doing so set the Initial Tune Parameters and then go to the top of this thread and set the parameters I suggested 2 months ago. Then work your way thru the normal tuning process.

Also, that Flight Controller is producing some worrisome errors which you should have seen after reviewing the log yourself and asked about:

1 Like

thank you very much for the answers, I took the pid from this post

0×1000 can be solved by preference but I have new firmware
0×3000 this error is internally related to the imu, gyroscope, these errors did not exist, they could have appeared after the first crash. and what settings do not make sense? Show me examples so I can understand what you’re talking about

Guys, thank you very much for your support and help! My drone flew great yesterday! but for some reason the autotune did not start, but I will deal with this later, but now I am very glad that it took off. It’s an incredible feeling to see how a 25 kg monster hangs in the air without any problems! and I would like to apologize for the Past messages, I was in a hurry and I was very scared that I did not collect such large Drones…

I see you reset to default, good. Never use parameters from another craft for any reason. But you made the same mistake that many have, rushing into Auto Tune before it’s ready to run. Where is your AltHold flight to use for the Notch Filter Configuration? Set these 1st and then make another hover flight to see how well it works:

Then if its stable and there is no output oscillation, which I don’t think there will be, run Magfit to calibrate the compass. Then think about running Auto Tune.

1 Like

Yes, I know and thanks for the tip that it was too early to turn on autotune, I still need to adjust the notch filter, but the throttle position for hovering was set to 0.15. And I haven’t figured out the notch filter yet. Unfortunately, it’s already late for me now and I need to sleep. Tomorrow morning, with a clear head, I will think and understand the documentation.

@Ilya_Smolnikov just do what @dkemxr posted. The parameters he posted are already adapted to you vehicle

1 Like

I tried to adjust it in Autotune but it didn’t work.
the drone bowed as expected and then a message appeared about the need to configure it manually. I tried it several times in both althold and stabilized mode
By the way, I don’t understand why it gives me an error on the compass when I took off there was no error, I see it only in the logs

Take a look at my post on how to methodically tune any multicopter. Looks like you skipped the magfit step.

Is it really because of this that it won’t start because the data is being configured? I used to set it up at all about the compass, I didn’t think about the auto-tuning, it went great, it seems like I haven’t flown for a long time and there have been big changes