Landing gear servos not travelling far enough

I am having difficulty with my tarot retractable landing gear, when I takeoff and retract the landing gear to get it out of the way of the camera it will not go far enough/ operate long enough to go all the way to the top and its looks very wonky. I could flick the switch twice to make it go into full retract mode but then the servos does not operate long/far enough to return to its original position, and if the same “flip twice” method is done from full retract the servos travel to far and would impact my gimbal if I let them. Right now I have them set to a good “down” position so that my equipment fits underneath but it looks so wonky when I go to retract them in flight. Any suggestions?

Provide logs and change the SERVO*_MIN_PWM and SERVO*_MAX_PWM parameters.

Otherwise we can only speculate.

If your using a Tarot Retract controller.
Like this one


Your not using a servo. It’s an electric motor only that drives a screw that lifts or lowers the gear.

The controller works by applying a voltage and current to the motor for a fix period of time. The gear in theory should retract in that time and the motor then jams when the gear hits the limit. The time runs out and the power is cut to the motor.

To lower the gear the reverse happens. A reversed voltage is applied, the motor runs in reverse and extends the gear until such time as the gear is down and again the motor jams when it reaches the limit.

The timer cuts out and then the power is turned off.

If the gear isn’t going all the way up then either it’s jamming…not likely or the timer is running out prematurely. There is no fix for that.
Replace the controller.

Again this assumes your using the Tarot controller I showed above.

Somes notes on the subject.
PWM only come into play on this controller to tell the controller, is it up or down you want or if there is no signal then to go to failsafe and lower the gear.

If you get one gear going up and the other down, reverse the wires on the one that’s wrong

Also if you use a Tarot controller for non-tarot gear you might find them retracting slower then normal due to the voltage being applied to the gear. Tarot gear operate around 7 or 8 volts while other gear might need 12 and so they run slow.

Thank you for the info! I am using that exact controller. It came with the 2 landing gears that I bought from EBay, here’s the exact link: https://www.ebay.com/itm/Tarot-Large-Electric-Retractable-Landing-Gear-90-Degree-TL4N003-for-25MM-Tube-/253087466943?mkcid=16&mkevt=1&_trksid=p2349624.m46890.l6249&mkrid=711-127632-2357-0

The eBay listing has them branded as Tarot so it doesn’t make sense why the seller would supply a controller that is not capable of adequately controlling the motors. I have the controller hooked up to a mauch 5.35V 3a BEC at the moment, but after looking at the standalone tarot controller it seems as though it’s possible to hook it up directly to the PDB as it’s “maximum voltage” is 26V, and since I run a 6S setup the PDB should never have more than that going through it, but let me know your thoughts. Here’s the link to the listing where I got that info: https://m.aliexpress.com/item/32859025936.html?albpd=en32859025936&acnt=708-803-3821&aff_platform=aaf&albpg=1162563038525&netw=u&albcp=9765961330&sk=UneMJZVf&trgt=1162563038525&terminal_id=108680325d1e4403920c952e495d1c84&tmLog=new_Detail&needSmbHouyi=false&albbt=Google_7_shopping&_randl_currency=USD&src=google&crea=en32859025936&_randl_shipto=US&aff_fcid=c008c9ec3fdd4f7f90ccc48a78a367cd-1627924084139-02822-UneMJZVf&gclid=CjwKCAjwr56IBhAvEiwA1fuqGvUIkICiDgxVwH7Gg2oRXk4sERlf54JQpgc9JgGt0pVqKzquM9QwQxoCfmcQAvD_BwE&albag=100795971798&aff_fsk=UneMJZVf&albch=shopping&albagn=888888&isSmbAutoCall=false&aff_trace_key=c008c9ec3fdd4f7f90ccc48a78a367cd-1627924084139-02822-UneMJZVf&device=m&gclsrc=aw.ds

If you have it on 5vdc that won’t work. The gear needs 8 volts to run and so 5vdc the motors will stall and time out.
I run mine off of the 6s buss with no issues.

Cheers

Solved: Directly connected the motor controller to the pdb and that did the trick. Thanks a million!

Glad it worked for you.
Enjoy and be safe…cheers

Hi rickyg32

I am using the same controller which is in the above image shared by you.

The issue with mine is when the landing gears retracts, they don’t stop at its retracted position, they then de-retract for few degree of angles and again gets retracted this happens continuously.

but when they are in complete de-retracted stage they don’t do such kind of jerking.

plz suggest the solution.

Hi yash, which flight controller are you using?

This landing gear controller works on specific type of gear. The gear has a jack screw in it that raises or lowers the gear. The controller when told to raise the gear, it runs the motors in the landing gear for a specific period of time. The theory being that the gear will run till it hits the end of the jack screws travel. The jack screw then binds because it’s at the end of it’s travel (gear up) and eventually the controller times out and the power is turned off. When the controller is told to lower the gear the reverse happens. The controller sends power in a reverse polarity to the motor in the gear and the motor runs till the jack screw again hit’s it’s end stop and binds. The controller eventually times out and turns off.
This is the way this controller works. IF your getting some odd behavior the first thing that comes to mind is whether you have a compatible retract system for this controller.

1 Like

I am using Pixhawk cube black flight controller

The landing gears which we are using are linked below (Tarot X Electronic Landing Gear Retractor TL8X003)
http://www.tarotrc.com/Product/Detail.aspx?Lang=en&Id=a9ed9fa0-d25a-47be-9cbd-230e55f39f1e
While ordering we checked the list of products which are compatible for controller.

Well that is the gear that works with that controller. I use the same gear on a tarot hexa I have. Works well.

So if I understand what your saying. The gear starts the retract sequence and then after it hits the up position it reverses partly. Sounds like this goes back and forth for a bit. IF your using the gear in the image I posted earlier and your supplying it enough power. Then the controller is faulty. These gear are really simple. Power it on till it hits the end of the jack screw then reverse the polarity to run it back. This sounds like it’s either not powered right. Getting a bad pwm or is faulty.

Could potentially be this issue: erratic SBUS Output / jitter reading · Issue #17476 · ArduPilot/ardupilot · GitHub

I have multiple tarot landing gears, some of them work fine using the deault landing gear options and others I have to use RC pass through otherwise I get the jitter issue you mentioned.

yes, you got completely right what I am trying to say. It goes back and forth after it hits the up position

Other thing which I want to know is what is the use of the Debugging interface port provided on the controller is there anyway that by using the debugging port we can rectify the controller issues or something like that

thank you for the time and knowledge you are sharing

Sorry my friend I know nothing about the debug port.
It sounds to me like a faulty controller. Do yo have access to another to test it. It sounds like the controller isn’t timing out correctly.

No for time being I have only that one handy which I can test. I will try to get a new one.

Thank you