Land problem in auto mode

Hello guys, I have a problem. Can you help me?
I have a 250mm quad, I want it to land automatically after the flight is over in auto mode.
However, when auto land, the quad rises constantly when it should go down. If I don’t put it in stabilized mode, it will rise almost 1 km.
This is how I set the land position: I put a standard waypoint and convert it to land. It takes the latitude and longitude parameters, writes 0 at the point where it should land.

My boarding pass is nora+, I am using cuav c-rtk 9p gnss gps. I have installed the latest beta version on Nora card. I have another quad, it has cuav nano and normal GPS on it and land is fine with it. I’m putting the bin file of the last flight below. Thanks in advance for your help.

https://drive.google.com/file/d/1GdLxScQW6L8JULipVVBv5ORkMQD-Ue21/view?usp=drivesdk

There is no beta firmware at this moment. You probably installed mission planner beta software and ArduCopter 4.2.2 firmware.
Please do not confuse the two. Those are two very different things

And post a .bin log file

Ok thanks, but can’t you see the bin file in this link? Otherwise I will update

https://drive.google.com/file/d/1GdLxScQW6L8JULipVVBv5ORkMQD-Ue21/view?usp=drivesdk

You have my attention. This is a serious bug. I can’t see how this is happening at this stage.

Ok, you are running: ArduCopter V4.2.2 (4fcfa4b2)

You seem to be running an analogue rangefinder that isn’t working. What is going on there?

Does this do this every time?

2 Likes

Thanks Leonard for your answer, primarily telemetry I use: cuav wifi telemetry. I tried 3 flights, each time after the auto flights were over, it started to rise while going to the land position. I switched to stabilized mode and landed manually. As I said in the first post, I’m using rtk. I was wondering if this could be an issue with rtk but other auto tasks do as I want them to. There is a detail like this, I don’t know if it gives an idea, but: when determining the tasks, I put a standard waypoint at the end, then I turn this waypoint into a land. It automatically gets the latitude and longitude values. There is only something strange, in the mission planner land mission, there are normally 4 zeros on the left side of the latitude and longitude. After the flight is over, the trailing 0 automatically changes to 1. I did not understand it.

Could you do a test for me where you:

  1. disable your range finder
  2. Do an RTL
  3. Repeat the same mission

I appreciate your help working through this. I may need to load some custom firmware with some debugging on it to work out what is happening here.

2 Likes

Ok, I only need telemetry for rtk’s base station to work. But I will try your suggestions on Monday morning.

1 Like

Hello again Leonard, I tested what you said today. unfortunately nothing has changed. I’ll leave the bin file and screenshot of the tasks below, thanks

https://drive.google.com/drive/folders/1rRRl5ntOBU3PELiy-kl0e4Nr8uHlbxgO?usp=sharing

Hi @Andromeda,

You didn’t disable your rangefinder. Can you do a test with this set:
RNGFND1_TYPE 0

Please reboot your aircraft after making this change.

Can you then do the same auto mission. Then take off again and fly away and then change to RTL mode.

Thanks for your help on this!!

1 Like

Yes I made a mistake, I just unplugged the cable. I’m going to try disabling it completely today. While I’ve found you, please allow me to ask this: How can I land a high-speed quad on a 10 meter high waypoint to another waypoint with the same latitude and longitude and 3 meter height at a lower speed? Yesterday I did this with do_change_speed but the speed didn’t change and the quad almost hit the ground. The speed was also 2000 cm/s. I want to use much higher speed, but if I do that, I may crash.

Sorry, I don’t think I understand what you are trying to do.

Yes, it’s a bit complicated, I’m trying to figure it out myself, if I can’t, I’ll write in detail. I changed the parameter you mentioned and did the same task and unfortunately the quad started to rise again. I used the same brand and model telemetry on another quad. Land worked.

https://drive.google.com/folderview?id=1FyOF0Cj-ler8rayR2D2SX7YrVCJrL_Lu

Sorry @Andromeda for me to work out what is going on here I really need you to do the flights I ask you to do.

This last flight isn’t the same as the first flight where you ended the mission with a land. You are also not manually flying away after the failure and doing an RTL.

Your RTL height is set to 15m so it would be good if you could let the aircraft climb to 30 m before aborting.

Thanks for your help.

Oh yes, I’m going to enter a contest soon. That’s why I’m constantly making changes to missions. Sorry, I didn’t save previous missions. Since my flight area is a bit small, after allowing 30 meters in Rtl mode, if it doesn’t stop at 30 meters and continues to rise, I may miss the control (I checked it very hard on the first try the other day) and any destruction will not work for me. I hope you understand me. Now I can land Manual after automatic tasks and that’s enough for me. But to help you, at worst, after two weeks, after the competition, I will do all you want and that will make me happy. Thank you very much for your patience.

We think we fixed this problem for 4.2.3. The beta of this is coming out over the next couple days. It would be great if you could test using it.

And you really should leave that range finder disabled until you fix it.

Thanks!!

1 Like