Servers by jDrones

Joystick Integration with Mission planner

Hello everyone,
I am trying to integrate Thrust master T- Flight Hotas 4 joystick with mission planner. I see no response for Throttle and Yaw in mission planner. But the joystick works fine when its calibrated with its own calibration tool for windows 10. So I am sure that the joystick is fine and my system has necessary drivers to run them, its just that the mission planner is not accepting inputs for throttle and yaw.
Does Mission Planner support only a few set of joysticks? If yes please let me know what joysticks are compatible? and I prefer using actual joystick over game pads.

Thanks in advance.
Nihal Y.

Mission Planner accept every joystick that are compatible with DirectInput.
Check the “setup USB game controllers” in windows and click properties of your joystick. If you see the given axis in the Test tab, then Mission Planner will see it as well, all you have to do is to figure out how the given axis is named…Some joystick names throttle and yaw axis weirdly.

Thanks for your reply,
As I have mentioned in the earlier post, the joystick is working fine with its configurator and the axis is for throttle and yaw was figured out as Z and Rz axis respectively. The same axis input is accepted by mission planner as I don’t get any response from it.
Auto detect of the stick movements is detected as Rx for every input so auto detect is not working for me.

I just checked it with my Hottas X V2. Mission Planner accepts Z and Rz axis for throttle and yaw, and shows the movement just right in the Jostick setup panel.

  1. What do you mean “it’s configurator” ? I did not installed any software for the joy, it using the internal Win10 drivers.
  2. Are you using the latest (1.70) mission planner ?

By telling it’s configurator I mean the T_Flight Hotas control panel properties which lets you know what axis is for what. The joystick works fine here and that’s how I got to know the axis for different stick inputs.
But the same axis wont give any response in mission planner.

Yes I am on the latest version of the mission planner.

Could you please delete all Mission Planner.log* files from c:\ProgramData\Mission Planner directory then run Mission Planner, go to joystick panel select HoTTAs, and do an auto detect on the trottle. Take care not to move the stick. Then send Mission Planner.log* files alongside with the Documents\Mission Planner\config.xml file for checking…

Here is the link to all the files.
Sorry for the late reply.

Google drive link:
https://drive.google.com/open?id=1uxSlvMNbC-8LxsOm3wLliqd7tHebE27A

Mp logs needed from the C:\ProgramData\Mission Planner directory…

Yes I gave it from there only.

There should be .log files…not tlog and rlog
ProgramData is usually a hidden directory

I think its this.
But i dont know why the dates have changed!
1 01-Jan-80 5-30-00 AM.bin.log (55.9 KB)

still nope, check the hidden directory in c:\ it called ProgramData
There is a Mission Planner dir in it, you find gmapcache and srtm directories there. I need the log from this directory.

I hope its this.

Yes, this is the one. Now all yo have to do is to delete all Mission Planner.log* files from c:\ProgramData\Mission Planner directory then run Mission Planner, go to joystick panel select HoTTAs, and do an auto detect on the throttle. Take care not to move the stick. Then send Mission Planner.log* files

I have got 2 files. I am attaching both of them.
https://drive.google.com/open?id=15SMUS8NlleHtidtk-ePeuLjypX-4Dpgw

Well, it seems that axes are recognized by Mission Planner, but no movement is registered (I assume you moved the throttle).
To make sure that it is not some third party software or windows issue, could you try it on an other windows machine ? (A fresh install is preferred, but not necessarily). Also you don’t have to connect a copter, Joystick settings should work while disconnected.

I made sure that the sticks were not moved. I in fact got the same error message telling, no movement registered.
I have tried it in a different system with the latest version of the Mission planner. But stil no luck.

Oh nice, thanks for letting me know that joystick should work even without connecting a plane or copter.

Is there any way that I get this Hotas 4 up and running?

If it was a system issue the joystick should not have worked even in T_Flight Hotas control panel properties right? Its working there but not in mission planner.

Till now I have tried in 3 different systems including this one but none of them worked.

I’ll compile a small test program with the same libraries that Mission Planner is using to make check easier. Will send it this evening.

1 Like

Sure I will wait for it. Thanks.

Servers by jDrones