Iris+ Pixhawk Solid Red light after boot unable to connect to Mission Planner or QGround control

Hi there,
I am new to Ardupilot and I tried to update the firmware on my iris+ from Mission Planner and Qground control. After the update to the latest version (3.6) it seemed to fail at boot(no startup tone only B/E would flash for a few seconds and go off)I tried a bunch of other stuff like booting it from DFU, changing the SD and almost everything I could find out there. I also tried putting on the PX4 stack from Qground control it started giving me an error tone with a flashing blue light. Finally I followed this link (last post) and loaded ArduCopter-v2 1.px4 from Now I get a start up tone but ends with a double beep and solid red light. I am unable to connect to QGround control it gives me a missing missing SD card error even though I inserted the micro SD card. I tried to format my SD card and also use a new SD card but the error still exits. On Mission planner i get a CHECK BRD_TYPE : px4io not found.
I’ve tried almost everything I was able to find online but I have not succeed yet, Is there anyway I could just get the default firmware for the Iris+?
Any help is appreciated

Thank you,

Good day, just try flash another firmware on your board and while booting press the safety switch.
Just in case you corrupted the bootloader you need a jtag programmer for restore it.
just try flash arducopter_with_bl.hex

Thanks for your reply @Dave84 , it’s so appreciated!

I’m working with Niharika on the Iris – we’ve tried almost all available AC firmware and they seem to upload fine except for the failures upon booting…we did try to reboot with the safety switch pressed, but it did not seem to do anything.
We also tried to update the IO firmware but that seemed to fail as well, typically getting “failed to update”

We did read something about the bootloader and reflashing it but since we were able to upload new firmwares, we thought that was an indication of the bootloader being fine. But we’re gonna try right away.

Thanks for the link! Do we just install this one like any other firmware on MP? I’m not familiar with “jtag programmer” but Google might help.

Thanks again!

@Dave84 Re JTAG programmer, like [this?](ARCELI ST-Link stlink V2 STM8S STM8L STM32 Cortex-M0 Cortex-M3 Swim JTAG SWD Interface Programmer

Is that instead of using the DFU method from the Wiki?

If you want restore the bootloader you need a jtag programmer,
You can use the stlink v2 or a nucleo board, and for flash it you can use the Stm32 link utility.
Just let me know

@Dave84 Thank you for your help. We do not have a stlink v2 but we are going to order would that work? I just installed the Stm32 link utility tool. Do we have to just flash arducopter_with_bl.hex using Stm32 link utility?


better this version of the stlink v2 :

After this you need this bootloader binary file, you can download it from this site :

just choose the pixhawk1.bin

You need to find the correct pin on your board and solder pin headers, you must look for swdio, swclk, gnd and rst

Okay great thank you @Dave84 , We have just placed an order for the stlink v2 but in the mean time we followed this thread @rmackay9
We tried following and loaded the boatloader using DFU, the px4fmuv2 firmware seemed to have downloaded However the device name at the end did not show in the USB bus (“PX4 BL FMU v2.x”) but 0026ac and the product ID 0x0011 shows up. We then tried to upload the APM: Copter V3.5.7 Quad firmware. No lights(except the green pwr lights) come on and it does connect to Mavlink but says Check BRD_TYPE: px4io start failed. Which is the correct arducopter firmware for the iris+ Pixhawk1 quad?

with dfu mode you can do the full reset chip?

you must look for pixhawk1.bin

@Dave84 Im not sure if it does the full rest.
Following we downloaded the px4fmuv2_bl.bin bootloader. I’ll try doing the same with the pixhawk1.bin instead.

I’ll check the program for dfu mode… but if there is the option full reset the chip just do it… it will reset the chip for new installation of the bootloader and firmware. just let me know

@Dave84 I tried uploading the pixhawk1_bl.bin bootloader ( by DFU mode) and the Copter/stable-3.6.1/Pixhawk1 -arducopter.apj firmware but i think it failed to upload because on mission planner when it said wait for the musical tone to complete there was no musical tone. I guess i’ll just do the stlink v2 using Stm32 link utility with the arducopter_with_bl.hex

as last trial you can try with these options… with mission planner just press Ctrl+F whilr the fc is connected and just choose the option Bootloader update or just try to install qgroundcontrol and try…

I suspect that the bootloader thing is a red herring. It’s more likely that there is a hardware issue that is causing the flight controller to not come up correctly. For example an IMU failure would make it unresponsive.

Hi Randy, i need an info and if its possible an advice, as im still running on my mro x2.1 arm F4 the firmware version nuttx 3.6.9 (im using qgroundcontrol) i need know what will be the emprovements about update the it with chibios version 3.6.9

@Dave84, for most users there is little noticeable difference between NuttX and ChibiOS. ChibiOS runs more quickly and efficiently though so the vehicle does fly slightly better. Also the reduced memory and CPU usage means we will be able to pack more features into the software in coming releases.

Thank you for the info you gave me, i will test it and I will report you.

Hi @rmackay9 Is there any way to confirm it could be a hardware issue? If it is a software issue do you suggest anyway we could tackle it ? We got it from someone else so we want to just confirm its a hardware issue before returning it.


@Dave84 We got the STLINK V2 but I am unsure where the swdio, swclk, gnd and rst pins are on the Pixhawk. I have attached a picture of the our pixhawk board. I have marked the FMU Boot pin and the Debug port as per ( ( Could you please help me identify the right pins?


Good day, i send you the correct pinout for jtag/swd connectors