Iris+ Pixhawk Solid Red light after boot unable to connect to Mission Planner or QGround control

Hi @Dave84 I am unable to connect to the STLink tool. I get these errors.

11:32:59 : Disconnected from device.

11:33:02 : Can not connect to target!
Please select “Connect Under Reset” mode from Target->Settings menu and try again.
If you’re trying to connect to a low frequency application , please select a lower SWD Frequency mode from Target->Settings menu.
11:33:12 : No target connected
11:34:01 : STLink USB communication error
11:34:21 : Can not connect to target!
If you’re trying to connect to an STM32W1xx device, please select Normal or HotPlug mode from Target->Settings menu.
If you’re trying to connect to a low frequency application , please select a lower SWD Frequency mode from Target->Settings menu.
11:34:28 : No target connected
11:35:04 : STLink USB communication error

Do you power the pixhawk while the Stlink is connected?

I power it as soon as I connect the ST link

can you send me pls pictures of the wiring

Hi @Dave84 We don’t have connector heads so we are holding the pins. But this is what our connection looks like.
Black - GND
Brown- 3.3V
White - SWDIO
Grey - SWCLK

@Dave84, We are a little confused about the sequence. Are we supposed to power the drone after we connect the STlink to the board? Also, does the FMU Boot pin need to be pulled up to 3.3V? What order should this happen in?
We first connected the fmu boot pin to 3.3 V then connected the ST link pins , then powered the drone and then clicked on Target> connect on the ST link utility tool. It seemed to have connected once . The time it connected the FMU B/E light was a constant red/amber then we clicked on target> program but the connection was lost after a little while.
We tried to follow the steps from here Bootloader restore

@Dave84 We managed to have connected and flashed the

Nothing different happened. The drone still does not play the start up tone and just the power lights come on. On connecting to mission planner it says “Check BRD_TYPE: Failed to upload I/O firmware”

This is the log of the St link utility tool

before flash the firmware, do you have done the full chip erase…, erase all the memory bank 1 and bank 2 and the full memory?
After you flash the firmware in binary just disconnect the stlink, and while press the safety switch power the pixhawk

@Dave84 We just tried that but nothing different happened. Just to confirm, The right firmware to flash is right? Or is it pixhawk1_bl.bin?

:before flash the firmware you must do this:on stlink utility: target option select erase chip, erase Bank1 and Bank2, erase sector (in this option just selcet all).
After this just flash the pixhawk1_bl.bin, you can use also the .hex but try first the binary.

@Dave84 We tried the arducopter_with_bl.hex , it dint work with that. And the ST link utility tool is not accepting the pixhawk1_bl.bin. We are trying the pixhawk1_bl.hex just to see if that works.

@Dave84 We erased everything and were able to flash the pixhawk1_bl.bin. We then put in the Arducopter V3.5.7 Quad firmware from Mission planner. But it’s still giving us the same errors “Check BRD_TYPE: Failed to upload I/O firmware” unfortunately. It may just be a hardware issue as @rmackay9 mentioned . We are just going to send it back. Thank you so much for your help. We learnt alot. We have another iris+ coming in. Hopefully that works good.

did you check the parameter Brd type? when you power the fc you push at the same time the safety switch?
If you press the safety button and power on the Pixhawk. It should load the I/O firmware and you should be good to go

@Dave84 We checked the Brd type. Its by default on Auto detected to PX4. We changed it Pixhawk a while ago but that dint really help. We have been pressing the safety button and powering the Pixhawk while the button is pressed but it does not make a difference. I am not sure if our safety button is broken. Anyway to check that?

Do you check also the bootloader of the io?

No, we only battled with the FMU – would we use the same bootloader bin file for the IO? And the corresponding pins as per your earlier message.
We are frankly not quite sure how they all play together.

for the Io the bootloader is different… but the extension is always .bin
In case you want flash Io the bootloader file is px4io.bin
The Io pads are near the pin headers… swdio… clk… vcc… gnd. Don’t use the same pads of the fmu coz you will flash the Io bootloader on the fmu… of course in case you can recover it
I will do some test with my old pixhawk1

you can find more info in this post

Hi @Dave84 We did with thesafety switch and through the nsh console. That did not seem to work either.

ok… after you press the safety switch do you see no blink red light