I can't do PID tuning of this Hexa

FC is pixhawk4 (Holybro).
The firmware was installed through the Mission planner program.

I have tuned the pid of many drones so far.

But now this Hexa is something different.

Stabilize flight is no problem.

The motor is T motor u8 lite.

This requires 12cell, I didn’t have a battery so I flew with 10cell.

I thought it wouldn’t make a big difference in flight, and in fact Stabilize didn’t have any major issues.

But with Loiter there is a problem.

The feeling of control was very light, but my hexa was unable to hold its position every moment and showed a fluctuating phenomenon.

velxy_p velxy_i I tried other values ​​such as posxy_p other than the velxy_z value, but there was no significant difference.

I have tried increasing the default parameter by 2~30% and looking at it and lowering it.

There was no big difference.

What parameter should I touch in this case?

Looking at the log, it seems certain that overshoot occurs. However, changing the number does not change the flight significantly.


Sounds like a very similar copter to what i was tuning… same motors too, does it have the T motor flame 60amp esc? and what prop size are you running?

Good idea to run these on 12s as well.

And what is the all up weight of the copter?

I was changing the P term on stabilized pitch/roll while flying, i had it set to a rotary knob on my X9D.

right, it is flame 60amp esc
prop is 29inch
total weight is 11.285kg

If you need it, I’ll upload it as a parameter.

thank you

You need to set the initial parameters properly, download this spreadsheet or press Alt A in MissionPlanner

Then with these bigger units there’s no quick/easy way, you need to get involved in some manual tuning
Even print out the pages and work through them, crossing sections out as you go

And you’ll probably need transmitter tuning

Also set a transmitter switch and channel for emergency motor stop

Yep so those 29 inch props are wayyy to big. I would suggest 2880. And those flame esc’s are very unreliable. (Had a tripple esc failure yesterday with them). Your weight is low as well. Try aim for 15-20kg

Agreed you need more weight, we fly AUW around 24kg with a hex and u8 lite and 29" prop combo and out hover throttle is just below 50%, so you’re probably nearer to 25% or less which means you won’t have great control over the craft.

When using a 10-cell battery, my drone couldn’t bear the weight and was dragged by the payload like a pendulum. If I change to 12cell, will it make a difference?
thank you

It shouldn’t do, as the issue with the overshoot is most likely due to a poorly set up, poorly tuned and overpowered copter. Looking at your logs your hover throttle is around 20% (MOT_THST_HOVER 0.199) which means you’re overpowered. You’re also running default pids which aren’t suitable for large copters and is likely the cause of your issues.

You need to make sure you thoroughly follow the instructions as detailed by Shawn a few posts back.

The U8 Lite motors are rated for only 12s, and they are not a sporty motor fyi they are for efficiency. Flying 10s with these bad boys is not a good idea


I just flew a drone.

This is definitely no overshoot compared to yesterday.

Changed from 10cell to 12cell, and changed the parameters.

Please take a look at the log.

Fixed phld_angle parameters.

Overshooting has definitely been reduced, but what values ​​do I need to adjust to get a little more precise flight?

I’ve touched many drones, but this is the first time this has happened.

I’ve touched a lot of the pids of drones bigger than this and have solved the problems, but this doesn’t change no matter how much I touch…

Did you changed the the MOT_BAT_VOLT_MAX and MOT_BAT_VOLT_MIN parameters for 10S ?

Today’s flight was 12cell, and the volt max min based on 12cell was set.
thank you

I am suffering with same issue. Is your problem solved @Ricoman

no. Not resolved at all…

@AmitSingh please:

  1. use the latest ArduCopter 4.1.0-beta 6 (if you can)
  2. make sure you use a calibrated voltage and current monitor
  3. follow the tuning instructions (Alt-A in mission planner)
  4. tune the dynamic notch filter
  5. try autotuning in a calm day without wind, and
  6. post the resulting .bin files in a new forum thread.

Without log files we can not help you.

Is my uploaded blog useless? I’m afraid it crashed once during autotune.

Sorry, @Ricoman I do not have time right now to download, open, and analyze your binary log file.

I hope someone else can help you.

i have created a topic for that here,

you can find my logs in the above link