Servers by jDrones

Huge Octo not disarming on landing ***SOLVED***

Hi,
I follow that topic because I have a serious problem related to disarming with AC3.4.
I’m on it since several days and i begin to go nuts!!!
First I thought it was a refresh rate of GPS Issue, but it seems to not. My copter (huge octo, my loved tool for work since 4 years) does not disarm by itself after touching the ground. I always used auto landing, and it cost me a propeller set the first time I flew with AC3.4.
I Upload a log, you can see I wait for disarming (while still in poshold) for 3-4 seconds, then go back to stabilize to disarm manually. Even withouttaking off, if I engage throttle at 10% for making the props spinning, then go back to throttle down, it does not disarm.

2017-05-15 14-13-30.bin (3.8 MB)

Please could you help me…
Julien from Corvus Monitoring

Are you pulling the throttle down and left on landing?
That is the command to disarm in copter

With auto landing it should do it all by itself when the landing is detected.

Both times, it looks like the copter has only just touched down at the point when you switch to stabilize.

It would be interesting to see what the motors are doing, but this data isn’t in your log.

If this is easily reproducible, can you set your log bitmask to 176126, try landing and post the log again?

Hello, thank you for your answers.
I switch to stab/throttle down immediatly because if I don’t, the props continue to spin, and after 4 or 5 seconds the throttle raise by itself, causing the copter to tip over (I try a new word^^) and breaking 4 props. My thought is that it try to repositionning, and as it is on the ground…

I’ll do another flight today, waiting for the props to accelerate and send the log.

Thanks!!

Hi Julien,
This reply is not going to solve your problem, but, have you considered adding the ‘emergency shutdown-mode’ on one of your Tx switches? At least when you see things going wrong on the ground, you can act by shutting down the copter prior to causing damage to the rig. At least, have this option available until you know that your problem has been solved. Maybe I err on be over cautious, but I have my finger on the ‘kill’ switch on landing, just for ‘in case’. To be honest, I normally use the ‘kill’ switch once the copter has touched down. On the other hand, I haven’t experienced the landing-problem that you have described, for me it works,
but I like the ‘emergency/kill/shutdown’ option.

All the best,
Gerhard

I am getting reports from out operators in the field about this very same behavior! We are running 3.3.3 on an DJI S1000+ with a pixhawk1. Happens right around time 20:54. This is a very very dangerous situation as we have to STAND NEXT TO IT to make sure it does not happen, which is about 1 in 6 landings. No sonar is used currently (it did not seem to help). This appears to be a pressure bubble problem but I can not confirm that. A kill switch is not an available option for us.

80.BIN (3.3 MB)

It doesn’t look like the CTUN parameters are in your log file to check actual output throttle PWM values, but I noticed that there are no land detection messages so there may be something inconsistent in your MOT* parameters. I also noticed that your z vibration levels were fairly high, which may be confusing the land detection logic since it looks at vertical motion as well. https://github.com/ArduPilot/ardupilot/blob/master/ArduCopter/land_detector.cpp#L70

I have some discussion here:
http://discuss.ardupilot.org/t/landing-detection-logic-doesnt-work-for-high-powered-copter-with-kde-motors/14891/3

hi Guys, sorry for the delay, lot of work here!

here is the log, i waited the maximum after landing, you can see the motor speed that raise just before i switch to stab/throttle down.

Still no clear idea of what happen, i did’nt had the time to test with extra foam, will try it soon.
Thanks!!

my log is 40mo, 22 compressed for a maximum size of 4.5

I’ll do one shorter flight, or do you have another solution?
Julien

Finally, here is the log!!

One short flight with autolanding, 176126 on log bitmask, as the previous one i leave the octo in loiter/autoland on the ground, then waited for the motor speed raising to switch to stab.

Thanks for your patience!
Julien2017-05-29 10-33-24.bin (968 KB)

Any suggestion?

Thanks!

I’m not sure if this is causing the problem, but your rangefinder doesn’t seem to be giving good readings:

Try disabling sonar to see if itmakes any difference.

2 Likes

Why is MOT_SPIN_ARM = 0?

Just had a quick look through the land_detector code.

If you have a rangefinder, landing detection only works if the rangefinder is reporting an altitude of less than 2m.

// if we have a healthy rangefinder only allow landing detection below 2 meters
bool rangefinder_check = (!rangefinder_alt_ok() || rangefinder_state.alt_cm_filt.get() < LAND_RANGEFINDER_MIN_ALT_CM);

As your rangefinder is always reporting ~2.7m, the landing detection will never run.

1 Like

Thanks for analyses, i never carry about sonar/rangefinder param since i removed the analog one 2 years ago… I think you gave me the answer, and will confirm that tomorrow, I planned a testing/tuning session. It’s just strange that this issue appeared only with 3.4 upgrade as I didnt changed anything relative to rangefinder since a long time.

For the motor spin, I put 0 to have a static props when landed. As it is high on it’s legs with batteries on top and good power set up, a little thrust+wind could make it fall. With that “no disarm” issue, i’d rather totally stop the props when throttle down/stab mode.

I keep you in touch tomorrow!

Julien

OK, Issue Solved!!!
I’m a bit shamy, because it’s a simple case, my sonar range parameter was on “enabled”, with all relative parameters set. Everything is fine now…

Thank you very much!

2 Likes

The question now is: “why these parameters came back only on 3.4, and get out when I downgraded to 3.3?”

how did you solve it now exactly? i have the same problem with my octo quad X copter.
Thank you in advance!

Hi,
Sorry for the delay…
I just disabled (by unchecking the box) the sonar in missionplanner.

Julien

Servers by jDrones