How to install Arducopter on Matek H743 mini?

Having successfully got Arducopter running on my TRex500 heli using an mRo R15 FC, I’ve decided to go ‘budget’ for my next build, which will be another TRex500 but with a Matek H743 mini…

I’ve been looking at the Ardupilot wiki, at the Matek web site, Github, and at u-tube videos, but I can’t make head nor tail of their instructions. I’m using a PC running fully updated Windows 10 - 64. What I’ve done so far:-

  • I’ve been to the Ardupilot site and downloaded Ardupilot heli 4.2.2 hex file for the Matek H743, and saved it on my desktop (where it’s pretending to be an OpenTX file :unamused:)

  • I’ve downloaded Zagi, though I don’t seem to have ‘installed’ it, for I can’t find it anywhere on my PC. But when I run it from the web it shows the following screen, which I don’t know what to do with::unamused:


  • From the Matek site I’ve installed STM32 Cube Programmer, as instructed, but I can’t figure out what to do with it either :unamused:

Can anyone point me to simple step-by-step instructions for getting Ardupilot onto my Matek H743 board please?

Plug your flight controller into the USB (you may have to put the board in DFU mode by holding the boot button when plugging in USB) in the top right you will see in the blue there in your image it says stlink click the drop down and select usb which should give you an option to select the proper com port

after that hit the browse button next to the device memory and select your firmware then upload the firmware. You can also sometime try betaflight (load custom firmware option then use your ardu firmware) I know people have had luck using that but I was not able to get it to work and also had to use STM32 to get my JHEMCU GSF405A 1S-2S AIO F4 to flash. I am away from my office and will double check the firmware flashing procedure tomorrow morning but thats the general way.

Thank you fuego. That seems to have worked; it erased a bunch of files and then did the download and reported it complete. I guess the next step is to connect to MP and configure the board?

MP on my PC won’t connect it at the moment because it can’t find the correct USB port, so I’ll try again this afternoon on my workshop laptop which I normally use.

Better think this as programming a STM device through USB. See dfu-util.

Acronyms tend to make my eyes glaze over :roll_eyes: I now see, using Google, that “STM” is “Synchronous Transfer Module” and “DFU” stands for “Device Firmware Update”. Presumably my H743 incorporates an STM, and what I’ve just done is a DFU?

The file I just installed is “arducopter.hex” for Matek H743 controller. Will I now be able to update and configure it using MP, as I have done with my Pix controllers?

Unless the H743 comes with AP pre-installed, you have to use FW with bootloader when flashing for the first time: arducopter-heli_with_bl.hex

Ahh, thank you. I used the plain vanilla arducopter-heli.hex file. I’ll use the _bl version and try again.

OK, arducopter-heli_with_bl.hex is now installed, but when I now try to connect it to MP I get the following error message:


When I connect the board to the laptop USB port, while pressing the button next to its USB port, I get the usual “ding-dong” sound confirming the device has been found. So what do I need to do to solve the mavlink issue, please?

once you have uploaded that bl firmware you do not need to hold the button just plug in usb. you no longer need to be in DFU mode

But if I don’t press the button I don’t get the “ding-dong”, and I get the same error message as before when trying to connect to MP.

I’ve tried also with QGC, and it doesn’t recognise that anything’s connected.

what does device manager show with it plugged in not holding the boot button. should be under com ports

As seen here you will get several different opinions on how to flash. I have found the best way is to use dfu-util and flash the bootloader only 1st. Bootloader files found here Bootloaders
After that you can use MP to flash the Ardupilot firmware.

Note: Follow the procedure here for With DFU
Flash bootloader dfu-util

BTW-One reference for this process is @andyp1per Build Blog for the 5" and 7" LR builds.

We’re getting somewhere: Using SMT32CubeProgrammer I reinstalled the _bl version of the Ardupilot 4.2.2 Matek H743 hex file. I realise now that when I did it earlier this afternoon it didn’t really do anything – this time it went through the delete files routine and then installed the new file.

MP still gives the same error message as before, and APMPlanner doesn’t detect any device.
QGC did detect it, and confirmed the board type and firmware correctly (Matek H743 mini, Ardupilot 4.2.2 heli), was able to reinstall the firmware, and was able to read the parameters, but in the Summary tab it gives an error message “QGroundControl does not currently support setup of your vehicle type. If your vehicle is already configured you can still fly”. The board is now showing solid red led, and flashing blue or green at various times, and my laptop now gives the “ding dong” sound when it’s plugged in without pressing the button. Previously it was only showing solid red.

To answer your question fuego, there’s no listing in Device Manager for com ports, but below is a screenshot of the USB portion of the screen. I don’t know which of those devices is the Matek board, but they’re all reported as working correctly when I click on them for details. The only other USB device connected to the laptop is a wireless mouse, so I don’t know why there’s 3 devices showing.

dxemr: Sorry, I didn’t see your latest post until just now because I was too busy composing my own reply to fuego’s post.

I can find the bootloaders using your link – presumably MatekH743_bl.hex is the one I would use. But I’m utterly confused by your DFU link. It implies that dfu_util is a program that will download a bootloader file, and says 0.11 is its current version, so I scroll down the index of releases to 0.11 and see six different files, none of which seem to be an executable program. Since I’ve got STM32CubeProgrammer running, would that be able to install the bootloader file instead?

But, as mentioned in my previous post, it looks like I’ve already got a bootloader installed, as well as Ardupilot 4.2.2 heli. The only problem is MP can’t connect to the Matek board. Is the bootloader in arducopter-heli_with_bl.hex the wrong one, or is MP missing some add-on that would allow it to connect?

Use this version for Windows “” . It runs on a Command Line and as per the wiki you enter dfu-util -a 0 --dfuse-address 0x08000000 -D new-board-bootloader.bin -R of course substituting the bootloader file name you are using.

Thanks, I can find in the list of dfu releases, but what do I do with it? I’ve downloaded it and unzipped it, and I get a folder with three “Application” files – dfu-prefix, dfu-suffix, and dfu-util. Trying to run dfu-util it appears that nothing happens other than the standard Windows message about do I want this program to change things. When I type the “dfu-util …” command into the command line (now called “Powershell” :roll_eyes:) I presume I replace the “new-board-bootloader.bin” bit of your command line example with the full path name for the .bin file I want to use?

P.S. I can’t find a wiki with instructions how to use dfu-util.

I once had a similar issue on a Matek H743 Mini. The board was defective. I replaced it, and everything worked as it should.

Try this;
Unzip the dfu-util files to a directory and put this unzipped BL file in the same directory: (18.8 KB)
Then from the Command prompt navigate to that directory. With the board in DFU mode enter this:
dfu-util -a 0 --dfuse-address 0x08000000 -D MatekH743_bl.hex -R

Thanks guys.

Yuri_Rage, I was beginning to think the same, since QGC can connect enough to confirm that the correct firmware is installed, but it and the other configurators can’t connect to do any configuring.

dkemxr, I’ll give that a go later today, before contacting the vendor about a replacement board.

Even though you can connect, I would try this: When Problems Arise — Copter documentation

Also I would try the latest beta of Mission Planner, just for kicks. It still doesn’t sound to me like the FC really is broken.