How to increase P value (PID) beyond maximum value in Mission Planner

Hello my name is William Walker. I am interested in increasing the P value (PID) beyond the maximum limit in Mission Planner. I am developing a large drone with very heavy arms and the motors are not able to stabilize the vehicle with the Roll P value set to maximum in the Mission Planner flight controller software. Is there any way to increase the P value beyond the 0.8 limit? and if not, is there a way I can get Mission Planner to increase the differential control range of the motors, so I can stabilize my drone? The drone is operating at about 60% servo range and has plenty of headroom for additional control. Thank you.

Generally large machines dont need large values, the large propellers spinning and their inertia makes them much more stable.

can you give more specifics about what your setup is and a log file.

You can set whatever you want in all parameters list, but I don’t advise that without someone checking one of the logs to see if that is what you really need to do.

Here is a link to the unmanned drone I am developing:

It is technically a lifting body tilt rotor triicopter vehicle. To restate the problem:

the vehicle is basically a 200 lb drone with very heavy arms that give it a lot of rotational inertia. 60 lbs of batteries are located on the front of the side panels, 30 lbs on each side. The 1st test had only 2 batteries installed and the other 3 were outside in the ground. The vehicle hovered very well and was very stable. Below is link to see the 1st hover test:

The 2nd flight had all 4 batteries in the vehicle. It hovered well, but it was not as stable.

Similar behavior in the ~1.5 lb 1/6 scale model required the Roll P value to be increased to its maximum limit of 0.8. But the full scale vehicle is much heavier and needed a lot of batteries to make it balance at the correct CG for horizontal flight

The vehicle hovered at about 60% throttle, and Mission Planner shows that the back motor operates at 50% servo range, and the front motors operate at 60% servo range.

Again, I need to find a way to increase the Roll P value of the PID controller beyond its max limit of 0.8. If this is not possible, then perhaps there is a way to increase the differential control range of the motors? If it is not possible in Mission Planner, then maybe this can be done in the ESC software. In front we are using Fatboy 14S/15S 300A ESCs in front and Hacker Q100-5L 10kW 138KV motors with 32x10.7in Mejzlik 2Blade carbon props. In back we are using a 18kW cont/40kW peak 80KV motor with a APD 28S 120V ESC, and 2 of the same props used in front forming a 4 blade prop.

What parameter are you talking about? ATC_RAT_RLL_P ?

Never mind, it’s a VTOL and you posted in Copter.

You can select full parameter tree or full parameter list to the left on the mission planner config screen. That will give you the full list of parameters in which you can set any values you want. It will give you a warning initially but will allow you to set the value outside the recommended range.

I have looked at the parameter tree. But the Roll P value is limited to a maximum value of 0.8, apparently I need more and I have no idea how to get more.

The parameter I am trying to a way to increase is:

It should be in both but would be easier to find in the tree because they are grouped. Look for the Q group

Yes, thank you I found that. But I still need to find a way to increase Roll P beyond its maximum limit of 0.8.

So you’ve entered a larger value and it will ask are you sure. You say yes and then it will enter the value. You then hit write Params. Refresh the params and it should be in there

Yes, I did that. but no larger values than 0.8 for the Roll P mm parameter are not accepted. Apparently 0.8 is the maximum value the parameter can be. Could there be some other parameter limiting this value ,.or is there a parameter to increase motor differentia control range? Or is there another parameter which also effectively increases overall Roll P?

I don’t recall that I’ve ever put the value for that parameter that high but I didn’t think it was limited within the code. There is a derivative term that is probably for quad planes Q_A_RAT_RLL_D. However that is not the same as the P term. This term works on the rate of change of the rate error

I can put in higher, MissionPlanner asks “…are you sure?”
I say Yes and it saves the value.
I write the values to FC, then refresh and the new higher value is still there

Surprisingly this doesn’t work for
At least not in SITL.

I recall a situation like this but don’t remember the parameter. In any case using QGC to make the change worked and then it was persistent in Mission Planner.

Thank you all for your valuable information! I have confirmed what you said and I am now able to enter higher Roll P values via the Full Parameter list. The reason I got confused is that parameter entry via QP Extended tuning, and Standard Parameter windows limits the Roll P to 0.8. But as you said, entry via the Full Parameter list is unlimited. Thank you so much for helping me understand the solution to the problem :slight_smile:

The vehicle is flying much better now with
Roll P = 1.4
Pitch P = 1.0

Both started at P = 0.8 on Jan 10 and caused the vehicle to be wobbly.

Now with high P values the vehicle is much more stable as seen in the latest test yesterday Jan 15:

Thanks again for everyone’s suggestions!

By the way, the foam you see falling off the vehicle is what enables the vehicle to take off. It is just foam sheeting taped to the inside edge of the side panels blocking the initial thrust flow from going under the side panels, which would otherwise create a vacuum and prevent take off. But upon landing the taped panels do not flex as much as the shocks, causing the foam panels to break off. The taped panels was just a quick temporary fix to get the vehicle to take off so we can study the vehicle in flight.

Does anyone have any ideas on a better way to prevent a vacuum from forming in under the side panels due to the thrust going under the side panels?