How To disable Compass

Hi Everyone,

I want to fly without a compass. i got PH2.1 running on arducopter 3.5 rc 11 .

any help will be appreciated

Like this.


Hi Jagger,

I still have bad compass health even when i disable arm check ? any idea

None at all.

But bad compass health is different to wanting to fly without a compass.Changing those parameters will disable all compasses but will not find the fault.

The Pixhawk 2.1 is particularly unhappy about being calibrated indoors.Outside away from all metal is the favoured spot.That may be enough to sort it out.If not try posting a full post about the build hardware,with details of what you’ve tried and including logs.

Allowing the unit to warm up for a few minutes can make a difference apparently (reboot afterwards,outdoors).

thanks again for the replay.
I am using Pixhawk 2.1 with arducopter 3.5.rc1 stable. I want to fly in an area with a high magnetic field. I want to be ready for the worst case scenario to get my drone flying safely without the compass.

Please find the params file bellow.
ones i disable the hardware , i get the error with bad cbad compass health.param (13.3 KB)
ompass health

I think that may be worth a new question all of it’s own.It will certainly need someone more knowledgable than me to suggest a solid set up for that kind of flying.Try something along the lines of

"How can I set up to fly in a high magnetic field with Pixhawk 2.1? "

It’s a good question and I have no idea of the answer.There may be one from the experts.It may need specialised hardware though.