HM-TRP 433Mhz SiK radios

Hi guys,
I have two of these radios.
I know that these are the ones used in 3dr telemetry radios.

Air unit is connected to my Kakute H7 mini UART4 RX and TX pads. Powering it using 3V3 pad.
Ground unit is connected to a standard USB FTDI adapter.
When I try to connect, I do get the button turn “Disconnect” but “Getting Params” window never downloads parameters. (Attached screenshot).

Serial4 setting is also attached.

When I can’t really connect, I tried to update the SiK firmware but that looks impossible (Attached photo).

Is there a way I can make both radios talk with each other?

It is actually downloading params but too slow.

How can this be faster?

You will need to be able to access the configuration page for these radios and check the air speed they are using to transmit data, maybe too slow…

Also, with Ardupilot firmware version are you using? the newest ones (for instance Copter v4.1 and onwards) have FTP, that reduces greatly the overhead of downloading parameters…

Also check the baud rate for your radios, try to work with at least 57600 (and remember to update ardupilot parameters also)

No I can’t connect to the module neither using SiK configuration tool nor HopeRF configuration tool.
I probably need to burn 3dr bootloader.
I did use 57600 baud.

I see… sorry but I do not know how to help you more with this, have never worked with this specific radio.

Hi @ZeusEx,

Yes, you have to burn the Sik-radio boot loader (and the hm-trp-sik-radio-fw) first.
I got some plain vanilla HM-TRP’s with a different (HopeRF) firmware too.

After updating the radio chip to Sik-firmware they where fully compatible with other existing (2nd gen) 3DR-radio’s.

To be able to burn a sik radio boot loader to the chip you need a Silabs prog adapter:

The necessary wiring can be found here.

1 Like

Yes I ordered the Silab debugger.
Did you use this code?
From description I understand that I need linux.
Isn’t there a bootloader software from Silab where I could select the BL and FW?

Hi @ZeusEx

Yes, I build the bin file by myself. I was experimenting with multi-point-firmware too.

You don’t need to compile the boot loader. You can choose the pre-build ones from the official AdruPilot firmware server. The link can be found here:

The instructions how to flash the bootloader can be found on the official Sik-github repo:

Yes, I used Linux (ubuntu). I used the the ec2 tools from ThunderFly. They are the most recent ones I could find and work flawless with newer python. The link can be found here: ec2 tools

Good luck!!

Hi @VRquaeler thank you!
Alright. Once I get the debugger, I will start working on it.

After this module has 3DR firmware, how do you wire it for the sik configurator tool?
3.3V → Vin
RX —> TX
TX —> RX

Do you also connect Config to GND to put in bootloader mode?


Yes, the wiring seems good. Grounding the config wire is needed only in case of forcing to bootloader mode.

I was convinced that when using sik configurator, config pad must be low. (From datasheet) and enable must be always low. Setting high puts it to sleep mode.

Another question, which usb to ttl adapter (cp2102 vs ch340) did you use?
Logically they are similar and later supports higher rate but still was wondering since I couldn’t manage to connect to any configuration tool using my ch340


If I remember correctly, after installing the boot loader only there was no need to ground the config pin. But I could be wrong. I am not really sure about the config pin anymore. It’s some time ago.

have used both, the FTDI and CP21XX adapters successfully.

hi @VRquaeler
I am trying ec2tool for bootloader and firmware.
Could you please write the commands for bootloader and firmware uploading?
I am kind of confused here.

Can’t remember all the the detail’s.
I would start with something like:
./ec2upload bootloader_hm_trp_433.hex

But I can remember that’s necessary to have write permission to the USB-port.
You should try:
sudo ./ec2upload bootloader_hm_trp_433.hex

After the installation of the boot loader you can connect the Sik-radio to MissionPlanner and install the firmware.
No more scary Linux command line action needed. :wink:

PS: The path to your hex file may vary.

Thanks @VRquaeler
I thought I also needed to include usb port and baud rate in the command.
Tomorrow I will work on hardware side and hopefully would be ready to burn bootloader.
I wish AP SiK configurator too could write the bootloader. If the whole process would have been much quicker and easier.

1 Like


Let us know how if you get it working.

1 Like

Bootloader burning was successful.
Like you mentioned, I used

sudo ./ec2upload bootloader_hm_trp_433.hex

Wiki page mentions that using ec2 tool, firmware could be also uploaded and I followed that. I know you suggested to use AP. That was a big mistake I made and I truly regret. This is the command.

sudo ./ec2upload radio_hm_trp.ihx

Firmware uploading was also successful but then all the leds stopped blinking.
Manufacturer says that either I toss the module to garbage or replace the Si1000 chip.
I am going to order some of those standard firmware modules to finish my test.

Better news is that I received some of those modules with 3DR bootloader preburnt. This time I used AP for firmware and this module is now working with AP/SiK configurator tool.

Last week I received some new HM_TRP modules… just wanted to update that knowing my last mistake, this time I was successful.

1 Like

Glad to hear you were able to made it work :+1: :+1:

1 Like