Hexacopter Wind Wobbling

Hey guys hoping someone can help me out.

Testing my hexacopter today in loiter mode, Winds are 10-15 mph pretty strong winds.

My drone in wobbling pretty bad not sure if theres somehting i can do to fix it.

Autotune has been done and flies pretty solid in no wind. Here is my flight log .bin file.

picture of hexa.

The tune isn’t that great. Start by updating to latest Stable V4.1.1. Then run Mission Planners Alt>A tuning plug-in because you do not have some Initial Tuning Parameters set. Clearly you have done some tuning but these may help. Then configure the Dynamic Notch Filter. Then tune again or run Auto Tune.

1 Like

Hey Dave I appreacite you for looking it over.

Thanks for getting back to me, will do.

Yea I did the simple altitude hold tuning.

Little new to Ardupilot, what do you mean by ALT>A tunning plug in?

Connect the FC to Mission Planner and hit the Alt>A keys which will bring up the plug-in with prompts for prop size and battery power. Answer them and the suggested parameters will be produced. Make those changes. For your craft the significant parameters will be the rate filters, the Gyro filter and Motor Thrust scaling. You can drop the INS_ACCEL_FILTER to 10Hz also.

1 Like

ok thank you, will do.

“You can drop the INS_ACCEL_FILTER to 10Hz also.”

Is that what you meant by configure Dynamic Notch Filter.

Again thanks you for the help

No, that is not the notch filter.

Please do:

  1. the Alt-A stuff, as stated above.
  2. read the Tuning Process Instructions — Copter documentation carefuly
  3. Read the Managing Gyro Noise with the Static Notch and Dynamic Harmonic Notch Filters — Copter documentation

Will do Thank you for the help.

Actually if you update Mission Planner to latest Beta (bottom of Help Screen) the plug-in has been merged into the Main Setup page under Frame.

1 Like

Ok , are you speaking for the ALT A tuning plugin?

Yes, this replaces the plug-in with a native Setup Tab. You want to update to the latest MP Beta often anyway to keep of with new features added to Ardupilot.
Can be found here:


hey @dkemxr, went through the gyro noise notch setup.

flying alot better.

im stuck on one part.

INS_HNTCH_REF = hover_thrust * squareroot(min_freq/hover_freq)

how do i calculate from the graph

1.hover thrust
2.min freq

Also which part in the documentation do i go to next after the advanced notch frequency scalling adjustment in throttle based mode.

here is my log if you would like to take a look at it

You could use
1.hover thrust = 0.326
2.min freq = 50
3.hover_freq = 65

If you pull up your FFT graphs you’ll be able to see how I picked those numbers

and you could set

You’ve got some physical yaw bias happening

Motors 1, 3 and 6 are working harder to counteract 2, 4 and 5 (or one of those) - probably motor mounts are twisted on the arms slightly. See if you can fix that, then run another Autotune.

1 Like

Hey Shawn much appreciated for looking over my log. Thank you will try that out.

" You’ve got some physical yaw bias happening"

What do you mean by this?

“Motors 1, 3 and 6 are working harder to counteract 2, 4 and 5 (or one of those) - probably motor mounts are twisted on the arms slightly. See if you can fix that, then run another Autotune.”

Will definitely check the mounts. How can you tell that some motors are working harder from the chart?

See in that graph that the red, blue and purple lines are higher in the RCout PWM scale. If you check the motor order diagrams you’ll see for Hexacopter that 1, 3 and 6 are Counter-Clockwise, and they are working a bit harder that 2, 4 and 5 because one (or more) of the those clockwise motors must be tilted slightly producing thrust that is not exactly vertical. Of course all yaw comes from motor torque, so any misaligned thrust easily interferes with the yaw derived from torque. The extra PWM required to keep yaw under control also detracts from pitch/roll stability, up to a point. Eventually pitch and roll will take priority once yaw has reached it’s preset limit (MOT_YAW_HEADROOM,200) and you will start to lose yaw control then.
This can also make tuning harder and Autotune or manual tuning can never produce ideal results with that physical yaw bias interfering.

1 Like

Hey Shawn thanks so much.

I see now.

So this is what happened and I think might be the problem to that if you could help me out.

Motor 3 esc ripped so I bought the same one and replaced it.

The thing I noticed is that when I arm the drone all propellers start spinning except the single esc that I newly installed.

Until I push up the throttle a little in when that motor 3 starts to also spin.

Not sure if that could be the problem and if you would have any solutions to that.

Now thinking about it also usually noticed the drone would lift off at a slight angle with the right side always being higher.

Do the semi-automatic all-at-once ESC calibration:

And still be sure to get all the motors and props perfectly level!

1 Like

@xfacta @dkemxr Thank you guys for the help.

I did everything autotuned it again and is flying great, although there is no wind today to test in windy conditions.

I will test it out in windy conditions and get back to you guys.

Are there any other parameters i should focus on when running missios in loiter/guided mode?

Also here is my log from today if you guys can give me any tweaks?

Setup battery voltage monitoring. Other than that it looks good!

1 Like

Hey Dave thanks.

Hey guys so tested my drone out in 10 - 12 mph winds.

I got some pretty strong wobble and movement.

The winds slowed down at the end of the flight, so it was alot better at the end.

What can i tweak while i can while the winds are blowing.

Here is my log if you can take a look at it.

Also thank you guys for all the help and taking your time to help.

The drone flies great in liitle to no winds.

then follow through the rest here in order:

Without the voltage monitoring (at least) you are missing out on the advantages of
MOT_BAT_VOLT_* parameters and the battery voltage failsafe parameters.
The current monitoring is also extremely handy for diagnosis and battery capacity monitoring.
It’s virtually mandatory when you’ve got a battery powered device up in the air.

You can set
These wont fix the wobbliness but are just tying off a couple of loose ends.

Make sure all the wiring is cleaned up and not vibrating or flapping around in the prop wash.

Finally you need to run Autotune on each axis, after setting up the voltage and current monitoring. That should clean up the slightly noisy attitude control, and the noisy motor outputs because of the attitude control.

Attitude control

Motor outputs, should probably be a bit cleaner looking, better attitude control should fix this

1 Like