Servers by jDrones

Helo Pixhawk 2.4.8 AltHold Unsteady (Analyze Log File)

(Banjing) #1

Help please on anaylzing this log file. I tried AltHold, it hover in the middle of the throttle but it keeps on moving.

Also, the transmitter stick control using up and down is reverse, when i push up the actual drone is going down, when pushes down it goes up. What seems to be the problem?

(hosein gh) #2

hi @banjing
there is no any useful data in your log because you didn’t fly at the least one minute.
please note that althold mode doesn’t provide position holding but your copter must not drift to much in wide and clam area.
for a good performance in althold mode and other mods like loiter, poshold and … first balance your copter , check propeller balance , motors shaft and then run auto tune.
about your throttle stick you should reverse it from your radio control and if it doesn’t support this operation you can set RC3_REVERSED = 1 from parameters list.

1 Like
(Dave) #3

Before doing anything else why don’t you update the firmware to current stable? The version you are running (3.4.6) is >2yrs old. So you have posted in the wrong thread also.

1 Like
(Banjing) #4

Hi Sir, thank you for your response. Yes the propeller are balance, before i used it balance it using propeller balancer. I dont know what I am missing, it hovers but its moving not steady. How would I run auto tune? Sorry so new to this. Thanks.

(Banjing) #5

Hi Sir, thank you for your response. Yes already updated to the latest firmware, still the same. So sorry im new to this thing, but Im willing to learn and explore.

(Banjing) #6

How can I reverse it in my transmitter? Im using Flysky Fs i6

(hosein gh) #7

I dont have this transmitter but i think its described in user manual
https://www.manualslib.com/manual/1295793/Fly-Sky-Fs-I6x.html?page=16

1 Like
(hosein gh) #8

Here is auto tune instructions
http://ardupilot.org/copter/docs/autotune.html

1 Like
(Banjing) #9

Ive done some research, but my transmitter is only 6 channel how can i set auto tune to CH7 or CH8? :frowning:

(hosein gh) #10

You can set autotune as a flight mode
33695369

1 Like
(Banjing) #11

If I set it as a flight mode will I still be able to control the quad? Because first step now is im controlling it using Radio Transmitter, later on I will use telemetry once stabled and Mission Drone.

Will it still hover on autotune? Wont it fly quickly to the sky once armed? I mean if the throttle still low wont it fly? Because I have this experience, when I armed the drone it automatically fly to the sky :frowning: Very scary.

(hosein gh) #12

I didn’t ever used autotune as a flight mode
But i think it’s althod mode with autotune and you can control your copter in this mode.
And note that you have to take off with stabilize or other modes then change it to autotune.

If you are using sbus encoder you can easily connect your ch 6 receiver to ch 7 encoder input

1 Like
(Banjing) #13

Hi Sir, thanks for the response. Im not using sbus encoder though, im using flysky fs i6 transmitter and fs ia6b receiver. Theres no channel 7 for me to use auto tune not as a flight mode :frowning: How will I do that?

(Shawn) #14

You just pick it as a flight mode on your normal flight mode channel. I suggest something like Stabilise, AltHold,Autotune then later when you’ve done tuning set the Autotune flight mode back to Loiter or whatever you choose.

1 Like
(hosein gh) #15

Just try it as a flight mode and dont worry, its must be control able, all of ardupilot features are tested in beta and will not have problem like this.

Also pay attention to @xfacta post it seems that he used this feature

1 Like
(Banjing) #16

Hi @xfacta thank for you response. My switch is currently configured for Stabilize, AltHold and Loiter. You mean, I configured it to Stabilize, AltHold and AutoTune for me to be able to use AutoTune? If i choose this flight will it night fly continuously to the sky once armed? hehe . Sorry im really new to this.

Also, is it okay to use AutoTune im using 2200mah battery and Pixhawk 2.4.8 clone.

(Banjing) #17

hi @hosein_gh thank you so much for your inputs. I hope I will solved this drifting issue soon huhu

(hosein gh) #18

@banjing if you have 2200mah battery its better to tune every axe separately for example for tuning roll you should set AUTOTUNE_AXES = 1 from parameters list

2 Likes
(Banjing) #19

Hi Sir, how would I do it? Please help. No knowledge how :frowning: Should I remove all the propeller?

(hosein gh) #20

remove props !!! why ?
no you dont need to remove props
as my experience 2200mah battery is low for tuning roll ,pitch and yaw
connect your copter to mission planner and then got to full parameter list and change AUTOTUNE_AXES = 1 for tuning roll after finish charge your battery then connect your copter to mission planner again and change AUTOTUNE_AXES = 2 for pitch and same steps for yaw

please read the auto tune document completely
http://ardupilot.org/copter/docs/autotune.html

2 Likes