Graupner HOTT telemetry doesn't work at all

the wiki says that HOTT telemetry should work in copter “later than 4.0”.
Honestly, i can’t find any code in copter 4.0.3 that would implement HOTT telemetry.

4.0.4dev seems to have such code, but it doesn’t work at all:

I connected my RX (a Gr-16) as shown in the wiki and set the 3 parameters accordingly, but no telemetry data is available on the TX (an MX-20 in my case)

btw the drawing in the wiki is not correct: the telemetry line of the GR-16 is next to the edge of its housing, not the gnd line…

I cannot comment on the HOTT working, as I use the Madhacker MAVlink adapter, but I can confirm that the documentation is wrong.

André, I’m stil using yours😊

Hott Telemetry should be included in Copter-4.0.4 which should start beta testing within the next month. I didn’t write the feature but I’m sure we can get it working once it’s in beta. I’m personally a little reluctant to jump into trying to resolve issues in our development branch but perhaps other developers will.

I’ve updated the wiki page so hopefully that helps the next person know that it’s not supported until Copter-4.0.4.

Thanks for the report

Thx for your answer Randy
The dawing in the wiki is imho very misleading (see my 1st post)

Perhaps someone can tell me, if the code (as it is now) ever worked ???
There are some strange things in that code:
uart -> begin is in the loop section, normally one would expect that in the init routine ?!?
Where is the code that calls the init routine ? …
HOTT is half-duplex (one line). Where is the code, that switches the uart in this mode ??? Will this work with any standard STM32F4 board ?

If you are searching for solution that usually works (arducopter + hott) look here:


http://mediamax.pro/MAVLink2HoTT/

norim, i’m using exactly this firmware since years now and it works very well indeed, but it’s not open source, so i can’t modify it.

Having this integrated in flightcontroller firmware would be much nicer (less wiring , (little) less weight,…)

You have right it will be better to have hott telemetry in source of arducopter.
Please consider also that Graupner is bankrupt.

Graupner (founded 1930 !) was only a distribution branch of South Korean company SH Inc. for the last 7 years (so “Made in Germany” was kind of a joke).
So i think the radios and receivers will be available in future.

Hi Randy,

could you please replace the wrong image in the wiki : https://ardupilot.org/copter/docs/common-hott-telemetry.html?highlight=hott

with this one:
hott-telem-wiring2

1 Like

Markus, the drawing is fine now, but a working code would be even better !

I am neither a developer nor did I make the original image. You complained about the image, but you didn’t provide the solution. I just tried to help a little.

ok, got the code working:

UART 1,2,3,6 have flow control enabled by default, so that must be disabled for Hott telemetry.
Inserting this line in the init routine of AP_Hott_Telem.cpp does the trick:
uart->set_flow_control(AP_HAL::UARTDriver::FLOW_CONTROL_DISABLE);

There are some other minor things that don’t work correct now, but no doubt, this will be resolved until 4.0.4. is released.

Thx a lot to the developer who wrote this library; very nice for Graupner users !

Can you construct a PR?

I’ll wait until 4.0.4 has reached rc status.
I’m quite sure the developers will iron out these small bugs themselves meanwhile.

@fs007,

Thanks very much for the feedback. So it seems like for some reason the auto detection of the flow control didn’t work. I think the flow control can also be disabled by setting BRD_SER1_RTSCTS = 0?

@ultrafuge,

Awesome, thanks very much for the corrected image!

I didn’t know this parameter and i’m afraid many other users don’t know it too. So hardcoding in the driver may be a good idea.
btw: the FrSky telemetry driver does the same ! And in the Hott driver even the baudrate is hardcoded !

@fs007,

Ok, that does seem to make sense. Issue raised here.

In any case, for now I’ve added the parameter to the wiki and update the diagram with the one that @ultrafuge provided. It may not be ideal but at least people should be able to get it working now.

Can someone guide me how to add support for HOTT telemetry to Arducopter 4.03 firmware. I am afraid a little bit of 4.04 dev firmware because it’s not tested. Is that possible to compile official 4.03 firmware with HOTT support for Cube Orange ?

I checked the 4.04 dev from 21.05.2020 firmware. HOTT telemetry works great!