GPS: No GPS with Omnibus f4 pro


I am using the flight controller Omnibus f4 pro for my quadcopter. My current problem is, that my flight controller doesn’t get any data from my GPS sensor (BN-880).

I tested the GPS sensor with an Arduino and with the evaluation software u-center from u-blox and got data of the NMEA protocol:


So the GPS sensor isn’t the problem. Therefore I looked the board connection of the flight controller up: GPS is attached to UART6 (SERIAL3).

My parameter list for Serial 3 looks like this:


However, I don’t understand why I still get the message “GPS: No GPS” in Mission Planner.

Does anyone have an idea, how I can solve my problem?
Thank you in advance :slight_smile:


Melanie -

On Omnibus F4 boards there are serial port/UART complications which can prevent GPS/telemetry/etc from working, particularly if you are using an SBUS receiver. And this is further complicated by the number of variations of F4 board that are available.

Not knowing what type of board you have, I would suggest you read all of the link below, and try the various work arounds. For my part I have an AKK F4 “V3” board and an SBUS receiver and was never able to get telemetry or GPS to work.

Good luck!

Same here, with an Omnibus nano v6. Flashed latest Plane dev 4.1, i can make everything (SBUS, telemetry, compass, etc) working BUT the GPS. Parameters are same of yours (apart speed, which i set to 38). I tried almost everything in params, neither. Before flashing Plane fw, i tried INAV firmware and GPS was working fine (so GPS is ok and wiring too). I’m quite hopeless … i don’t know what to try more.

Have you read the setup page for your board that is linked below?

Note that there appears to be only one UART available (for telem) under the default board configuration. You might want to try BRD_ALT_CONFIG=1, as described.

2 full UARTS + I2C is available in BRD_ALT_CONFIG = 1, using RX3 / TX3 pins as SERIAL4. In default BRD_ALT_CONFIG = 0, RX3 and TX3 pins will default to I2C SDA and SCL respectively.

Good luck!

thanks, i didn’t try to change that param, i’ll give a try.

i tried it, no luck… i’m very puzzled.


You are in good company. Have you checked that you have it wired correctly for Ardupilot? It may differ from what worked with Inav.

Also, this:


Here’s another, this time with a parameter file you can try:

FWIW I have an AKK V3 on which I’ve never got the GPS or telem to work either.