Servers by jDrones

Frsky s.port telemetry on kakute f7

I was wondering if there is a way to use s.port from x4r on kakute f7 aio. I tried to use uart 4 and set it up for frsky s.port, didnt work then i read that it has to be on uart 6, but that has sbus, if i move it the radio is not detected. Is frsky smart port even possible without a hack?

works great

If you run 3.6.x, you need a serial inverter, documented here
Otherwise, you can try 3.7.0-dev from the repository and use SERIAL_OPTIONS to invert your com signal.

1 Like

Ok I have it working but is it then possible to get the telemetry through taranis to pc?
I am already using 3.7 dev.

I am having issues with the Kakute F7 V1.5 (not AIO) pass through telemetry, despite the invert issue no longer being a problem, and looking for some advice.

The interesting thing is that I’m successfully getting both the RX telemetry (not too exciting) AND the GPS telemetry, which indicates to me that the FC is actually passing something through properly. But I’m not getting the other FC telemetry, e.g. battery voltage and current. If I look on the “battery monitor” section of mission planner, I can see the battery voltage and current being updated, indicating that it is being measured and communicated to mission planner over the USB serial connection. But it’s not going back to the taranis.

details:

Arducopter 4.0.5
Mission Planner 1.3.74

TX firmware on Taranis X9D+2019: ACCESS 2.3.10
RX firmware on R-XSR: ACCESS 2.1.0

RX6 <-----> S.BUS
TX6 <-----> S.PORT

SERIAL6_BAUD=57
SERIAL6_OPTIONS=7
SERIAL6_PROTOCOL=10

Tekko32 4-in-1 metal ESCs, with ESC passthrough enabled (and successful) on serial5/uart 7.

My discovered sensors on the taranis include RSSI, RxBt, VFR, and GPS. The first three come direct from the R-XSR RX, but the last one only started working when I configured the serial port for passthrough, so that makes me feel like I almost succeeded.

I have no errors in my logs.

I plug in the battery to test, props removed, to provide sufficient power.

I have not installed the Yaapu LUA yet, I was hoping to discover sensors before adding that extra layer.

Am I missing something obvious? Does the other onboard telemetry have to also be enabled elsewhere in the settings?

Servers by jDrones