Servers by jDrones

Flight mode change failed - GPS fail

I’m using ArduRover 4.0 and unable to set the mode to “Auto” using mission planner. When I try to arm the rover using the transmitter “Arm” switch, mission planner displays the “Failsafe error x1” message. Please see status messages from log below. No idea why the GPS is fail even with gpssatcount = 15.

Vehicletype ArduRover
Firmware Version V4.0.0
Firmware Hash 0e52bafa
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = NA -
Test: Brownout = UNKNOWN - No CTUN log data
Test: Compass = GOOD - mag_field interference within limits (20.02%)
Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: FLT_MODE
Test: GPS = FAIL - Min satellites: 0, Max HDop: 1.39
Test: IMU Mismatch = WARN - Check vibration or accelerometer calibration. (Mismatch: 0.84, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = NA -
Test: NaNs = FAIL - Found NaN in BAT.Curr
Found NaN in BAT.CurrTot
Found NaN in BAT.EnrgTot
Found NaN in STER.LatAcc
Found NaN in POS.RelOriginAlt
Found NaN in THR.Speed
Test: OpticalFlow = FAIL - ‘FLOW_FXSCALER’ not found
Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = UNKNOWN - No CURR log data

We may be able to asses the problem if you post the parameter file.Or a link to the .bin log file…

Dave, please see link to .bin log file. Thanks for your help.

The documentation says that Plane and Copter use EKF, how about rover?

In mission planner, “EKF” is highlighted in RED, so would that be an issue?

Yes, all version of Ardupilot use EKF. You do have a Mission Saved on the FC right? I’m not sure what that error message is. Also, which 2 GPS units do you have?

Yes, the mission is saved on the FC (pixhawk cube). I was able to execute the mission a few times, then I updated to rover 4.0 and changed a few parameters related to the EKF and AHRS (next time I’ll be careful and document what I changed).

The 2 GPS units are Emlid Reach M+ and Here GNSS.

You have probably seen this thread? Not sure it’s applicable. I would reset the EKF parameters to default.

I updated my EKF parameters and recalibrated the compass. But now I get the “Bad Gyro Health” message.

Do I need to calibrate the accelerometer?

So I calibrated the Accelerometer and now it sometimes says “Error velocity variance”. It seems like it needs to be calibrated one more time.

Servers by jDrones