ESC Sync problem with update from 3.6.9 to 3.6.10


I have found this strange problem, when updating to 3.6.10 or 3.6.11.

The drone is equiped with the Cube Black and T-Motor F55A Pro II Brushless ESC 55A 4in1

In the air or on the ground, the motor and ESC run fine in 3.6.9

Video 3.6.9

Without changing any settings, this happens in 3.6.10 or 3.6.11

Video 3.6.10

Does anybody know if some parameters have changes, which we need to adjust?

best regards

What output type are you using? PWM, OneShot, DShot?

I used PWM on this drone.

Thanks for the report. I’ve passed this onto @tridge to see if he has any ideas. I think one thing we changed between 3.6.9 and 3.6.10 was we switched over to use the ChibiOS I/O firmware which is responsible for low level PWM outputs.

This is obviously not a long term solution but I wonder if the ESCs would work better if connected to the “Auxiliary” outputs on the flight controller (assuming it’s a Pixhawk or compatible). These outputs are not from the I/O board but rather straight from the main CPU.

I also wonder if you could check using “latest” (aka “master”, aka “Copter-4.0.0-dev”). This can be loaded from the MP’s Install Firmware screen after first pressing Ctrl-Q. I wouldn’t fly this (although it’s probably safe) but I would really like to know if this sync issue is also in our latest firmware. I don’t see the issue at all myself so it’s likely a combination of a particular set of ESC hardware and the pwm output…

1 Like

You shouldn’t need to. Can you send me a log to take a look at? Ideally a log on 3.6.9 then one on 3.6.11.

Thx for the Feedback, i tested the latest 4.0.0. it is the same as with

The drone is an octocopter, so we use 2x 4in1 ESC with 300kv Motors and cant use the aux outputs.

I will make a flight with the 3.6.9 today and uploads both logfiles.

1 Like

You can find the 2 log files here

I installed the 4.0 RC Version, it now works fine now, thx again for the fix!

1 Like

I installed the latest Version 4.01 RC2 on this drone, unfortunately the ESC Sync problem is back. I tried also the 4.00 and latest dev., same problem.

Does anybody know what exaclty changed between the 4.0 RC Version and this? @rmackay9 @tridge

Hi @Christian81,

The changes between versions are listed in the ReleaseNotes and while some are easy to understand others are not.

I guess because your post that 4.0.0 was working was in Oct, it’s most likely that it was Copter-4.0.0-rc1 that worked for you.

Copter-4.0.1-rc3 will be out soon so I might ask if you can retest with that version although we don’t know of any specific changes that would affect the PWM outputs. If that still doesn’t work for you I might produce a CubeBlack build for you of Copter-4.0.0-rc1 so we can confirm that the issue really was fixed in that version.

Hi @rmackay9,

thank you for the info, I just tested the RC3 Version, it is still there. I checked if I had the Version on my laptop that worked and I did, it was the 4.0.0-rc1


Thanks for confirming that -rc3 does not fix the issue. Could you re-confirm that 4.0.0-rc1 does work? I’ve recompiled -rc1 on my machine and placed a binary here.

P.S. this version is actually not identical to what would have produced but it’s very close and should act the same.

Thank you for the Feedback, I did try a test again with 4.0.0 RC1, last time it was in the bench. This time in the air and the issue did happen. So it was not fixed in this Version, sorry for the mistake. I will check your Version today and let you know.

Ok, txs for doing the test. In the coming days I’ll produce a version of 3.6.9 and 3.6.10 so you can confirm that one has the sync issue and the other doesn’t and then we can narrow down on which change between these two versions caused the issue.


I was wondering if you could provide a log using Copter-4.0.x? We discussed this on the dev call and it seems that 4.0.x has a new IOMC onboard log message that provides information about the IO processor’s health including errors and restarts.

I will also produce those test firmwares for you shortly.


Thank you again for your help! We tried the 4.0RC1 you provided, the problem is still there.

I can send you also a logfile, but it will take 2-3 days.


Sorry to keep asking you to testing various firmwares… but I think there’s a good chance we’ve got to the bottom of this finally so I’m wondering if you can test the binary from Tridge at the bottom of this thread. Here’s a direct link to the CubeBlack binary that has a fix. This is Copter-4.0.2-dev so it hasn’t gone through beta testing so please be careful.

Here is a similar problem I am having on 4.0.1 (Cube PH 2.1)


@Jimmy_Oliver that sounds like a motor timing issue.
I would go through available data on the firmware/motor combination as a first step.
Definitely doesn’t sound like bearings.

1 Like

I dialed back to v3.6.9 and the knocking stopped but I am still going to roll back firmware on ESC’s when KDE decides to get back to me on my service ticket.