Servers by jDrones

EKF2 Yaw Inconsistent

Hi all, I have been experiencing a consistent issue since uploading 4.0 onto my drone. I will perform a flight in which it will fly beautifully. Then, I’ll land the drone, and when I go to take off again, I will receive an EKF2 Yaw Inconsistent by XX degrees error message. I don’t quite understand why this is happening, and it will occasionally go away if I reboot the Pixhawk. Has anyone else experienced this issue? If so, what did you do to fix it? I’m not sure if any ardupilot developers may be able to share their input on why this is occurring and how to fix it. Thanks in advance.

Having the same issue. Only thing to add is the degree measurement changes as the aircraft sits…without movement…ie. 27, 24, 23, 55, etc.

Thanks for the report, any chance of an onboard log? I’d like to try and figure out if it’s the two EKF cores that are disagreeing with each other or if it’s DCM. Fixing or removing the check vs DCM has come up before (see discussion here) so I hope we will get to this in a point release in the near-ish future.

Last 2 flights, 1st was fine, 2nd with the yaw error…

@Bobmarr
I am using 4.0.2 and have the same problem.
Did you solve it?

Sorry, no. My only work around is to reboot after each flight, haven’t found a more elegant solution. I do not get the error with a similar Px4 build, only the older 2.8.4 from somewhere around 2014.

I’m really curious what the problem is… :울음 소리:

Having the same issue, i’m on 4.0.3 Arduplane VTOL.

Same issue even for me, only fix is to reboot…

Could a temporary solution be to set parameter EK2_IMU_MASK or EK3_IMU_MASK to 1 ? (depending on your value of param AHRS_EKF_TYPE)
This way less EKF cores exists, which might reduce inconsistency?

I think this would only work with the EK2/EK3 inconsistent messages, not sure about the DCM message.

Is this all with some particular type of hardware (Flight Controller) , or with any/varied hardware?

@tony_skyfish I’d love to try it. But I’m having another problem right now…

@xfacta I’m using cube black.

Same problem here with brand new drone, cube black, kore carrier boad

Hi Bobmarr,
I’d run the Compass/Motor calibration and this might be fixed. Also upgrade to 4.0.2 if you havent already.

https://ardupilot.org/copter/docs/common-compass-setup-advanced.html#compassmot-compensation-for-interference-from-the-power-wires-escs-and-motors

Hi rk2cy_u,
do you have a log .bin file from your Cube black when this is happening?

Same problem also here with cube black, standard carrier board and external rm3100 compass from drotek

Funny you mentioned that… I have latest version, I’m away right now but it is 4.02 something. Also new install of qgc and mp… but on startup qgc gives an alert message that it needs version 3.3 or up and may behave badly with older versions …it does not say what is supposed to be version 3.3, but my assumption was it is the copter firmware… which is already 4.02…

We’re also having this same issue. It’s been happening on every ~8-10th boot for us. Would more logs help?

We are having the same issue on 4.0.4 Plane VTOL. Updated today at the field and got this message when trying to arm, here2 showed yellow leds. Waited a little less the ten minutes and message went away and compass leds changed to green and we were able to arm.

The Here2 gps does not give me the warm and fuzzies. What GPS module is everybody running? Looking for some other options.

Same problem here with CubeBlack running ArduCoper 4.0.0 or greater with Here 2 GNSS module connected through CAN.

Servers by jDrones