EKF variance error with Pozyx

Hello. I’m having an issue with getting the Pozyx works for the ArduRover.

I’ve followed all the steps in https://ardupilot.org/copter/docs/common-pozyx.html. I don’t need the Z coordinate, so I configure the IndoorLoiter to run 2.5 D positioning.

The global position latitude & longitude data are always 0. It never jump to the BCN_LATITUDE and BCN_LONGITUDE as I expected. Pozyx serial output looks fine though. I’ve also checked the DataFlash Log and all the BCN data looks normal.

I noticed that I always get EKFCHECK-2. Based on what I read, it means there are at least 2 variance errors on the EKF. I initially tried EKF2, then I switched to EKF3, but the result is the same. Here are the logs and parameters:

I am not sure whether the error is caused by wrong parameter settings or hardware setup. FYI, I do not use compass or GPS.

Do you have any suggestions? Thanks.

Hi everyone. I am still stuck with this issue.

I suspect the beacon position somehow does not translate into horizontal position. On the mission planner I saw these two flags on EKF status in red:
velocity_horiz Off
pos_horiz_abs Off

I found some other threads with similar issue, but their solutions does not apply to me.

This thread suggests that the power module for Pixhawk needs to be replaced. But I use Kakute F7 and do not use any power module.

This thread suggests using an older firmware or having better setup (reduce compass interference, more stable GPS). But in my setup I only use Pozyx. No compass and no GPS. And when I tried to build the older firmware, I found that the older firmware does not support Kakute F7.

Can anyone please give me some hints on how to troubleshoot my issue? Really appreciate your help. Thanks.