EKF variance error, GPS lost and status goes from 4 to 1 multiple times during flight

Hi Guys
Today I had a flight test with arducopter v_4.3.0. During flight EKF variance error produced and Copter lost GPS multiple times. In my previous tests also it happened on the ground tests(with version 4.2.0).
What I did:
1- Changed GPS serial port
2- Change GPS module
3- Changed GPS wires and connectors
4- Tested Arducopter some versions

But still have problem. Any idea and help appreciated.
Here is GPS status log during flight.

Hi

What GPS are you using?

I had a similar problem with a Here3 GPS, and was produced because the support screw were to long and too tight… when I release the screw, the GPS start working just fine. May be the screw bend the electronic board inside and bring this kind of problems.

Hope this can help, bye

Thanks for your reply.
I’m using ublox neo-M8N GPS module. In it’s box, the GPS board is not under pressure and I think it’s fine. I also checked while it was open.

Is it placed far away from other electronics?
Does it have a clear unobstructed view of the sky?

@amilcarlucas
Yes I have tried to place it far away from other electronics and placed it on the GPS holder used for copters.
I always test it in football pitch with most clear sky view. It detects 14-15-16 satellites during test.

This is not an ArduCopter firmware issue. This is a GPS signal quality issue. You need to improve the quality of the signal.

Just stick to ArduCopter 4.3.0 version, and move the GPS further away from other electronics, especially USB3.0 cables.

1 Like

@amilcarlucas
So you mean it’s due to interference?
OK, I’ll test tomorrow and give you my test result. I will place GPS more far away from other equipment.
Can GPS power supply cause this issue?

@amilcarlucas
Can I ask another question?

In my tests I get so many “GPS Glitch” and “Logger Stock Thread” errors. Do you know what the problem is?
“GPS Glitch” is due to interference also?

Yes, all those errors come from the GPS receiver, not the Ardupilot firmware.
GPS Glitch are per definition GPS signal errors.
Yes, low power supply voltage can and will also cause issues.

1 Like

Which module? Post a link to the .bin flight log.

Thanks @amilcarlucas
I’ll try with some modification in GPS installation and share the result.
Do you have any idea about the message “Logger Stock Thread”? It also happens occasionally. Should I ask it in another post?

@dkemxr
Hi, I’m using this GPS module.
https://www.alibaba.com/pla/M8N-GPS-APM28-26-Flight-Control_62237278240.html?mark=google_shopping&biz=pla&searchText=drones&product_id=62237278240&language=en&field=UG&src=sem_ggl&from=sem_ggl&cmpgn=18596716467&adgrp=&fditm=&tgt=&locintrst=&locphyscl=2702&mtchtyp=&ntwrk=x&device=c&dvcmdl=&creative=&plcmnt=&plcmntcat=&p1=&p2=&aceid=&position=&localKeyword=&gclid=CjwKCAiA68ebBhB-EiwALVC-Nt8Dk6qHCEfOfDJrLMUD0JsG8uY109tixNHj7VtehlVD4F0C0QepxxoCKKQQAvD_BwE

Here is my flight .bin file: Dropbox - 2022-11-14 13-04-18.bin - Simplify your life

I would say either the GPS module is bad (cheap knock-off possibly) or the connection is bad.

The rule of thumb prescribed by the manufacturers is to position the GPS 10cm away from any device that creates a magnetif field (Motors, Motor wires, Battery wires, ESC ect.). I printed a GPS mask 10 cm long so the diagonal distances in red arrow are more than 10 cm away.

I don’t know if the receiver antenna, VTX antenna and the Telemetry antenna will cause GPS interference but I can’t really do anything about it anymore. Reactions from the experts will be appreciated regarding how I positioned the GPS relative to the other components. If they does cause interference, any recommendations for improvements would be nice.

Disable the VTX and re-test.

Hi
I increased the length of GPS stand and also put an aluminum plate under the GPS (for blocking radiation interference from my radio link and other modules) and tested my quadcopter. The test was good and seems the problem has solved.
Here is the picture of GPS module:

But at my last test, the EKF Variance error and failsafe occurred and the copter went to land mode. I checked the log file for GPS status but it seems OK! lat and lon also seems OK.


How can I check the EKF details and find the main problem?

Another Point: When I was flying the weather was windy little bit, I think when the wind moves the copter, this error occurs. What do you think?

You might need to calibrate the compass after moving that GPS. It looks like an effective change, did you connect that ground plate to 0 volts (ground) ?

1 Like