E-flight converge default file

I’ve created a default parameters file for the E-Flight convergence that I flew on the weekend. This file is actually from Tridge who has also flown it.

This can also be loaded using the Mission Planner’s “Full Parameter List” or “Full Parameter Tree” page (look for a drop-down on the right side, select “EFlight_Convergence” and press “Load Presaved” button. By the way, you may need to load the file twice (or set the Q_ENABLE parameter to “1” before loading the file) in order to make the Q_* parameters visible.

Below are pictures of Tridge’s setup.

My group’s setup was a little different, but like Tridge, we put the flight controller (we used an mRobotics Pixhawk1) on the bottom upside-down. Tridge put his telemetry radio in the vehicle’s nose and then put the GPS taped to the bottom (see pic above) while we chose to put our telemetry ratio on the bottom, and GPS in the nose. Because of the GPS wires, we had to set the COMPASS_ORIENT to “2”.

1 Like

When overwriting with this parameter, Yaw can not be controlled. This is the best parameter file for me.EFlight_test0616_best.param (15.9 KB)

This is a test video. Yaw control shakes with a little overshoot.

1 Like

Hi Do you have the servo connectivity diagram. Im struggling to get mine wire up correctly


1 Like

Flying an Eflite Convergence with ArduPlane 3.8.4. Attempted our first transition from QSTABILIZE to MANUAL today. It did a couple backflips, then transitioned to forward flight. Fortunately we had plenty of altitude. It flew ok otherwise. I think the tail motor is turning off too soon or maybe too quickly. The log shows that Channel 3 output (tail motor) changes much more rapidly in transitioning to plane mode than transitioning back to multicopter mode. Is there a parameter that delays or slows the tail motor shutoff? Parameter file is attached. Convergence2018-02-13.param (16.0 KB)

Hi, I am also making a similar vtol flying wing. Is it possible to do fly into FBWA from QLOITER or QSTABILISE without the pitot tube? I dont have airspeed sensor so I disabled it. When I switch to FBWA, the motors don’t tilt.

This is the test video using px4 firmware, it worked without airspeed sensor. https://www.youtube.com/watch?v=xjXYP6rdP1o . PX4 also supports differential thrust yaw in plane mode but I am facing problem in back transition with the PX4 so I want to try APM.


the airspeed sensor is always optional with ArduPilot. In the flights we’ve done with this vehicle we’ve never used a pitot tube actually.

I tried to look into the parameters. For example if I want to do a transition to FBWA from QHOVER, the front motors tilt slowly but do not fully tilt. I think it is required to have a measurement of airspeed. (I set ARSPD_TYPE=0, as I don’t have an airspeed sensor or pitot tube) .It is also given in the documentation: http://ardupilot.org/plane/docs/quadplane-flying.html#transition. "Once the aircraft reaches an airspeed of ARSPD_FBW_MIN (or Q_ASSIST_SPEED if that is set and is greater than ARSPD_FBW_MIN) the amount of assistance the quad motors provide will decrease over 5 seconds. After that time the aircraft will be flying purely as a fixed wing. " Can you please clarify ?

that’s right, it won’t tilt fully till it reaches speed. It does work without an airspeed sensor though - it uses an airspeed estimate based on GPS speed plus a wind estimate.
To test the full tilt fwd on the ground, use MANUAL mode, or run very fast with the plane :slight_smile:
Cheers, Tridge

Hey guys I have set my convergence up with a full sized Pixhawk and 8xr but no gps… I am having the same problem motors won’t fully tilt and transition. Is it possible to make this work without GPS?

My convergence is flying well in manual, fbwa mode but turns really slowly in automode when flying a mission.

Can anyone advice me on what I can change to increase the rate of turn?


Check parameter Q_ANGLE_MAX. It limits the roll and pitch angles in VTOL modes (value is in centidegrees so 4500 is 45 degrees). Also check LIM_ROLL_CD which sets the max roll angle in FW modes.

1 Like

I’m building a bigger size like convergence and Id like to know if the firmware will work with an upscaled version? Can someone point me to the exact download with link so I can have easy access when I get the pixhak4?

Email me @ flyingwoodchuck51@gmail.com than you

Hello all. I just finished the conversion and I seem to have yaw issues. It wags in hover mode. Anyone else has this issue and if so what should I change. I did do some updates, I replaced the tilt servos with digital higher torque and also the eleven servos. the ESC is also replaced with normal 30amp Turnigy Red with the old original simonK on them. All seems good so far minus the yaw issues.