Servers by jDrones

E-flight converge default file

vtol
eflight-convergence

(rmackay9) #1

I’ve created a default parameters file for the E-Flight convergence that I flew on the weekend. This file is actually from Tridge who has also flown it.

This can also be loaded using the Mission Planner’s “Full Parameter List” or “Full Parameter Tree” page (look for a drop-down on the right side, select “EFlight_Convergence” and press “Load Presaved” button. By the way, you may need to load the file twice (or set the Q_ENABLE parameter to “1” before loading the file) in order to make the Q_* parameters visible.

Below are pictures of Tridge’s setup.



My group’s setup was a little different, but like Tridge, we put the flight controller (we used an mRobotics Pixhawk1) on the bottom upside-down. Tridge put his telemetry radio in the vehicle’s nose and then put the GPS taped to the bottom (see pic above) while we chose to put our telemetry ratio on the bottom, and GPS in the nose. Because of the GPS wires, we had to set the COMPASS_ORIENT to “2”.


E-Flite Convergence with PixRacer and SBUS output
(TsuyoshiKawamura) #2

When overwriting with this parameter, Yaw can not be controlled. This is the best parameter file for me.EFlight_test0616_best.param (15.9 KB)

This is a test video. Yaw control shakes with a little overshoot.


(David) #3

Hi Do you have the servo connectivity diagram. Im struggling to get mine wire up correctly

David


(John) #4

Flying an Eflite Convergence with ArduPlane 3.8.4. Attempted our first transition from QSTABILIZE to MANUAL today. It did a couple backflips, then transitioned to forward flight. Fortunately we had plenty of altitude. It flew ok otherwise. I think the tail motor is turning off too soon or maybe too quickly. The log shows that Channel 3 output (tail motor) changes much more rapidly in transitioning to plane mode than transitioning back to multicopter mode. Is there a parameter that delays or slows the tail motor shutoff? Parameter file is attached. Convergence2018-02-13.param (16.0 KB)


(Joydeep Bhowmik) #5

Hi, I am also making a similar vtol flying wing. Is it possible to do fly into FBWA from QLOITER or QSTABILISE without the pitot tube? I dont have airspeed sensor so I disabled it. When I switch to FBWA, the motors don’t tilt.

This is the test video using px4 firmware, it worked without airspeed sensor. https://www.youtube.com/watch?v=xjXYP6rdP1o . PX4 also supports differential thrust yaw in plane mode but I am facing problem in back transition with the PX4 so I want to try APM.


(rmackay9) #6

Joydeep,

the airspeed sensor is always optional with ArduPilot. In the flights we’ve done with this vehicle we’ve never used a pitot tube actually.


(Joydeep Bhowmik) #7

I tried to look into the parameters. For example if I want to do a transition to FBWA from QHOVER, the front motors tilt slowly but do not fully tilt. I think it is required to have a measurement of airspeed. (I set ARSPD_TYPE=0, as I don’t have an airspeed sensor or pitot tube) .It is also given in the documentation: http://ardupilot.org/plane/docs/quadplane-flying.html#transition. "Once the aircraft reaches an airspeed of ARSPD_FBW_MIN (or Q_ASSIST_SPEED if that is set and is greater than ARSPD_FBW_MIN) the amount of assistance the quad motors provide will decrease over 5 seconds. After that time the aircraft will be flying purely as a fixed wing. " Can you please clarify ?